mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH] mfd: tps6586x: correct device name of the regulator cell
@ 2013-06-10 20:06 Marc Dietrich
  2013-06-10 20:12 ` Stephen Warren
  2013-06-11 12:00 ` [PATCH v2] " Mark Brown
  0 siblings, 2 replies; 3+ messages in thread
From: Marc Dietrich @ 2013-06-10 20:06 UTC (permalink / raw)
  To: linux-kernel; +Cc: Samuel Ortiz, Mark Brown, Stephen Warren, linux-tegra

Change the device name of the regulator function to the one chosed for
MODULE_ALIAS. This fixes kernel module loading for the regulator function.
Also change the name of the platform driver to make everything consistent.

Signed-off-by: Marc Dietrich <marvin24@gmx.de>
---
I don't think this "fix" can still go into 3.10, but I would love to see
it there because otherwise many distro kernels supporting tegra2 would have
to force load the driver.

 drivers/mfd/tps6586x.c                 |    2 +-
 drivers/regulator/tps6586x-regulator.c |    2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/mfd/tps6586x.c b/drivers/mfd/tps6586x.c
index 721b918..4b93ed4 100644
--- a/drivers/mfd/tps6586x.c
+++ b/drivers/mfd/tps6586x.c
@@ -107,7 +107,7 @@ static struct mfd_cell tps6586x_cell[] = {
 		.name = "tps6586x-gpio",
 	},
 	{
-		.name = "tps6586x-pmic",
+		.name = "tps6586x-regulator",
 	},
 	{
 		.name = "tps6586x-rtc",
diff --git a/drivers/regulator/tps6586x-regulator.c b/drivers/regulator/tps6586x-regulator.c
index d8fa37d..2c9155b 100644
--- a/drivers/regulator/tps6586x-regulator.c
+++ b/drivers/regulator/tps6586x-regulator.c
@@ -439,7 +439,7 @@ static int tps6586x_regulator_remove(struct platform_device *pdev)
 
 static struct platform_driver tps6586x_regulator_driver = {
 	.driver	= {
-		.name	= "tps6586x-pmic",
+		.name	= "tps6586x-regulator",
 		.owner	= THIS_MODULE,
 	},
 	.probe		= tps6586x_regulator_probe,
-- 
1.7.9.5

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2013-06-11 12:00 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2013-06-10 20:06 [PATCH] mfd: tps6586x: correct device name of the regulator cell Marc Dietrich
2013-06-10 20:12 ` Stephen Warren
2013-06-11 12:00 ` [PATCH v2] " Mark Brown

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome