mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Steve French" <smfrench@gmail.com>
To: "Greg KH" <gregkh@suse.de>
Cc: "Randy Dunlap" <randy.dunlap@oracle.com>,
	"Stephen Rothwell" <sfr@canb.auug.org.au>,
	linux-next@vger.kernel.org, LKML <linux-kernel@vger.kernel.org>,
	sfrench@samba.org
Subject: Re: linux-next: Tree for January 12 (cifs vs. staging)
Date: Mon, 12 Jan 2009 14:40:21 -0600	[thread overview]
Message-ID: <524f69650901121240v7bd019a8scc4a41823d308725@mail.gmail.com> (raw)
In-Reply-To: <20090112202136.GA8854@suse.de>

On Mon, Jan 12, 2009 at 2:21 PM, Greg KH <gregkh@suse.de> wrote:
> On Mon, Jan 12, 2009 at 02:13:29PM -0600, Steve French wrote:
>> On Mon, Jan 12, 2009 at 1:32 PM, Greg KH <gregkh@suse.de> wrote:
>> > On Mon, Jan 12, 2009 at 01:23:07PM -0600, Steve French wrote:
>> >> Is there some magic compile option alternative (other than renaming
>> >> the function, which may be ok, since others probably don't depend on
>> >> it)?  MD5Init is used outside fs/cifs/md5.c so can't be static
>> >
>> > No, you should rename it to cifs_md5init to show that it is only for the
>> > cifs module to use.  Try not to polute the global namespace with generic
>> > function names.
>>
>> Looks like cifs has the following related functions which I can rename
>> if that makes it easier:
>> 001a2e9 R_386_PC32        MD5Final
>> 0001a302 R_386_PC32        MD5Update
>> 0001a38c R_386_PC32        MD5Init
>> 0001a39f R_386_PC32        MD5Update
>
> That would make life easier for you as well :)
>
>> Any others that I missed ...
>
> Not that I see at the moment, but you might want to look at all of your
> global symbol names to make sure they start with "cifs_".

I had gone through the cifs.ko module's namespace a few times years
ago to make sure that most of the names were unlikely to cause
problems, but it is a moving target (functions get added and static
ones get moved etc. over time), and keeping functions names reasonably
short but still descriptive can be helpful (as long as they are likely
to be unique).   Looking at it now, the vast majority have something
smb/cifs specific in the function name (e.g. cifs or SMB or less
commonly: lanman or trans2 or ntlm etc. which are also likely to be
unique)


-- 
Thanks,

Steve

  reply	other threads:[~2009-01-12 20:40 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2009-01-12  4:45 linux-next: Tree for January 12 Stephen Rothwell
2009-01-12 18:19 ` linux-next: Tree for January 12 (cifs vs. staging) Randy Dunlap
2009-01-12 18:58   ` Steve French
2009-01-12 19:13     ` Greg KH
2009-01-12 19:23       ` Steve French
2009-01-12 19:32         ` Greg KH
2009-01-12 20:13           ` Steve French
2009-01-12 20:21             ` Greg KH
2009-01-12 20:40               ` Steve French [this message]
2009-01-12 21:07       ` Steve French
2009-01-13  2:01         ` Valdis.Kletnieks
2009-01-13  2:27           ` Dave Kleikamp
2009-01-13  2:35             ` Valdis.Kletnieks
2009-01-12 19:19     ` Dave Kleikamp
2009-01-12 19:23       ` Greg KH
2009-01-12 19:35       ` Steve French
2009-01-12 18:50 ` [PATCH -next] libfc: needs CRC32 Randy Dunlap
2009-01-13  0:05   ` Love, Robert W
2009-01-12 18:53 ` [PATCH -next] scsi_debug: needs CRC_T10DIF Randy Dunlap
2009-01-13  3:26   ` Martin K. Petersen
2009-01-12 19:08 ` linux-next: Tree for January 12 (afs/fscache) Randy Dunlap
2009-01-13  6:35 linux-next: Tree for January 12 (cifs vs. staging) Herbert Xu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=524f69650901121240v7bd019a8scc4a41823d308725@mail.gmail.com \
    --to=smfrench@gmail.com \
    --cc=gregkh@suse.de \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-next@vger.kernel.org \
    --cc=randy.dunlap@oracle.com \
    --cc=sfr@canb.auug.org.au \
    --cc=sfrench@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®