* Re: [PATCH] mtd: phram: Make phram 64-bit compatible [not found] <524C4CF5.7060601@nsn.com> @ 2013-10-07 17:49 ` Brian Norris 2013-10-07 16:53 ` Jörn Engel 2013-10-08 7:46 ` Alexander Sverdlin 0 siblings, 2 replies; 4+ messages in thread From: Brian Norris @ 2013-10-07 17:49 UTC (permalink / raw) To: Alexander Sverdlin; +Cc: linux-mtd, Joern Engel, David Woodhouse, Linux Kernel + LKML On Wed, Oct 02, 2013 at 06:42:29PM +0200, Alexander Sverdlin wrote: > mtd: phram: Make phram 64-bit compatible > > phram was 32-bit limited by design. Machines are growing up, but phram > module is still useful. Update it. The patch is bigger than minimum, > because simple_strtoul() is obsolete. > > Tested on MIPS64 and compile-tested for PPC (32 bit). > > Signed-off-by: Alexander Sverdlin <alexander.sverdlin@nsn.com> Pushed to l2-mtd.git. Thanks! Can this driver use the library memparse() function instead of open-coding it? [To answer myself:] I noticed this in drivers/mtd/devices/phram.c, which prevents us from using memparse(): /* By dwmw2 editorial decree, "ki", "Mi" or "Gi" are to be used. */ Are we (MTD) holding a revolutionary position against the standard kernel libraries, which recognize [KkMmGg] prefixes, but not [kMG]i prefixes? Should we extend memparse() to accept either form? Or would doing so simply pollute the library and not really satisfy anyone? [After more research:] It looks like this topic may be the subject of some long-past flame wars. If I am digging up past demons, then I'd prefer to let sleeping Balrogs lie. Brian ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] mtd: phram: Make phram 64-bit compatible 2013-10-07 17:49 ` [PATCH] mtd: phram: Make phram 64-bit compatible Brian Norris @ 2013-10-07 16:53 ` Jörn Engel 2013-10-08 16:36 ` Geert Uytterhoeven 2013-10-08 7:46 ` Alexander Sverdlin 1 sibling, 1 reply; 4+ messages in thread From: Jörn Engel @ 2013-10-07 16:53 UTC (permalink / raw) To: Brian Norris Cc: Alexander Sverdlin, linux-mtd, Joern Engel, David Woodhouse, Linux Kernel On Mon, 7 October 2013 10:49:43 -0700, Brian Norris wrote: > > [After more research:] It looks like this topic may be the subject of > some long-past flame wars. If I am digging up past demons, then I'd > prefer to let sleeping Balrogs lie. Most of the time it is obvious from context whether you want base-1000 or base-1024 numbers. So in the common case the extra letter is plain annoying. In less common cases it matters a lot and lack of the extra letter is rather irritating. One possible solution would be to have three suffixes. Ki for base-1024, Kd for base-1000 and K for "I don't care, you decide for me". But I am sure that would simply cause another round of flamewars. It is not a hard technical problem. As a result, noone on this list has the required expertise to solve it. Jörn -- Money can buy bandwidth, but latency is forever. -- John R. Mashey ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] mtd: phram: Make phram 64-bit compatible 2013-10-07 16:53 ` Jörn Engel @ 2013-10-08 16:36 ` Geert Uytterhoeven 0 siblings, 0 replies; 4+ messages in thread From: Geert Uytterhoeven @ 2013-10-08 16:36 UTC (permalink / raw) To: Jörn Engel Cc: Brian Norris, Alexander Sverdlin, MTD Maling List, Joern Engel, David Woodhouse, Linux Kernel On Mon, Oct 7, 2013 at 6:53 PM, Jörn Engel <joern@logfs.org> wrote: > One possible solution would be to have three suffixes. Ki for > base-1024, Kd for base-1000 and K for "I don't care, you decide for > me". But I am sure that would simply cause another round of > flamewars. Indeed. Why deviate from SI with "Kd" (a new invention)?? That should just be "k". Gr{oetje,eeting}s, Geert -- Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- geert@linux-m68k.org In personal conversations with technical people, I call myself a hacker. But when I'm talking to journalists I just say "programmer" or something like that. -- Linus Torvalds ^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] mtd: phram: Make phram 64-bit compatible 2013-10-07 17:49 ` [PATCH] mtd: phram: Make phram 64-bit compatible Brian Norris 2013-10-07 16:53 ` Jörn Engel @ 2013-10-08 7:46 ` Alexander Sverdlin 1 sibling, 0 replies; 4+ messages in thread From: Alexander Sverdlin @ 2013-10-08 7:46 UTC (permalink / raw) To: ext Brian Norris; +Cc: linux-mtd, Joern Engel, David Woodhouse, Linux Kernel Hi! On 10/07/2013 07:49 PM, ext Brian Norris wrote: > Are we (MTD) holding a revolutionary position against the standard > kernel libraries, which recognize [KkMmGg] prefixes, but not [kMG]i > prefixes? Should we extend memparse() to accept either form? Or would > doing so simply pollute the library and not really satisfy anyone? I was also irritated re-inventing the wheel here, but the problem is -- millions of people out there have their startup scripts and uboot environments for phram, who expect this just to work with the next kernel upgrade... -- Best regards, Alexander Sverdlin. ^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2013-10-08 16:36 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
[not found] <524C4CF5.7060601@nsn.com>
2013-10-07 17:49 ` [PATCH] mtd: phram: Make phram 64-bit compatible Brian Norris
2013-10-07 16:53 ` Jörn Engel
2013-10-08 16:36 ` Geert Uytterhoeven
2013-10-08 7:46 ` Alexander Sverdlin
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox
Powered by JetHome