From: Joe Damato <ice799@gmail.com>
To: linux-x86_64@vger.kernel.org, linux-newbie@vger.kernel.org,
kernel-janitors@vger.kernel.org, linux-kernel@vger.kernel.org
Cc: Joe Damato <ice799@gmail.com>
Subject: [PATCH 01/12] x86: Cleanup x86 descriptors, remove a/b fields from structs
Date: Fri, 24 Oct 2008 20:15:21 -0700 [thread overview]
Message-ID: <52f8491fb5d55c0171840b01638ea6db0a98f3be.1224903712.git.ice799@gmail.com> (raw)
In-Reply-To: <1224904532-9586-1-git-send-email-ice799@gmail.com>
Split the single descriptor struct into an IDT struct and a struct for ldt/gdt/tss. This was done because the fields in IDTs are not the same or in the same order as ldt/gdt/tss descriptors. More meaningful field names were added and the a/b fields were removed.
Signed-off-by: Joe Damato <ice799@gmail.com>
---
include/asm-x86/desc_defs.h | 32 +++++++++++++-------------------
1 files changed, 13 insertions(+), 19 deletions(-)
diff --git a/include/asm-x86/desc_defs.h b/include/asm-x86/desc_defs.h
index b881db6..68abda4 100644
--- a/include/asm-x86/desc_defs.h
+++ b/include/asm-x86/desc_defs.h
@@ -11,27 +11,21 @@
#include <linux/types.h>
-/*
- * FIXME: Acessing the desc_struct through its fields is more elegant,
- * and should be the one valid thing to do. However, a lot of open code
- * still touches the a and b acessors, and doing this allow us to do it
- * incrementally. We keep the signature as a struct, rather than an union,
- * so we can get rid of it transparently in the future -- glommer
- */
+/* 8 byte idt gate descriptor */
+struct gate_struct {
+ u16 base0;
+ u16 seg_sel;
+ u8 reserved;
+ unsigned type: 4, zero: 1, dpl: 2, p: 1;
+ u16 base1;
+} __attribute__((packed));
+
/* 8 byte segment descriptor */
struct desc_struct {
- union {
- struct {
- unsigned int a;
- unsigned int b;
- };
- struct {
- u16 limit0;
- u16 base0;
- unsigned base1: 8, type: 4, s: 1, dpl: 2, p: 1;
- unsigned limit: 4, avl: 1, l: 1, d: 1, g: 1, base2: 8;
- };
- };
+ u16 limit0;
+ u16 base0;
+ unsigned base1: 8, type: 4, s: 1, dpl: 2, p: 1;
+ unsigned limit: 4, avl: 1, l: 1, d: 1, g: 1, base2: 8;
} __attribute__((packed));
enum {
--
1.5.4.3
next prev parent reply other threads:[~2008-10-25 3:30 UTC|newest]
Thread overview: 25+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-10-25 3:15 [PATCH 00/12] x86: Cleanup idt, gdt/ldt/tss structs Joe Damato
2008-10-25 3:15 ` Joe Damato [this message]
2008-10-25 3:15 ` [PATCH 02/12] x86: Use new gate_struct for gate_desc Joe Damato
2008-10-25 3:15 ` [PATCH 03/12] x86: Cleanup usage of struct desc_struct Joe Damato
2008-10-25 3:15 ` [PATCH 04/12] x86: Add macros for gate_desc Joe Damato
2008-10-25 3:15 ` [PATCH 05/12] x86: Refactor pack_gate " Joe Damato
2008-10-25 3:15 ` [PATCH 06/12] x86: Refactor pack_descriptor Joe Damato
2008-10-25 3:15 ` [PATCH 07/12] x86: Add a static initializer for IDTs Joe Damato
2008-10-25 3:15 ` [PATCH 08/12] x86: Use static intializer for IDT entries Joe Damato
2008-10-25 3:15 ` [PATCH 09/12] x86: Add static initiazlier for descriptors Joe Damato
2008-10-25 3:15 ` [PATCH 10/12] x86: Use static initializers " Joe Damato
2008-10-25 3:15 ` [PATCH 11/12] x86: Use macros for getting/setting descriptors Joe Damato
2008-10-25 3:15 ` [PATCH 12/12] x86: Use struct fields instead of bitmasks Joe Damato
2008-10-29 12:56 ` Jeremy Fitzhardinge
2008-10-29 12:58 ` [PATCH 09/12] x86: Add static initiazlier for descriptors Jeremy Fitzhardinge
2008-10-29 12:54 ` [PATCH 04/12] x86: Add macros for gate_desc Jeremy Fitzhardinge
2008-10-29 12:52 ` [PATCH 03/12] x86: Cleanup usage of struct desc_struct Jeremy Fitzhardinge
2008-10-29 12:53 ` [PATCH 02/12] x86: Use new gate_struct for gate_desc Jeremy Fitzhardinge
2008-10-25 5:40 ` [PATCH 00/12] x86: Cleanup idt, gdt/ldt/tss structs Willy Tarreau
2008-10-27 10:57 ` Ingo Molnar
2008-10-25 9:39 ` walter harms
2008-10-27 10:55 ` Ingo Molnar
2008-10-27 14:34 ` H. Peter Anvin
2008-10-27 21:15 ` Joe Damato
2008-10-27 23:02 ` Jeremy Fitzhardinge
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=52f8491fb5d55c0171840b01638ea6db0a98f3be.1224903712.git.ice799@gmail.com \
--to=ice799@gmail.com \
--cc=kernel-janitors@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-newbie@vger.kernel.org \
--cc=linux-x86_64@vger.kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®