mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Suzuki K Poulose <suzuki.poulose@arm.com>
To: Jonathan Cameron <jonathan.cameron@oss.qualcomm.com>
Cc: kvm@vger.kernel.org, kvmarm@lists.linux.dev, maz@kernel.org,
	will@kernel.org, catalin.marinas@arm.com,
	linux-kernel@vger.kernel.org,
	linux-arm-kernel@lists.infradead.org, steven.price@arm.com,
	aneesh.kumar@kernel.org, oupton@kernel.org, gshan@redhat.com,
	joey.gouly@arm.com, tabba@google.com, yuzenghui@huawei.com,
	linux-coco@lists.linux.dev, gankulkarni@os.amperecomputing.com,
	sdonthineni@nvidia.com, alpergun@google.com,
	fj0570is@fujitsu.com, WeiLin.Chang@arm.com,
	lpieralisi@kernel.org, enju.kohei@fujitsu.com
Subject: Re: [PATCH v18 5/7] firmware: arm_rmm: Activate the RMM
Date: Mon, 21 Sep 2026 10:04:53 +0100	[thread overview]
Message-ID: <5318f467-317b-4d67-a39b-39e5ce1d860c@arm.com> (raw)
In-Reply-To: <178978126542.2352296.10527413259157627665.b4-review@b4>

On 19/09/2026 02:27, Jonathan Cameron wrote:
>> Activate the RMM after the basic configuration. This is a memory transferring,
>> stateful operation.
>>
>> Signed-off-by: Steven Price <steven.price@arm.com>
>> Signed-off-by: Suzuki K Poulose <suzuki.poulose@arm.com>
> 
> With the declaration moved as per standard way of dealing with __free
> magic (there are docs in cleanup.h on this)
> 
> Reviewed-by: Jonathan Cameron <jonathan.cameron@oss.qualcomm.com>
> 
>> ---
>> Changes since v17:
>>   * Inline RMM_ACTIVATE command and remove the definitions from arm-rmi-cmds.h
>>   * Use scope-based cleanup to free sro object
>> Changes since v16:
>>   * Split into a new patch
>> ---
>>   drivers/firmware/arm_rmm/rmi.c | 14 +++++++++++++-
>>   1 file changed, 13 insertions(+), 1 deletion(-)
>>
>> diff --git a/drivers/firmware/arm_rmm/rmi.c b/drivers/firmware/arm_rmm/rmi.c
>> index 4f9898ece754..ecc89e91d264 100644
>> --- a/drivers/firmware/arm_rmm/rmi.c
>> +++ b/drivers/firmware/arm_rmm/rmi.c
>> @@ -762,6 +762,7 @@ static int rmi_configure(void)
>>   static int __init arm64_init_rmi(void)
>>   {
>>   	int ret;
>> +	struct rmi_sro_state *sro __free(kfree) = NULL;
>>
> Read the guidance in cleanup.h
> 
> This is a path to a potentially grumpy Linus.  He's made the sensible
> point a number of times that putting the declaration of the destructor
> anywhere that isn't right next to the contstructor is a recipe for
> hard to read code and odd bugs (this one isn't buggy,
> but the principle is more general and the readability thing does hold!)

Ack

> 
>>   	/* Continue without realm support if we can't agree on a version */
>>   	ret = rmi_check_version();
>> @@ -776,7 +777,18 @@ static int __init arm64_init_rmi(void)
>>   	if (ret)
>>   		return ret;
>>   
>> -	return 0;
>> +	/* Activate the RMM */
>> +	sro = kmalloc_obj(*sro);
> 
> struct rmi_sro_state *sro __free(kfree) = kmalloc_obj(*sro);

Thanks

> 
>> +	if (!sro)
>> +		return -ENOMEM;
>> +
>> +	ret = rmi_sro_memxfer_cmd(sro, GFP_KERNEL, SMC_RMI_RMM_ACTIVATE);
>> +	if (ret) {
>> +		pr_err("RMM activate failed\n");
>> +		ret = ret < 0 ? ret : -ENXIO;
>    		return ret < 0 ? ...
>> +	}
> 
> return 0;
> Perhaps to make it more obvious that any non 0 return means error?

We want to differentiate between the linux errnos vs RMM errors 
(positive). I will rework this to address the RMI_BLOCKED comment
from Sudeep.

Cheers
Suzuki


> 
> Doesn't really matter
> 


  reply	other threads:[~2026-09-21  9:04 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-12  8:36 [PATCH v18 0/7] firmware: arm_rmm: Add RMM v2.0 base RMI support Suzuki K Poulose
2026-09-12  8:36 ` [PATCH v18 1/7] firmware: arm_rmm: Add SMC definitions for calling the RMM Suzuki K Poulose
2026-09-14  0:28   ` Gavin Shan
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21  9:27     ` Suzuki K Poulose
2026-09-21 10:02       ` Suzuki K Poulose
2026-09-21 21:27         ` Jonathan Cameron
2026-09-21 10:14       ` Suzuki K Poulose
2026-09-21 21:29         ` Jonathan Cameron
2026-09-21 21:33       ` Jonathan Cameron
2026-09-12  8:36 ` [PATCH v18 2/7] firmware: arm_rmm: Check for RMI support at init Suzuki K Poulose
2026-09-14  1:04   ` Gavin Shan
2026-09-14 10:27   ` Sudeep Holla
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21  9:00     ` Suzuki K Poulose
2026-09-21 21:37       ` Jonathan Cameron
2026-09-12  8:36 ` [PATCH v18 3/7] firmware: arm_rmm: Configure the RMM with the host's page size Suzuki K Poulose
2026-09-14  1:21   ` Gavin Shan
2026-09-14  6:34     ` Suzuki K Poulose
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21  9:31     ` Suzuki K Poulose
2026-09-12  8:36 ` [PATCH v18 4/7] firmware: arm_rmm: Add support for SRO Suzuki K Poulose
2026-09-14  5:04   ` Gavin Shan
2026-09-14  6:22     ` Suzuki K Poulose
2026-09-14  8:19       ` Suzuki K Poulose
2026-09-14  9:59         ` Gavin Shan
2026-09-14  9:50       ` Gavin Shan
2026-09-14 12:50   ` Sudeep Holla
2026-09-14 14:02     ` Suzuki K Poulose
2026-09-14 14:47       ` Suzuki K Poulose
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21 12:42     ` Suzuki K Poulose
2026-09-21 21:46       ` Jonathan Cameron
2026-09-12  8:36 ` [PATCH v18 5/7] firmware: arm_rmm: Activate the RMM Suzuki K Poulose
2026-09-14  5:06   ` Gavin Shan
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21  9:04     ` Suzuki K Poulose [this message]
2026-09-12  8:36 ` [PATCH v18 6/7] firmware: arm_rmm: Ensure the RMM has GPT entries for memory Suzuki K Poulose
2026-09-14  5:41   ` Gavin Shan
2026-09-14  8:38     ` Suzuki K Poulose
2026-09-16 18:23   ` Alper Gun
2026-09-21  9:30     ` Suzuki K Poulose
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21  9:32     ` Suzuki K Poulose
2026-09-21 13:38       ` Suzuki K Poulose
2026-09-21 21:58         ` Jonathan Cameron
2026-09-12  8:36 ` [PATCH v18 7/7] firmware: arm_rmm: Add wrappers for Realm related RMI commands Suzuki K Poulose
2026-09-14  5:46   ` Gavin Shan
2026-09-15 19:35   ` Alper Gun
2026-09-15 19:55     ` Suzuki K Poulose
2026-09-19  1:27   ` Jonathan Cameron
2026-09-21 21:53 ` [PATCH v18 0/7] firmware: arm_rmm: Add RMM v2.0 base RMI support Jonathan Cameron

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5318f467-317b-4d67-a39b-39e5ce1d860c@arm.com \
    --to=suzuki.poulose@arm.com \
    --cc=WeiLin.Chang@arm.com \
    --cc=alpergun@google.com \
    --cc=aneesh.kumar@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=enju.kohei@fujitsu.com \
    --cc=fj0570is@fujitsu.com \
    --cc=gankulkarni@os.amperecomputing.com \
    --cc=gshan@redhat.com \
    --cc=joey.gouly@arm.com \
    --cc=jonathan.cameron@oss.qualcomm.com \
    --cc=kvm@vger.kernel.org \
    --cc=kvmarm@lists.linux.dev \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lpieralisi@kernel.org \
    --cc=maz@kernel.org \
    --cc=oupton@kernel.org \
    --cc=sdonthineni@nvidia.com \
    --cc=steven.price@arm.com \
    --cc=tabba@google.com \
    --cc=will@kernel.org \
    --cc=yuzenghui@huawei.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®