mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Tomeu Vizoso <tomeu.vizoso@collabora.com>
To: Stephen Boyd <sboyd@codeaurora.org>,
	Mike Turquette <mturquette@linaro.org>
Cc: linux-kernel@vger.kernel.org, Alban Browaeys <alban.browaeys@gmail.com>
Subject: Re: [PATCH 2/3] clk: Rename child_node to clks_node to avoid confusion
Date: Fri, 06 Feb 2015 15:02:05 +0100	[thread overview]
Message-ID: <54D4C95D.30909@collabora.com> (raw)
In-Reply-To: <1423181968-32149-3-git-send-email-sboyd@codeaurora.org>

On 02/06/2015 01:19 AM, Stephen Boyd wrote:
> The child_node member of struct clk is named the same as the
> child_node member of struct clk_core. Let's rename the struct
> clk's member to clks_node to avoid getting confused with the
> child_node member of struct clk_core and to match the name of the
> list head, clks.
> 
> Cc: Tomeu Vizoso <tomeu.vizoso@collabora.com>
> Cc: Alban Browaeys <alban.browaeys@gmail.com>
> Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
> ---
>  drivers/clk/clk.c | 12 ++++++------
>  1 file changed, 6 insertions(+), 6 deletions(-)

Yeah, I like this better.

Reviewed-by: Tomeu Vizoso <tomeu.vizoso@collabora.com>

Thanks,

Tomeu

> diff --git a/drivers/clk/clk.c b/drivers/clk/clk.c
> index 5469d7714f5d..315dc22b7356 100644
> --- a/drivers/clk/clk.c
> +++ b/drivers/clk/clk.c
> @@ -83,7 +83,7 @@ struct clk {
>  	const char *con_id;
>  	unsigned long min_rate;
>  	unsigned long max_rate;
> -	struct hlist_node child_node;
> +	struct hlist_node clks_node;
>  };
>  
>  /***           locking             ***/
> @@ -851,10 +851,10 @@ static void clk_core_get_boundaries(struct clk_core *clk,
>  	*min_rate = 0;
>  	*max_rate = ULONG_MAX;
>  
> -	hlist_for_each_entry(clk_user, &clk->clks, child_node)
> +	hlist_for_each_entry(clk_user, &clk->clks, clks_node)
>  		*min_rate = max(*min_rate, clk_user->min_rate);
>  
> -	hlist_for_each_entry(clk_user, &clk->clks, child_node)
> +	hlist_for_each_entry(clk_user, &clk->clks, clks_node)
>  		*max_rate = min(*max_rate, clk_user->max_rate);
>  }
>  
> @@ -2376,7 +2376,7 @@ struct clk *__clk_create_clk(struct clk_hw *hw, const char *dev_id,
>  	clk->max_rate = ULONG_MAX;
>  
>  	clk_prepare_lock();
> -	hlist_add_head(&clk->child_node, &hw->core->clks);
> +	hlist_add_head(&clk->clks_node, &hw->core->clks);
>  	clk_prepare_unlock();
>  
>  	return clk;
> @@ -2385,7 +2385,7 @@ struct clk *__clk_create_clk(struct clk_hw *hw, const char *dev_id,
>  void __clk_free_clk(struct clk *clk)
>  {
>  	clk_prepare_lock();
> -	hlist_del(&clk->child_node);
> +	hlist_del(&clk->clks_node);
>  	clk_prepare_unlock();
>  
>  	kfree(clk);
> @@ -2663,7 +2663,7 @@ void __clk_put(struct clk *clk)
>  
>  	clk_prepare_lock();
>  
> -	hlist_del(&clk->child_node);
> +	hlist_del(&clk->clks_node);
>  	clk_core_set_rate_nolock(clk->core, clk->core->req_rate);
>  	owner = clk->core->owner;
>  	kref_put(&clk->core->ref, __clk_release);
> 


  reply	other threads:[~2015-02-06 14:02 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-02-06  0:19 [PATCH 0/3] CCF fixes/cleanup for per-user series Stephen Boyd
2015-02-06  0:19 ` [PATCH 1/3] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF Stephen Boyd
2015-02-06  0:36   ` Stephen Boyd
2015-02-06  0:19 ` [PATCH 2/3] clk: Rename child_node to clks_node to avoid confusion Stephen Boyd
2015-02-06 14:02   ` Tomeu Vizoso [this message]
2015-02-06  0:19 ` [PATCH 3/3] clk: Replace of_clk_get_by_clkspec() with of_clk_get_from_provider() Stephen Boyd
2015-02-06 11:43   ` Tomeu Vizoso
2015-02-06 17:24     ` Stephen Boyd
2015-02-06  1:40 ` [PATCH v2] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF Stephen Boyd
2015-02-06 10:57   ` Sylwester Nawrocki
2015-02-06 11:23     ` Tomeu Vizoso
2015-02-06 17:36     ` Stephen Boyd
2015-02-06 12:34   ` Tomeu Vizoso
2015-02-06 17:11     ` Stephen Boyd

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=54D4C95D.30909@collabora.com \
    --to=tomeu.vizoso@collabora.com \
    --cc=alban.browaeys@gmail.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mturquette@linaro.org \
    --cc=sboyd@codeaurora.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome