From: Stephen Boyd <sboyd@codeaurora.org>
To: Sylwester Nawrocki <s.nawrocki@samsung.com>,
Mike Turquette <mturquette@linaro.org>,
Tomeu Vizoso <tomeu.vizoso@collabora.com>
Cc: linux-kernel@vger.kernel.org,
Alban Browaeys <alban.browaeys@gmail.com>,
Beata Michalska <b.michalska@samsung.com>
Subject: Re: [PATCH v2] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF
Date: Fri, 06 Feb 2015 09:36:44 -0800 [thread overview]
Message-ID: <54D4FBAC.8000605@codeaurora.org> (raw)
In-Reply-To: <54D49E0D.8090809@samsung.com>
On 02/06/15 02:57, Sylwester Nawrocki wrote:
>
> As a side note, IMHO recent changes made the code much harder to follow,
> e.g. by using 'clk' local variable name interchangeably for 'struct clk'
> and 'struct clk_core' types and by using same field name in different data
> structures, like 'child_node'. I guess the changes were limited to make
> the diff smaller, nevertheless it seems we ended up with something rather
> illegible.
Yes it was to reduce diff. I plan to do the rename once the dust settles.
>
> Tested-by: Sylwester Nawrocki <s.nawrocki@samsung.com>
>
>
Thanks.
--
Qualcomm Innovation Center, Inc. is a member of Code Aurora Forum,
a Linux Foundation Collaborative Project
next prev parent reply other threads:[~2015-02-06 17:36 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2015-02-06 0:19 [PATCH 0/3] CCF fixes/cleanup for per-user series Stephen Boyd
2015-02-06 0:19 ` [PATCH 1/3] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF Stephen Boyd
2015-02-06 0:36 ` Stephen Boyd
2015-02-06 0:19 ` [PATCH 2/3] clk: Rename child_node to clks_node to avoid confusion Stephen Boyd
2015-02-06 14:02 ` Tomeu Vizoso
2015-02-06 0:19 ` [PATCH 3/3] clk: Replace of_clk_get_by_clkspec() with of_clk_get_from_provider() Stephen Boyd
2015-02-06 11:43 ` Tomeu Vizoso
2015-02-06 17:24 ` Stephen Boyd
2015-02-06 1:40 ` [PATCH v2] clkdev: Always allocate a struct clk and call __clk_get() w/ CCF Stephen Boyd
2015-02-06 10:57 ` Sylwester Nawrocki
2015-02-06 11:23 ` Tomeu Vizoso
2015-02-06 17:36 ` Stephen Boyd [this message]
2015-02-06 12:34 ` Tomeu Vizoso
2015-02-06 17:11 ` Stephen Boyd
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=54D4FBAC.8000605@codeaurora.org \
--to=sboyd@codeaurora.org \
--cc=alban.browaeys@gmail.com \
--cc=b.michalska@samsung.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mturquette@linaro.org \
--cc=s.nawrocki@samsung.com \
--cc=tomeu.vizoso@collabora.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome