mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v5] wifi: cfg80211: Remove the redundant wiphy_dev
@ 2025-09-10  1:55 Zheng tan
  2025-09-10 13:07 ` Johannes Berg
  0 siblings, 1 reply; 2+ messages in thread
From: Zheng tan @ 2025-09-10  1:55 UTC (permalink / raw)
  To: johannes; +Cc: arend.vanspriel, linux-kernel, linux-wireless, tanzheng

There is no need to call wiphy_dev again.Simplifying the
code makes it more readable.

Signed-off-by: Zheng tan <tanzheng@kylinos.cn>
Reviewed-by: Arend van Spriel <arend.vanspriel@broadcom.com>
Reviewed-by: Johannes Berg <johannes@sipsolutions.net>
---
Changes in v5:
-Modify the From and Signed-off-by.

Changes in v4:
-Keep the from and Signed-off-by tags consistent.

Changes in v3:
- Modify the patch description.

Changes in v2:
- Delete the use of dev_name instead of pdev->driver->name.
  This is incorrect.

 net/wireless/ethtool.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/net/wireless/ethtool.c b/net/wireless/ethtool.c
index 2613d6ac0fda..46e4317cbd7e 100644
--- a/net/wireless/ethtool.c
+++ b/net/wireless/ethtool.c
@@ -23,7 +23,7 @@ void cfg80211_get_drvinfo(struct net_device *dev, struct ethtool_drvinfo *info)
 	else
 		strscpy(info->fw_version, "N/A", sizeof(info->fw_version));
 
-	strscpy(info->bus_info, dev_name(wiphy_dev(wdev->wiphy)),
+	strscpy(info->bus_info, dev_name(pdev),
 		sizeof(info->bus_info));
 }
 EXPORT_SYMBOL(cfg80211_get_drvinfo);
-- 
2.25.1


^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2025-09-10 13:08 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-09-10  1:55 [PATCH v5] wifi: cfg80211: Remove the redundant wiphy_dev Zheng tan
2025-09-10 13:07 ` Johannes Berg

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®