From: Chanwoo Choi <cwchoi00@gmail.com>
To: Andy Shevchenko <andriy.shevchenko@linux.intel.com>,
Bumwoo Lee <bw365.lee@samsung.com>,
linux-kernel@vger.kernel.org
Cc: MyungJoo Ham <myungjoo.ham@samsung.com>,
Chanwoo Choi <cw00.choi@samsung.com>
Subject: Re: [PATCH v1 12/14] extcon: Use sizeof(*pointer) instead of sizeof(type)
Date: Mon, 3 Apr 2023 23:32:04 +0900 [thread overview]
Message-ID: <56c49141-c9c4-6b03-7ecf-74f6fdb1209e@gmail.com> (raw)
In-Reply-To: <20230322144005.40368-13-andriy.shevchenko@linux.intel.com>
On 23. 3. 22. 23:40, Andy Shevchenko wrote:
> It is preferred to use sizeof(*pointer) instead of sizeof(type).
> The type of the variable can change and one needs not change
> the former (unlike the latter). No functional change intended.
>
> Signed-off-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
> ---
> drivers/extcon/extcon.c | 17 ++++++-----------
> 1 file changed, 6 insertions(+), 11 deletions(-)
>
> diff --git a/drivers/extcon/extcon.c b/drivers/extcon/extcon.c
> index 0e04ea185c26..b3f038639cd6 100644
> --- a/drivers/extcon/extcon.c
> +++ b/drivers/extcon/extcon.c
> @@ -1099,9 +1099,7 @@ static int extcon_alloc_cables(struct extcon_dev *edev)
> if (!edev->max_supported)
> return 0;
>
> - edev->cables = kcalloc(edev->max_supported,
> - sizeof(struct extcon_cable),
> - GFP_KERNEL);
> + edev->cables = kcalloc(edev->max_supported, sizeof(*edev->cables), GFP_KERNEL);
Even if there are strictly not limitation of the number of maximum char
at the one line, But, I recommend to keep the 80 char at the one line
for the readability as following.
- edev->cables = kcalloc(edev->max_supported, sizeof(*edev->cables), GFP_KERNEL);
+ edev->cables = kcalloc(edev->max_supported,
+ sizeof(*edev->cables), GFP_KERNEL);
> if (!edev->cables)
> return -ENOMEM;
>
> @@ -1160,14 +1158,12 @@ static int extcon_alloc_muex(struct extcon_dev *edev)
> for (index = 0; edev->mutually_exclusive[index]; index++)
> ;
>
> - edev->attrs_muex = kcalloc(index + 1,
> - sizeof(struct attribute *),
> + edev->attrs_muex = kcalloc(index + 1, sizeof(*edev->attrs_muex),
> GFP_KERNEL);
> if (!edev->attrs_muex)
> return -ENOMEM;
>
> - edev->d_attrs_muex = kcalloc(index,
> - sizeof(struct device_attribute),
> + edev->d_attrs_muex = kcalloc(index, sizeof(*edev->d_attrs_muex),
> GFP_KERNEL);
> if (!edev->d_attrs_muex) {
> kfree(edev->attrs_muex);
> @@ -1213,8 +1209,8 @@ static int extcon_alloc_groups(struct extcon_dev *edev)
> return 0;
>
> edev->extcon_dev_type.groups = kcalloc(edev->max_supported + 2,
> - sizeof(struct attribute_group *),
> - GFP_KERNEL);
> + sizeof(*edev->extcon_dev_type.groups),
> + GFP_KERNEL);
ditto.
edev->extcon_dev_type.groups = kcalloc(edev->max_supported + 2,
- sizeof(*edev->extcon_dev_type.groups),
- GFP_KERNEL);
+ sizeof(*edev->extcon_dev_type.groups),
+ GFP_KERNEL);
> if (!edev->extcon_dev_type.groups)
> return -ENOMEM;
>
> @@ -1298,8 +1294,7 @@ int extcon_dev_register(struct extcon_dev *edev)
>
> spin_lock_init(&edev->lock);
> if (edev->max_supported) {
> - edev->nh = kcalloc(edev->max_supported, sizeof(*edev->nh),
> - GFP_KERNEL);
> + edev->nh = kcalloc(edev->max_supported, sizeof(*edev->nh), GFP_KERNEL);
- edev->nh = kcalloc(edev->max_supported, sizeof(*edev->nh), GFP_KERNEL);
+ edev->nh = kcalloc(edev->max_supported,
+ sizeof(*edev->nh), GFP_KERNEL);
> if (!edev->nh) {
> ret = -ENOMEM;
> goto err_alloc_nh;
--
Best Regards,
Samsung Electronics
Chanwoo Choi
next prev parent reply other threads:[~2023-04-03 14:32 UTC|newest]
Thread overview: 40+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-03-22 14:39 [PATCH v1 00/14] extcon: Core cleanups and documentation fixes Andy Shevchenko
2023-03-22 14:39 ` [PATCH v1 01/14] extcon: Fix kernel doc of property fields to avoid warnings Andy Shevchenko
2023-04-03 13:50 ` Chanwoo Choi
2023-03-22 14:39 ` [PATCH v1 02/14] extcon: Fix kernel doc of property capability " Andy Shevchenko
2023-04-03 13:51 ` Chanwoo Choi
2023-03-22 14:39 ` [PATCH v1 03/14] extcon: Use DECLARE_BITMAP() to declare bit arrays Andy Shevchenko
2023-04-03 14:04 ` Chanwoo Choi
2023-03-22 14:39 ` [PATCH v1 04/14] extcon: use sysfs_emit() to instead of sprintf() Andy Shevchenko
2023-04-03 14:10 ` Chanwoo Choi
2023-03-22 14:39 ` [PATCH v1 05/14] extcon: Amend kernel documentation of struct extcon_dev Andy Shevchenko
2023-04-03 14:10 ` Chanwoo Choi
2023-03-22 14:39 ` [PATCH v1 06/14] extcon: Allow name to be assigned outside of the framework Andy Shevchenko
2023-04-03 13:56 ` Chanwoo Choi
2023-03-22 14:39 ` [PATCH v1 07/14] extcon: Use unique number for the extcon device ID Andy Shevchenko
2023-04-03 14:52 ` Chanwoo Choi
2023-04-05 15:03 ` Andy Shevchenko
2023-03-22 14:39 ` [PATCH v1 08/14] extcon: Switch to use kasprintf_strarray() Andy Shevchenko
2023-04-03 14:58 ` Chanwoo Choi
2023-04-05 8:16 ` Andy Shevchenko
2023-04-05 15:05 ` Andy Shevchenko
2023-03-22 14:40 ` [PATCH v1 09/14] extcon: Use device_match_of_node() helper Andy Shevchenko
2023-04-03 14:14 ` Chanwoo Choi
2023-03-22 14:40 ` [PATCH v1 10/14] extcon: use dev_of_node(dev) instead of dev->of_node Andy Shevchenko
2023-04-03 14:17 ` Chanwoo Choi
2023-03-22 14:40 ` [PATCH v1 11/14] extcon: Remove dup device name in the message and unneeded error check Andy Shevchenko
2023-04-03 14:59 ` Chanwoo Choi
2023-03-22 14:40 ` [PATCH v1 12/14] extcon: Use sizeof(*pointer) instead of sizeof(type) Andy Shevchenko
2023-04-03 14:32 ` Chanwoo Choi [this message]
2023-03-22 14:40 ` [PATCH v1 13/14] extcon: Drop unneeded assignments Andy Shevchenko
2023-04-03 15:06 ` Chanwoo Choi
2023-03-22 14:40 ` [PATCH v1 14/14] extcon: Use positive conditional in ternary operator Andy Shevchenko
2023-04-03 14:38 ` Chanwoo Choi
2023-04-05 8:18 ` Andy Shevchenko
2023-03-30 10:11 ` [PATCH v1 00/14] extcon: Core cleanups and documentation fixes Andy Shevchenko
2023-03-31 0:48 ` Bumwoo Lee
2023-04-05 23:17 ` Chanwoo Choi
2023-04-06 0:04 ` Bumwoo Lee
2023-04-06 10:49 ` 'Andy Shevchenko'
2023-04-03 13:58 ` Chanwoo Choi
2023-04-05 8:12 ` Andy Shevchenko
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=56c49141-c9c4-6b03-7ecf-74f6fdb1209e@gmail.com \
--to=cwchoi00@gmail.com \
--cc=andriy.shevchenko@linux.intel.com \
--cc=bw365.lee@samsung.com \
--cc=cw00.choi@samsung.com \
--cc=linux-kernel@vger.kernel.org \
--cc=myungjoo.ham@samsung.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®