From: Babu Moger <babu.moger@amd.com>
To: Reinette Chatre <reinette.chatre@intel.com>,
tony.luck@intel.com, Dave.Martin@arm.com, james.morse@arm.com,
bp@alien8.de, ben.horgan@arm.com
Cc: corbet@lwn.net, skhan@linuxfoundation.org, rdunlap@infradead.org,
tglx@kernel.org, mingo@redhat.com, dave.hansen@linux.intel.com,
hpa@zytor.com, fenghuay@nvidia.com, akpm@linux-foundation.org,
rppt@kernel.org, dapeng1.mi@linux.intel.com, elver@google.com,
jlayton@kernel.org, enelsonmoore@gmail.com, kuba@kernel.org,
ebiggers@kernel.org, seanjc@google.com, peterz@infradead.org,
chao.gao@intel.com, jmattson@google.com, naveen@kernel.org,
ricardo.neri-calderon@linux.intel.com, tiala@microsoft.com,
chang.seok.bae@intel.com, prathyushi.nangia@amd.com,
kim.phillips@amd.com, elena.reshetova@intel.com,
darwi@linutronix.de, linux-doc@vger.kernel.org,
linux-kernel@vger.kernel.org, x86@kernel.org
Subject: Re: [PATCH v5 06/16] fs/resctrl: Introduce kernel mode states for resctrl
Date: Thu, 17 Sep 2026 09:05:10 -0500 [thread overview]
Message-ID: <56dcf2d4-5fc2-46a2-9391-1182a0a6ddde@amd.com> (raw)
In-Reply-To: <4277c043-c854-4c9f-90cd-9cceaab3c88c@intel.com>
Hi Reinette,
On 9/16/26 00:28, Reinette Chatre wrote:
> Hi Babu,
>
> On 8/26/26 12:32 PM, Babu Moger wrote:
>
>> ---
>> fs/resctrl/internal.h | 51 +++++++++++++++++++++++++++++++++++++++++++
>> fs/resctrl/rdtgroup.c | 33 ++++++++++++++++++++++++++++
>> 2 files changed, 84 insertions(+)
>>
>> diff --git a/fs/resctrl/internal.h b/fs/resctrl/internal.h
>> index e62a277dee85..4087bf44a06d 100644
>> --- a/fs/resctrl/internal.h
>> +++ b/fs/resctrl/internal.h
>> @@ -314,6 +314,57 @@ struct mbm_state {
>> u32 prev_bw;
>> };
>>
>> +/**
>> + * enum kmode_state - Control or monitoring state for a kernel mode
>> + * @KMODE_INHERIT: Inherit from the user space task.
>> + * @KMODE_ASSIGN: Use a global assignment for kernel mode.
>> + */
>> +enum kmode_state {
>> + KMODE_INHERIT,
>> + KMODE_ASSIGN
>> +};
>> +
>> +/**
>> + * struct resctrl_kmode_caps - Static kernel mode capabilities
>> + * @kmode_sup: Bitmap of supported kernel modes. Empty when neither
>> + * @ctrl_en nor @mon_en is set and kernel mode policy is
>> + * unavailable on this system.
>> + * @ctrl_en: Whether kernel mode may use global assignment for control.
>> + * @mon_en: Whether kernel mode may use global assignment for monitoring.
>
> Why is ctrl_en and mon_en needed? It seems to just store the output of
> whether system supports allocation and monitoring. I only see these used
> when user interacts reads or writes the kernel mode so not a "hot path" that
> needs to be optimized. Can these just be dropped and just use resctrl_arch_alloc_capable()
> and resctrl_arch_mon_capable() directly? Please note they are in process of
> being changed/renamed:
Sure. I'll remove it.
That also means we can consolidate everything into a single
resctrl_kmode_cfg structure.
> https://lore.kernel.org/lkml/20260831174421.13921-7-tony.luck@intel.com/
>
>> + */
>> +struct resctrl_kmode_caps {
>> + DECLARE_BITMAP(kmode_sup, RESCTRL_NUM_KERNEL_MODES);
>> + bool ctrl_en;
>> + bool mon_en;
>> +};
>> +
>> +/**
>> + * struct resctrl_kmode_active - Runtime kernel mode state
>> + * @kmode_cur: Currently selected kernel mode.
>> + * @ctrl_mode: Control assignment state when kernel mode is active.
>> + * @mon_mode: Monitoring assignment state when kernel mode is active.
>> + * @k_rdtgrp: Resource group backing global assignment mode.
>> + *
>> + * When @kmode_cur is %RESCTRL_INHERIT_USER, assignment state is ignored and
>> + * @k_rdtgrp is %NULL.
>
> This implies that this is only the state for RESCTRL_ASSIGN_GLOBAL_ENABLE_PER_CPU.
> If it is made specifically so there is no need to pretend it is generic and
> add all these caveats.
ok.
>
>> + */
>> +struct resctrl_kmode_active {
>> + enum resctrl_kernel_mode kmode_cur;
>> + enum kmode_state ctrl_mode;
>> + enum kmode_state mon_mode;
>
> Is "mode" accurate? This is all about kernel "mode" and now control and
> monitoring have other modes?
It can be control and monitor.
>
>> + struct rdtgroup *k_rdtgrp;
>
> Could naming be consistent? Consider, for example, kmode_rdtgrp? Although
> if this struct can be specific to the global per-CPU kernel mode then it can
> just be "rdtgrp".
Sure.
>
>> +};
>> +
>> +/**
>> + * struct resctrl_kmode_cfg - Global kernel mode state
>> + * @caps: Supported modes and assignment capabilities.
>> + * @active: Active mode, assignment state, and assigned group.
>
> Please do not list the struct members as part of its description elsewhere since
> that will be difficult to keep accurate. Just describe what the struct represents.
Will remove it.
>
>> + */
>> +struct resctrl_kmode_cfg {
>> + struct resctrl_kmode_caps caps;
>> + struct resctrl_kmode_active active;
>> +};
>> +
>> extern struct mutex rdtgroup_mutex;
>>
>> static inline const char *rdt_kn_name(const struct kernfs_node *kn)
>> diff --git a/fs/resctrl/rdtgroup.c b/fs/resctrl/rdtgroup.c
>> index 5dcbb0a964e8..3c53f3f74e5a 100644
>> --- a/fs/resctrl/rdtgroup.c
>> +++ b/fs/resctrl/rdtgroup.c
>> @@ -76,6 +76,13 @@ static void rdtgroup_destroy_root(void);
>>
>> struct dentry *debugfs_resctrl;
>>
>> +/*
>> + * Global kernel mode policy state: supported modes, active mode, assignment
>> + * capabilities, assignment state, and the resource group selected for a global
>> + * assignment.
>
> Same here - please do not just provide a list of the struct's members. A high level
> description instead.
ok.
>
> This code is really strange. This whole series is difficult to read. I have not seen
> these styles used before and surprised that it comes from you.
ack.
>
>> + */
>> +static struct resctrl_kmode_cfg resctrl_kcfg;
>
> I think the code will be easier to read if "resctrl_kcfg" -> "resctrl_kmode".
Sure.
>
>> +
>> /*
>> * Memory bandwidth monitoring event to use for the default CTRL_MON group
>> * and each new CTRL_MON group created by the user. Only relevant when
>> @@ -2297,6 +2304,30 @@ static void io_alloc_init(void)
>> }
>> }
>>
>> +/*
>> + * Initialize kernel mode policy defaults from architecture capabilities.
>> + *
>> + * When ctrl_en or mon_en is set, RESCTRL_INHERIT_USER is supported and
>> + * selected as the initial active mode. When neither is set, kmode_sup is
>> + * left empty, kernel mode policy is unavailable, and kmode_cur remains at
>> + * its zero-initialized default (RESCTRL_INHERIT_USER) but is unused.
>
> Above just verbatim describes the code. Please provide higher level why the
> code does what it does.
ok.
Thanks
Babu
next prev parent reply other threads:[~2026-09-17 14:05 UTC|newest]
Thread overview: 49+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-08-26 19:32 [PATCH v5 00/16] x86/resctrl: Add kernel-mode (e.g., PLZA) support to the resctrl subsystem Babu Moger
2026-08-26 19:32 ` [PATCH v5 01/16] x86/cpufeatures: Support Privilege Level Zero Association (PLZA) Babu Moger
2026-09-16 5:12 ` Reinette Chatre
2026-09-16 20:45 ` Babu Moger
2026-09-17 15:04 ` Reinette Chatre
2026-09-17 17:08 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 02/16] x86/resctrl: Add PLZA support to command-line options Babu Moger
2026-09-16 5:12 ` Reinette Chatre
2026-09-16 20:45 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 03/16] x86/resctrl: Add PLZA configuration definitions and data structures Babu Moger
2026-09-16 5:16 ` Reinette Chatre
2026-09-16 20:53 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 04/16] fs/resctrl: Introduce kernel mode policy enum Babu Moger
2026-09-16 5:14 ` Reinette Chatre
2026-09-16 20:53 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 05/16] x86,fs/resctrl: Introduce architecture hooks to program kernel mode Babu Moger
2026-09-16 5:26 ` Reinette Chatre
2026-09-16 20:57 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 06/16] fs/resctrl: Introduce kernel mode states for resctrl Babu Moger
2026-09-16 5:28 ` Reinette Chatre
2026-09-17 14:05 ` Babu Moger [this message]
2026-08-26 19:32 ` [PATCH v5 07/16] fs/resctrl: Introduce resctrl_set_kmode_support() to register supported modes Babu Moger
2026-09-16 5:29 ` Reinette Chatre
2026-09-17 14:20 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 08/16] x86/resctrl: Expose assign_global_enable_per_cpu when PLZA is available Babu Moger
2026-08-26 19:32 ` [PATCH v5 09/16] fs/resctrl: Add interface to display supported and active kernel modes Babu Moger
2026-09-16 5:32 ` Reinette Chatre
2026-09-17 15:29 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 10/16] fs/resctrl: Add support for hidden resource group files Babu Moger
2026-09-16 5:33 ` Reinette Chatre
2026-09-17 17:26 ` Babu Moger
2026-09-17 18:31 ` Reinette Chatre
2026-09-17 18:54 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 11/16] fs/resctrl: Introduce kmode_cpus/kmode_cpus_list per rdtgroup Babu Moger
2026-09-16 5:34 ` Reinette Chatre
2026-09-17 18:19 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 12/16] fs/resctrl: Program kernel mode assignments on CPU hotplug Babu Moger
2026-09-16 5:35 ` Reinette Chatre
2026-09-17 18:26 ` Babu Moger
2026-08-26 19:32 ` [PATCH v5 13/16] fs/resctrl: Deactivate the kernel mode association when a group is removed Babu Moger
2026-09-16 5:36 ` Reinette Chatre
2026-09-17 19:25 ` Babu Moger
2026-09-17 19:48 ` Reinette Chatre
2026-08-26 19:32 ` [PATCH v5 14/16] fs/resctrl: Add interface to modify kernel mode via info/kernel_mode Babu Moger
2026-09-16 5:50 ` Reinette Chatre
2026-08-26 19:32 ` [PATCH v5 15/16] fs/resctrl: Allow user space to write kmode_cpus/kmode_cpus_list Babu Moger
2026-08-26 19:32 ` [PATCH v5 16/16] fs/resctrl: Add documentation on kernel_mode with example Babu Moger
2026-09-01 21:14 ` Luck, Tony
2026-09-01 23:28 ` Moger, Babu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=56dcf2d4-5fc2-46a2-9391-1182a0a6ddde@amd.com \
--to=babu.moger@amd.com \
--cc=Dave.Martin@arm.com \
--cc=akpm@linux-foundation.org \
--cc=ben.horgan@arm.com \
--cc=bp@alien8.de \
--cc=chang.seok.bae@intel.com \
--cc=chao.gao@intel.com \
--cc=corbet@lwn.net \
--cc=dapeng1.mi@linux.intel.com \
--cc=darwi@linutronix.de \
--cc=dave.hansen@linux.intel.com \
--cc=ebiggers@kernel.org \
--cc=elena.reshetova@intel.com \
--cc=elver@google.com \
--cc=enelsonmoore@gmail.com \
--cc=fenghuay@nvidia.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=jlayton@kernel.org \
--cc=jmattson@google.com \
--cc=kim.phillips@amd.com \
--cc=kuba@kernel.org \
--cc=linux-doc@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=naveen@kernel.org \
--cc=peterz@infradead.org \
--cc=prathyushi.nangia@amd.com \
--cc=rdunlap@infradead.org \
--cc=reinette.chatre@intel.com \
--cc=ricardo.neri-calderon@linux.intel.com \
--cc=rppt@kernel.org \
--cc=seanjc@google.com \
--cc=skhan@linuxfoundation.org \
--cc=tglx@kernel.org \
--cc=tiala@microsoft.com \
--cc=tony.luck@intel.com \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®