From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com>
To: Miroslav Benes <mbenes@suse.cz>, Mark Brown <broonie@kernel.org>
Cc: Mark Rutland <mark.rutland@arm.com>,
jpoimboe@redhat.com, ardb@kernel.org, nobuta.keiya@fujitsu.com,
sjitindarsingh@gmail.com, catalin.marinas@arm.com,
will@kernel.org, jmorris@namei.org,
linux-arm-kernel@lists.infradead.org,
live-patching@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v13 06/11] arm64: Use stack_trace_consume_fn and rename args to unwind()
Date: Thu, 10 Mar 2022 06:36:09 -0600 [thread overview]
Message-ID: <574cbef1-89ce-3e43-cebb-5db1d8e854e5@linux.microsoft.com> (raw)
In-Reply-To: <alpine.LSU.2.21.2203100923470.16704@pobox.suse.cz>
On 3/10/22 02:33, Miroslav Benes wrote:
> On Wed, 9 Mar 2022, Mark Brown wrote:
>
>> On Tue, Mar 08, 2022 at 04:00:35PM -0600, Madhavan T. Venkataraman wrote:
>>
>>> It is just that patch 11 that defines "select
>>> HAVE_RELIABLE_STACKTRACE" did not receive any comments from you
>>> (unless I missed a comment that came from you. That is entirely
>>> possible. If I missed it, my bad). Since you suggested that change, I
>>> just wanted to make sure that that patch looks OK to you.
>>
>> I think that's more a question for the livepatch people to be honest -
>> it's not entirely a technical one, there's a bunch of confidence level
>> stuff going on. For example there was some suggestion that people might
>> insist on having objtool support, though there's also substantial
>> pushback on making objtool a requirement for anything from other
>> quarters. I was hoping that posting that patch would provoke some
>> discussion about what exactly is needed but that's not happened thus
>> far.
>
> I think everyone will be happy with HAVE_RELIABLE_STACKTRACE on arm64 as
> long as there is a guarantee that stack traces are really reliable. My
> understanding is that there is still some work to be done on arm64 arch
> side (but I may have misunderstood what Mark R. said elsewhere). And yes,
> then there is a question of objtool. It is one option but not the only
> one. There have been proposals of implementing guarantees on a compiler
> side and leaving objtool for x86_64 only (albeit objtool may bring more
> features to the table... ORC, arch features checking).
>
> Madhavan also mentioned that he enhanced objtool and he planned to submit
> it eventually
> (https://lore.kernel.org/all/1a0e19db-a7f8-4c8e-0163-398fcd364d54@linux.microsoft.com/T/#u),
> so maybe arm64 maintainers could decide on a future direction based on
> that?
>
Yes. I am working on that right now. Hope to send it out soon.
Madhavan
next prev parent reply other threads:[~2022-03-10 12:36 UTC|newest]
Thread overview: 75+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <95691cae4f4504f33d0fc9075541b1e7deefe96f>
2022-01-17 14:55 ` [PATCH v13 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks madvenka
2022-01-17 14:55 ` [PATCH v13 01/11] arm64: Remove NULL task check from unwind_frame() madvenka
2022-01-17 14:55 ` [PATCH v13 02/11] arm64: Rename unwinder functions madvenka
2022-01-17 14:56 ` [PATCH v13 03/11] arm64: Rename stackframe to unwind_state madvenka
2022-01-17 14:56 ` [PATCH v13 04/11] arm64: Split unwind_init() madvenka
2022-02-02 18:44 ` Mark Brown
2022-02-03 0:26 ` Madhavan T. Venkataraman
2022-02-03 0:39 ` Madhavan T. Venkataraman
2022-02-03 11:29 ` Mark Brown
2022-02-15 13:07 ` Mark Rutland
2022-02-15 18:04 ` Madhavan T. Venkataraman
2022-01-17 14:56 ` [PATCH v13 05/11] arm64: Copy the task argument to unwind_state madvenka
2022-02-02 18:45 ` Mark Brown
2022-02-15 13:22 ` Mark Rutland
2022-02-22 16:53 ` Madhavan T. Venkataraman
2022-01-17 14:56 ` [PATCH v13 06/11] arm64: Use stack_trace_consume_fn and rename args to unwind() madvenka
2022-02-02 18:46 ` Mark Brown
2022-02-03 0:34 ` Madhavan T. Venkataraman
2022-02-03 11:30 ` Mark Brown
2022-02-03 14:45 ` Madhavan T. Venkataraman
2022-02-15 13:39 ` Mark Rutland
2022-02-15 18:12 ` Madhavan T. Venkataraman
2022-03-07 16:51 ` Madhavan T. Venkataraman
2022-03-07 17:01 ` Mark Brown
2022-03-08 22:00 ` Madhavan T. Venkataraman
2022-03-09 11:47 ` Mark Brown
2022-03-09 15:34 ` Madhavan T. Venkataraman
2022-03-10 8:33 ` Miroslav Benes
2022-03-10 12:36 ` Madhavan T. Venkataraman [this message]
2022-03-16 3:43 ` Josh Poimboeuf
2022-04-08 14:44 ` Mark Rutland
2022-04-08 17:58 ` Mark Rutland
2022-04-10 17:42 ` Madhavan T. Venkataraman
2022-04-10 17:33 ` Madhavan T. Venkataraman
2022-04-10 17:45 ` Madhavan T. Venkataraman
2022-01-17 14:56 ` [PATCH v13 07/11] arm64: Make the unwind loop in unwind() similar to other architectures madvenka
2022-01-17 14:56 ` [PATCH v13 08/11] arm64: Introduce stack trace reliability checks in the unwinder madvenka
2022-01-17 14:56 ` [PATCH v13 09/11] arm64: Create a list of SYM_CODE functions, check return PC against list madvenka
2022-01-17 14:56 ` [PATCH v13 10/11] arm64: Introduce arch_stack_walk_reliable() madvenka
2022-01-17 14:56 ` [PATCH v13 11/11] arm64: Select HAVE_RELIABLE_STACKTRACE madvenka
2022-01-25 5:21 ` nobuta.keiya
2022-01-25 13:43 ` Madhavan T. Venkataraman
2022-01-26 10:20 ` nobuta.keiya
2022-01-26 17:14 ` Madhavan T. Venkataraman
2022-01-27 1:13 ` nobuta.keiya
2022-01-26 17:16 ` Mark Brown
2022-04-07 20:25 ` [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation madvenka
2022-04-07 20:25 ` [RFC PATCH v1 1/9] objtool: Parse DWARF Call Frame Information in object files madvenka
2022-04-07 20:25 ` [RFC PATCH v1 2/9] objtool: Generate DWARF rules and place them in a special section madvenka
2022-04-07 20:25 ` [RFC PATCH v1 3/9] dwarf: Build the kernel with DWARF information madvenka
2022-04-07 20:25 ` [RFC PATCH v1 4/9] dwarf: Implement DWARF rule processing in the kernel madvenka
2022-04-07 20:25 ` [RFC PATCH v1 5/9] dwarf: Implement DWARF support for modules madvenka
2022-04-07 20:25 ` [RFC PATCH v1 6/9] arm64: unwinder: Add a reliability check in the unwinder based on DWARF CFI madvenka
2022-04-07 20:25 ` [RFC PATCH v1 7/9] arm64: dwarf: Implement unwind hints madvenka
2022-04-07 20:25 ` [RFC PATCH v1 8/9] dwarf: Miscellaneous changes required for enabling livepatch madvenka
2022-04-07 20:25 ` [RFC PATCH v1 9/9] dwarf: Enable livepatch for ARM64 madvenka
2022-04-08 0:21 ` [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation Josh Poimboeuf
2022-04-08 11:41 ` Peter Zijlstra
2022-04-11 17:26 ` Madhavan T. Venkataraman
2022-04-11 17:18 ` Madhavan T. Venkataraman
2022-04-12 8:32 ` Chen Zhongjin
2022-04-16 0:56 ` Josh Poimboeuf
2022-04-18 12:28 ` Chen Zhongjin
2022-04-18 16:11 ` Josh Poimboeuf
2022-04-18 18:38 ` Madhavan T. Venkataraman
[not found] ` <844b3ede-eddb-cbe6-80e0-3529e2da2eb6@huawei.com>
2022-04-12 17:27 ` Madhavan T. Venkataraman
2022-04-16 1:07 ` Josh Poimboeuf
2022-04-14 14:11 ` Madhavan T. Venkataraman
2022-04-08 10:55 ` Peter Zijlstra
2022-04-08 11:54 ` Peter Zijlstra
2022-04-08 14:34 ` Josh Poimboeuf
2022-04-10 17:47 ` Madhavan T. Venkataraman
2022-04-11 16:34 ` Josh Poimboeuf
2022-04-08 12:06 ` Peter Zijlstra
2022-04-11 17:35 ` Madhavan T. Venkataraman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=574cbef1-89ce-3e43-cebb-5db1d8e854e5@linux.microsoft.com \
--to=madvenka@linux.microsoft.com \
--cc=ardb@kernel.org \
--cc=broonie@kernel.org \
--cc=catalin.marinas@arm.com \
--cc=jmorris@namei.org \
--cc=jpoimboe@redhat.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=mbenes@suse.cz \
--cc=nobuta.keiya@fujitsu.com \
--cc=sjitindarsingh@gmail.com \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome