From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com>
To: Mark Rutland <mark.rutland@arm.com>
Cc: broonie@kernel.org, jpoimboe@redhat.com, ardb@kernel.org,
nobuta.keiya@fujitsu.com, sjitindarsingh@gmail.com,
catalin.marinas@arm.com, will@kernel.org, jmorris@namei.org,
linux-arm-kernel@lists.infradead.org,
live-patching@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v13 04/11] arm64: Split unwind_init()
Date: Tue, 15 Feb 2022 12:04:06 -0600 [thread overview]
Message-ID: <dec185c2-305f-0d9a-6a2f-30cd1f4a6575@linux.microsoft.com> (raw)
In-Reply-To: <YgulrExdlfBcHoKP@FVFF77S0Q05N>
On 2/15/22 07:07, Mark Rutland wrote:
> Hi Madhavan,
>
> The diff itself largely looks good, but we need to actually write the comments.
> Can you pleaes pick up the wording I've written below for those?
>
> That and renaming `unwind_init_from_current` to `unwind_init_from_caller`.
>
> With those I think this is good, but I'd like to see the updated version before
> I provide Acked-by or Reviewed-by tags -- hopefully that's just a formality! :)
>
Will do.
Madhavan
> On Mon, Jan 17, 2022 at 08:56:01AM -0600, madvenka@linux.microsoft.com wrote:
>> From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com>
>>
>> unwind_init() is currently a single function that initializes all of the
>> unwind state. Split it into the following functions and call them
>> appropriately:
>>
>> - unwind_init_from_regs() - initialize from regs passed by caller.
>>
>> - unwind_init_from_current() - initialize for the current task
>> from the caller of arch_stack_walk().
>>
>> - unwind_init_from_task() - initialize from the saved state of a
>> task other than the current task. In this case, the other
>> task must not be running.
>>
>> This is done for two reasons:
>>
>> - the different ways of initializing are clear
>>
>> - specialized code can be added to each initializer in the future.
>>
>> Signed-off-by: Madhavan T. Venkataraman <madvenka@linux.microsoft.com>
>> ---
>> arch/arm64/kernel/stacktrace.c | 54 +++++++++++++++++++++++++++-------
>> 1 file changed, 44 insertions(+), 10 deletions(-)
>>
>> diff --git a/arch/arm64/kernel/stacktrace.c b/arch/arm64/kernel/stacktrace.c
>> index a1a7ff93b84f..b2b568e5deba 100644
>> --- a/arch/arm64/kernel/stacktrace.c
>> +++ b/arch/arm64/kernel/stacktrace.c
>> @@ -33,11 +33,8 @@
>> */
>>
>>
>> -static void unwind_init(struct unwind_state *state, unsigned long fp,
>> - unsigned long pc)
>> +static void unwind_init_common(struct unwind_state *state)
>> {
>> - state->fp = fp;
>> - state->pc = pc;
>> #ifdef CONFIG_KRETPROBES
>> state->kr_cur = NULL;
>> #endif
>> @@ -56,6 +53,46 @@ static void unwind_init(struct unwind_state *state, unsigned long fp,
>> state->prev_type = STACK_TYPE_UNKNOWN;
>> }
>>
>> +/*
>> + * TODO: document requirements here.
>> + */
>
> Please make this:
>
> /*
> * Start an unwind from a pt_regs.
> *
> * The unwind will begin at the PC within the regs.
> *
> * The regs must be on a stack currently owned by the calling task.
> */
>
>> +static inline void unwind_init_from_regs(struct unwind_state *state,
>> + struct pt_regs *regs)
>> +{
>
> In future we could add:
>
> WARN_ON_ONCE(!on_accessible_stack(current, regs, sizeof(*regs), NULL));
>
> ... to validate the requirements, but I'm happy to lave that for a future patch
> so this patch can be a pure refactoring.
>
>> + unwind_init_common(state);
>> +
>> + state->fp = regs->regs[29];
>> + state->pc = regs->pc;
>> +}
>> +
>> +/*
>> + * TODO: document requirements here.
>> + *
>> + * Note: this is always inlined, and we expect our caller to be a noinline
>> + * function, such that this starts from our caller's caller.
>> + */
>
> Please make this:
>
> /*
> * Start an unwind from a caller.
> *
> * The unwind will begin at the caller of whichever function this is inlined
> * into.
> *
> * The function which invokes this must be noinline.
> */
>
>> +static __always_inline void unwind_init_from_current(struct unwind_state *state)
>
> Can we please rename s/current/caller/ here? That way it's clear *where* in
> current we're unwinding from, and the fact that it's current is implicit but
> obvious.
>
>> +{
>
> Similarly to unwind_init_from_regs(), in a future patch we could add:
>
> WARN_ON_ONCE(task == current);
>
> ... but for now we can omit that so this patch can be a pure refactoring.
>
>> + unwind_init_common(state);
>> +
>> + state->fp = (unsigned long)__builtin_frame_address(1);
>> + state->pc = (unsigned long)__builtin_return_address(0);
>> +}
>> +
>> +/*
>> + * TODO: document requirements here.
>> + *
>> + * The caller guarantees that the task is not running.
>> + */
>
> Please make this:
>
> /*
> * Start an unwind from a blocked task.
> *
> * The unwind will begin at the blocked tasks saved PC (i.e. the caller of
> * cpu_switch_to()).
> *
> * The caller should ensure the task is blocked in cpu_switch_to() for the
> * duration of the unwind, or the unwind will be bogus. It is never valid to
> * call this for the current task.
> */
>
> Thanks,
> Mark.
>
>> +static inline void unwind_init_from_task(struct unwind_state *state,
>> + struct task_struct *task)
>> +{
>> + unwind_init_common(state);
>> +
>> + state->fp = thread_saved_fp(task);
>> + state->pc = thread_saved_pc(task);
>> +}
>> +
>> /*
>> * Unwind from one frame record (A) to the next frame record (B).
>> *
>> @@ -195,14 +232,11 @@ noinline notrace void arch_stack_walk(stack_trace_consume_fn consume_entry,
>> struct unwind_state state;
>>
>> if (regs)
>> - unwind_init(&state, regs->regs[29], regs->pc);
>> + unwind_init_from_regs(&state, regs);
>> else if (task == current)
>> - unwind_init(&state,
>> - (unsigned long)__builtin_frame_address(1),
>> - (unsigned long)__builtin_return_address(0));
>> + unwind_init_from_current(&state);
>> else
>> - unwind_init(&state, thread_saved_fp(task),
>> - thread_saved_pc(task));
>> + unwind_init_from_task(&state, task);
>>
>> unwind(task, &state, consume_entry, cookie);
>> }
>> --
>> 2.25.1
>>
next prev parent reply other threads:[~2022-02-15 18:04 UTC|newest]
Thread overview: 75+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <95691cae4f4504f33d0fc9075541b1e7deefe96f>
2022-01-17 14:55 ` [PATCH v13 00/11] arm64: Reorganize the unwinder and implement stack trace reliability checks madvenka
2022-01-17 14:55 ` [PATCH v13 01/11] arm64: Remove NULL task check from unwind_frame() madvenka
2022-01-17 14:55 ` [PATCH v13 02/11] arm64: Rename unwinder functions madvenka
2022-01-17 14:56 ` [PATCH v13 03/11] arm64: Rename stackframe to unwind_state madvenka
2022-01-17 14:56 ` [PATCH v13 04/11] arm64: Split unwind_init() madvenka
2022-02-02 18:44 ` Mark Brown
2022-02-03 0:26 ` Madhavan T. Venkataraman
2022-02-03 0:39 ` Madhavan T. Venkataraman
2022-02-03 11:29 ` Mark Brown
2022-02-15 13:07 ` Mark Rutland
2022-02-15 18:04 ` Madhavan T. Venkataraman [this message]
2022-01-17 14:56 ` [PATCH v13 05/11] arm64: Copy the task argument to unwind_state madvenka
2022-02-02 18:45 ` Mark Brown
2022-02-15 13:22 ` Mark Rutland
2022-02-22 16:53 ` Madhavan T. Venkataraman
2022-01-17 14:56 ` [PATCH v13 06/11] arm64: Use stack_trace_consume_fn and rename args to unwind() madvenka
2022-02-02 18:46 ` Mark Brown
2022-02-03 0:34 ` Madhavan T. Venkataraman
2022-02-03 11:30 ` Mark Brown
2022-02-03 14:45 ` Madhavan T. Venkataraman
2022-02-15 13:39 ` Mark Rutland
2022-02-15 18:12 ` Madhavan T. Venkataraman
2022-03-07 16:51 ` Madhavan T. Venkataraman
2022-03-07 17:01 ` Mark Brown
2022-03-08 22:00 ` Madhavan T. Venkataraman
2022-03-09 11:47 ` Mark Brown
2022-03-09 15:34 ` Madhavan T. Venkataraman
2022-03-10 8:33 ` Miroslav Benes
2022-03-10 12:36 ` Madhavan T. Venkataraman
2022-03-16 3:43 ` Josh Poimboeuf
2022-04-08 14:44 ` Mark Rutland
2022-04-08 17:58 ` Mark Rutland
2022-04-10 17:42 ` Madhavan T. Venkataraman
2022-04-10 17:33 ` Madhavan T. Venkataraman
2022-04-10 17:45 ` Madhavan T. Venkataraman
2022-01-17 14:56 ` [PATCH v13 07/11] arm64: Make the unwind loop in unwind() similar to other architectures madvenka
2022-01-17 14:56 ` [PATCH v13 08/11] arm64: Introduce stack trace reliability checks in the unwinder madvenka
2022-01-17 14:56 ` [PATCH v13 09/11] arm64: Create a list of SYM_CODE functions, check return PC against list madvenka
2022-01-17 14:56 ` [PATCH v13 10/11] arm64: Introduce arch_stack_walk_reliable() madvenka
2022-01-17 14:56 ` [PATCH v13 11/11] arm64: Select HAVE_RELIABLE_STACKTRACE madvenka
2022-01-25 5:21 ` nobuta.keiya
2022-01-25 13:43 ` Madhavan T. Venkataraman
2022-01-26 10:20 ` nobuta.keiya
2022-01-26 17:14 ` Madhavan T. Venkataraman
2022-01-27 1:13 ` nobuta.keiya
2022-01-26 17:16 ` Mark Brown
2022-04-07 20:25 ` [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation madvenka
2022-04-07 20:25 ` [RFC PATCH v1 1/9] objtool: Parse DWARF Call Frame Information in object files madvenka
2022-04-07 20:25 ` [RFC PATCH v1 2/9] objtool: Generate DWARF rules and place them in a special section madvenka
2022-04-07 20:25 ` [RFC PATCH v1 3/9] dwarf: Build the kernel with DWARF information madvenka
2022-04-07 20:25 ` [RFC PATCH v1 4/9] dwarf: Implement DWARF rule processing in the kernel madvenka
2022-04-07 20:25 ` [RFC PATCH v1 5/9] dwarf: Implement DWARF support for modules madvenka
2022-04-07 20:25 ` [RFC PATCH v1 6/9] arm64: unwinder: Add a reliability check in the unwinder based on DWARF CFI madvenka
2022-04-07 20:25 ` [RFC PATCH v1 7/9] arm64: dwarf: Implement unwind hints madvenka
2022-04-07 20:25 ` [RFC PATCH v1 8/9] dwarf: Miscellaneous changes required for enabling livepatch madvenka
2022-04-07 20:25 ` [RFC PATCH v1 9/9] dwarf: Enable livepatch for ARM64 madvenka
2022-04-08 0:21 ` [RFC PATCH v1 0/9] arm64: livepatch: Use DWARF Call Frame Information for frame pointer validation Josh Poimboeuf
2022-04-08 11:41 ` Peter Zijlstra
2022-04-11 17:26 ` Madhavan T. Venkataraman
2022-04-11 17:18 ` Madhavan T. Venkataraman
2022-04-12 8:32 ` Chen Zhongjin
2022-04-16 0:56 ` Josh Poimboeuf
2022-04-18 12:28 ` Chen Zhongjin
2022-04-18 16:11 ` Josh Poimboeuf
2022-04-18 18:38 ` Madhavan T. Venkataraman
[not found] ` <844b3ede-eddb-cbe6-80e0-3529e2da2eb6@huawei.com>
2022-04-12 17:27 ` Madhavan T. Venkataraman
2022-04-16 1:07 ` Josh Poimboeuf
2022-04-14 14:11 ` Madhavan T. Venkataraman
2022-04-08 10:55 ` Peter Zijlstra
2022-04-08 11:54 ` Peter Zijlstra
2022-04-08 14:34 ` Josh Poimboeuf
2022-04-10 17:47 ` Madhavan T. Venkataraman
2022-04-11 16:34 ` Josh Poimboeuf
2022-04-08 12:06 ` Peter Zijlstra
2022-04-11 17:35 ` Madhavan T. Venkataraman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=dec185c2-305f-0d9a-6a2f-30cd1f4a6575@linux.microsoft.com \
--to=madvenka@linux.microsoft.com \
--cc=ardb@kernel.org \
--cc=broonie@kernel.org \
--cc=catalin.marinas@arm.com \
--cc=jmorris@namei.org \
--cc=jpoimboe@redhat.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=live-patching@vger.kernel.org \
--cc=mark.rutland@arm.com \
--cc=nobuta.keiya@fujitsu.com \
--cc=sjitindarsingh@gmail.com \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome