mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Peter Ujfalusi <peter.ujfalusi@ti.com>
To: Rob Herring <robh@kernel.org>
Cc: <thierry.reding@gmail.com>, <airlied@linux.ie>,
	<tomi.valkeinen@ti.com>, <daniel.vetter@ffwll.ch>,
	<dri-devel@lists.freedesktop.org>, <linux-kernel@vger.kernel.org>,
	Mark Rutland <mark.rutland@arm.com>, <devicetree@vger.kernel.org>
Subject: Re: [PATCH 01/26] dt-bindings: display: display-timing: Add property to configure sync drive edge
Date: Mon, 12 Sep 2016 16:22:53 +0300	[thread overview]
Message-ID: <57580a7f-2462-3fb9-bb87-ff8387f7be38@ti.com> (raw)
In-Reply-To: <20160912130520.GA9582@rob-hp-laptop>

On 09/12/16 16:05, Rob Herring wrote:
> On Thu, Sep 01, 2016 at 02:22:55PM +0300, Peter Ujfalusi wrote:
>> There are display panels which demands that the sync signal is driven on
>> different edge than the pixel data.
>> With the syncclk-active property we can specify the clk edge to be used to
>> drive the sync signal. When the property is missing it indicates that the
>> sync is driven on the same edge as the pixel data.
>>
>> Signed-off-by: Peter Ujfalusi <peter.ujfalusi@ti.com>
>> CC: Rob Herring <robh+dt@kernel.org>
>> CC: Mark Rutland <mark.rutland@arm.com>
>> CC: devicetree@vger.kernel.org
>> ---
>>  Documentation/devicetree/bindings/display/panel/display-timing.txt | 6 ++++++
>>  1 file changed, 6 insertions(+)
>>
>> diff --git a/Documentation/devicetree/bindings/display/panel/display-timing.txt b/Documentation/devicetree/bindings/display/panel/display-timing.txt
>> index e1d4a0b59612..1436292e7a56 100644
>> --- a/Documentation/devicetree/bindings/display/panel/display-timing.txt
>> +++ b/Documentation/devicetree/bindings/display/panel/display-timing.txt
>> @@ -32,6 +32,12 @@ optional properties:
>>  			- active low  = drive pixel data on falling edge/
>>  					sample data on rising edge
>>  			- ignored     = ignored
>> + - syncclk-active: with
>> +			- active high = drive sync on rising edge/
> 
> rising edge of what? pixel clk?

Yes, pixel clk, I have copied and modified the 'pixelclk-active' option.
Probably it would be better to state it explicitly.

> 
>> +					sample sync on falling edge
>> +			- active low  = drive sync on falling edge/
>> +					sample sync on rising edge
>> +			- omitted     = same configuration as pixelclk-active
>>   - interlaced (bool): boolean to enable interlaced mode
>>   - doublescan (bool): boolean to enable doublescan mode
>>   - doubleclk (bool): boolean to enable doubleclock mode
>> -- 
>> 2.9.3
>>


-- 
Péter

  reply	other threads:[~2016-09-12 13:23 UTC|newest]

Thread overview: 36+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-09-01 11:22 [PATCH 00/26] drm/omap: Convert to use videomode from omap_video_timings Peter Ujfalusi
2016-09-01 11:22 ` [PATCH 01/26] dt-bindings: display: display-timing: Add property to configure sync drive edge Peter Ujfalusi
2016-09-12 13:05   ` Rob Herring
2016-09-12 13:22     ` Peter Ujfalusi [this message]
2016-09-01 11:22 ` [PATCH 02/26] video: display_timing: Add flags to select the edge when the sync is driven Peter Ujfalusi
2016-09-01 11:22 ` [PATCH 03/26] video: of: display_timing: Add support for syncclk-active property Peter Ujfalusi
2016-09-01 11:22 ` [PATCH 04/26] drm/omap: omap_display_timings: rename x_res to hactive Peter Ujfalusi
2016-09-15 11:58   ` Tomi Valkeinen
2016-09-01 11:22 ` [PATCH 05/26] drm/omap: omap_display_timings: rename y_res to vactive Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 06/26] drm/omap: omap_display_timings: rename hsw to hsync_len Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 07/26] drm/omap: omap_display_timings: rename hfp to hfront_porch Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 08/26] drm/omap: omap_display_timings: rename hbp to hback_porch Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 09/26] drm/omap: omap_display_timings: rename vsw to vsync_len Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 10/26] drm/omap: omap_display_timings: rename vfp to vfront_porch Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 11/26] drm/omap: omap_display_timings: rename vbp to vback_porch Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 12/26] drm/omap: HDMI5: Use pointer to cfg->v_fc_config.timings in hdmi_core_video_config Peter Ujfalusi
2016-09-15 12:03   ` Tomi Valkeinen
2016-09-01 11:23 ` [PATCH 13/26] drm/omap: omap_display_timings: Use display_flags for interlace mode Peter Ujfalusi
2016-09-15 12:06   ` Tomi Valkeinen
2016-09-01 11:23 ` [PATCH 14/26] drm/omap: dispc: Simplify _dispc_mgr_set_lcd_timings() parameters Peter Ujfalusi
2016-09-15 12:09   ` Tomi Valkeinen
2016-09-01 11:23 ` [PATCH 15/26] drm/omap: omap_display_timings: Use display_flags for h/vsync level Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 16/26] drm/omap: omap_display_timings: Use display_flags for DE level Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 17/26] drm/omap: omap_display_timings: Use display_flags for double_pixel mode Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 18/26] drm/omap: omap_display_timings: Use display_flags for pixel data edge Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 19/26] drm/omap: omap_display_timings: Use display_flags for sync edge Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 20/26] drm/omap: Change the types of struct omap_video_timings members Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 21/26] drm/omap: Replace struct omap_video_timings with videomode Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 22/26] drm/omap: Use consistent name for struct videomode Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 23/26] drm/omap: panel-tpo-td043mtea1: Add note for incorrect sync drive edge Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 24/26] drm/omap: panel-tpo-td028ttec1: " Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 25/26] drm/omap: panel-sharp-ls037v7dw01: Add note for incorrect data " Peter Ujfalusi
2016-09-01 11:23 ` [PATCH 26/26] drm/omap: panel-lgphilips-lb035q02: Add note for incorrect data drive edge and DE level Peter Ujfalusi
2016-12-14 21:32 ` [PATCH 00/26] drm/omap: Convert to use videomode from omap_video_timings Laurent Pinchart
2016-12-15  7:56   ` Tomi Valkeinen
2016-12-15  8:12   ` Peter Ujfalusi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=57580a7f-2462-3fb9-bb87-ff8387f7be38@ti.com \
    --to=peter.ujfalusi@ti.com \
    --cc=airlied@linux.ie \
    --cc=daniel.vetter@ffwll.ch \
    --cc=devicetree@vger.kernel.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mark.rutland@arm.com \
    --cc=robh@kernel.org \
    --cc=thierry.reding@gmail.com \
    --cc=tomi.valkeinen@ti.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®