From: AngeloGioacchino Del Regno <angelogioacchino.delregno@collabora.com>
To: Matthias Brugger <matthias.bgg@gmail.com>,
linux-mediatek@lists.infradead.org
Cc: linux-kernel@vger.kernel.org,
linux-arm-kernel@lists.infradead.org, kernel@collabora.com
Subject: Re: [PATCH v1 2/3] soc: mediatek: mtk-cmdq: Mark very unlikely branches as such
Date: Wed, 2 Oct 2024 15:02:51 +0200 [thread overview]
Message-ID: <5c5e3f7d-5ade-4625-bef9-4fcb7f717778@collabora.com> (raw)
In-Reply-To: <2cb6e2d6-226f-4a40-bdff-81baff8988a6@gmail.com>
Il 02/10/24 14:58, Matthias Brugger ha scritto:
>
>
> On 02/10/2024 14:43, AngeloGioacchino Del Regno wrote:
>> Il 02/10/24 14:41, Matthias Brugger ha scritto:
>>>
>>>
>>> On 18/09/2024 12:06, AngeloGioacchino Del Regno wrote:
>>>> Calling cmdq packet builders with an unsupported event number,
>>>> or without left/right operands (in the case of logic commands)
>>>> means that the caller (another driver) wants to perform an
>>>> unsupported operation, so this means that the caller must be
>>>> fixed instead.
>>>>
>>>> Anyway, such checks are here for safety and, unless any driver
>>>> bug or any kind of misconfiguration is present, will always be
>>>> false so add a very unlikely hint for those.
>>>>
>>>> Knowing that CPUs' branch predictors (and compilers, anyway) are
>>>> indeed smart about these cases, this is done mainly for human
>>>> readability purposes.
>>>>
>>>
>>> Are you really sure we need that? As you mentioned the unlikely() is probably
>>> useless as compiler and branch predictions will do the job. I don't see the
>>> complexity in the code to have this annotations for human readability.
>>>
>>> I would argue against using unlikely() here as, in general, it is discouraged to
>>> use it. We will just create a data point of doing things that should only be
>>> done with very good reason. I don't see the reason here, it will only confuse
>>> other developers about the use of likely() and unlikely().
>>>
>>
>> If you have strong opinions I have no problem dropping this.
>
> My take would be to drop it.
>
Let's drop it then. :-)
>> Perhaps I can add a comment stating "this is very unlikely to happen and should
>> be dropped after thorough cleanup", if that's better?
>>
>
> As these are exported functions they could be used by out-of-tree modules, so it
> could make sense to check the input parameter. Maybe transform it to WARN_ON(event
> >= CMDQ_MAX_EVENT)?
>
The reasoning behind all of this is that those functions are used in drivers'
performance paths, including display and camera.... so a WARN_ON would be even
more against what I'm trying to do.
At this point we can just leave this as it is....
> Regards,
> Matthias
>
>> Cheers!
>> Angelo
>>
>>> Regards,
>>> Matthias
>>>
>>>> Signed-off-by: AngeloGioacchino Del Regno
>>>> <angelogioacchino.delregno@collabora.com>
>>>> ---
>>>> drivers/soc/mediatek/mtk-cmdq-helper.c | 10 +++++-----
>>>> 1 file changed, 5 insertions(+), 5 deletions(-)
>>>>
>>>> diff --git a/drivers/soc/mediatek/mtk-cmdq-helper.c
>>>> b/drivers/soc/mediatek/mtk-cmdq-helper.c
>>>> index 620c371fd1fc..4ffd1a35df87 100644
>>>> --- a/drivers/soc/mediatek/mtk-cmdq-helper.c
>>>> +++ b/drivers/soc/mediatek/mtk-cmdq-helper.c
>>>> @@ -336,7 +336,7 @@ int cmdq_pkt_wfe(struct cmdq_pkt *pkt, u16 event, bool clear)
>>>> struct cmdq_instruction inst = { {0} };
>>>> u32 clear_option = clear ? CMDQ_WFE_UPDATE : 0;
>>>> - if (event >= CMDQ_MAX_EVENT)
>>>> + if (unlikely(event >= CMDQ_MAX_EVENT))
>>>> return -EINVAL;
>>>> inst.op = CMDQ_CODE_WFE;
>>>> @@ -351,7 +351,7 @@ int cmdq_pkt_acquire_event(struct cmdq_pkt *pkt, u16 event)
>>>> {
>>>> struct cmdq_instruction inst = {};
>>>> - if (event >= CMDQ_MAX_EVENT)
>>>> + if (unlikely(event >= CMDQ_MAX_EVENT))
>>>> return -EINVAL;
>>>> inst.op = CMDQ_CODE_WFE;
>>>> @@ -366,7 +366,7 @@ int cmdq_pkt_clear_event(struct cmdq_pkt *pkt, u16 event)
>>>> {
>>>> struct cmdq_instruction inst = { {0} };
>>>> - if (event >= CMDQ_MAX_EVENT)
>>>> + if (unlikely(event >= CMDQ_MAX_EVENT))
>>>> return -EINVAL;
>>>> inst.op = CMDQ_CODE_WFE;
>>>> @@ -381,7 +381,7 @@ int cmdq_pkt_set_event(struct cmdq_pkt *pkt, u16 event)
>>>> {
>>>> struct cmdq_instruction inst = {};
>>>> - if (event >= CMDQ_MAX_EVENT)
>>>> + if (unlikely(event >= CMDQ_MAX_EVENT))
>>>> return -EINVAL;
>>>> inst.op = CMDQ_CODE_WFE;
>>>> @@ -476,7 +476,7 @@ int cmdq_pkt_logic_command(struct cmdq_pkt *pkt, u16
>>>> result_reg_idx,
>>>> {
>>>> struct cmdq_instruction inst = { {0} };
>>>> - if (!left_operand || !right_operand || s_op >= CMDQ_LOGIC_MAX)
>>>> + if (unlikely(!left_operand || !right_operand || s_op >= CMDQ_LOGIC_MAX))
>>>> return -EINVAL;
>>>> inst.op = CMDQ_CODE_LOGIC;
>>
next prev parent reply other threads:[~2024-10-02 13:02 UTC|newest]
Thread overview: 16+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-09-18 10:06 [PATCH v1 0/3] soc: mediatek: mtk-cmdq-helper: Various cleanups AngeloGioacchino Del Regno
2024-09-18 10:06 ` [PATCH v1 1/3] soc: mediatek: mtk-cmdq: Move mask build and append to function AngeloGioacchino Del Regno
2024-10-02 12:33 ` Matthias Brugger
2024-09-18 10:06 ` [PATCH v1 2/3] soc: mediatek: mtk-cmdq: Mark very unlikely branches as such AngeloGioacchino Del Regno
2024-10-02 12:41 ` Matthias Brugger
2024-10-02 12:43 ` AngeloGioacchino Del Regno
2024-10-02 12:58 ` Matthias Brugger
2024-10-02 13:02 ` AngeloGioacchino Del Regno [this message]
2024-09-18 10:06 ` [PATCH v1 3/3] soc: mediatek: mtk-cmdq: Move cmdq_instruction init to declaration AngeloGioacchino Del Regno
2024-09-19 22:43 ` kernel test robot
2024-10-02 12:52 ` Matthias Brugger
2024-10-02 9:08 ` [PATCH v1 0/3] soc: mediatek: mtk-cmdq-helper: Various cleanups AngeloGioacchino Del Regno
2024-10-02 13:00 ` Matthias Brugger
2024-10-03 8:08 ` AngeloGioacchino Del Regno
2024-10-07 14:33 ` Matthias Brugger
2024-10-07 14:36 ` AngeloGioacchino Del Regno
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5c5e3f7d-5ade-4625-bef9-4fcb7f717778@collabora.com \
--to=angelogioacchino.delregno@collabora.com \
--cc=kernel@collabora.com \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-mediatek@lists.infradead.org \
--cc=matthias.bgg@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®