From: John Fastabend <john.fastabend@gmail.com>
To: Brian Vazquez <brianvv@google.com>,
Brian Vazquez <brianvv.kernel@gmail.com>,
Alexei Starovoitov <ast@kernel.org>,
Daniel Borkmann <daniel@iogearbox.net>,
"David S . Miller" <davem@davemloft.net>
Cc: Yonghong Song <yhs@fb.com>, Stanislav Fomichev <sdf@google.com>,
Petar Penkov <ppenkov@google.com>,
Willem de Bruijn <willemb@google.com>,
linux-kernel@vger.kernel.org, netdev@vger.kernel.org,
bpf@vger.kernel.org, Brian Vazquez <brianvv@google.com>
Subject: RE: [PATCH v2 bpf-next 2/9] bpf: add generic support for lookup and lookup_and_delete batch ops
Date: Fri, 22 Nov 2019 09:25:32 -0800 [thread overview]
Message-ID: <5dd81a0ca016a_690a2ae784a225c459@john-XPS-13-9370.notmuch> (raw)
In-Reply-To: <20191119193036.92831-3-brianvv@google.com>
Brian Vazquez wrote:
> This commit introduces generic support for the bpf_map_lookup_batch and
> bpf_map_lookup_and_delete_batch ops. This implementation can be used by
> almost all the bpf maps since its core implementation is relying on the
> existing map_get_next_key, map_lookup_elem and map_delete_elem
> functions. The bpf syscall subcommands introduced are:
>
> BPF_MAP_LOOKUP_BATCH
> BPF_MAP_LOOKUP_AND_DELETE_BATCH
>
> The UAPI attribute is:
>
> struct { /* struct used by BPF_MAP_*_BATCH commands */
> __aligned_u64 in_batch; /* start batch,
> * NULL to start from beginning
> */
> __aligned_u64 out_batch; /* output: next start batch */
> __aligned_u64 keys;
> __aligned_u64 values;
> __u32 count; /* input/output:
> * input: # of key/value
> * elements
> * output: # of filled elements
> */
> __u32 map_fd;
> __u64 elem_flags;
> __u64 flags;
> } batch;
>
> in_batch/out_batch are opaque values use to communicate between
> user/kernel space, in_batch/out_batch must be of key_size length.
>
> To start iterating from the beginning in_batch must be null,
> count is the # of key/value elements to retrieve. Note that the 'keys'
> buffer must be a buffer of key_size * count size and the 'values' buffer
> must be value_size * count, where value_size must be aligned to 8 bytes
> by userspace if it's dealing with percpu maps. 'count' will contain the
> number of keys/values successfully retrieved. Note that 'count' is an
> input/output variable and it can contain a lower value after a call.
>
> If there's no more entries to retrieve, ENOENT will be returned. If error
> is ENOENT, count might be > 0 in case it copied some values but there were
> no more entries to retrieve.
>
> Note that if the return code is an error and not -EFAULT,
> count indicates the number of elements successfully processed.
>
> Suggested-by: Stanislav Fomichev <sdf@google.com>
> Signed-off-by: Brian Vazquez <brianvv@google.com>
> Signed-off-by: Yonghong Song <yhs@fb.com>
> ---
> include/linux/bpf.h | 11 +++
> include/uapi/linux/bpf.h | 19 +++++
> kernel/bpf/syscall.c | 176 +++++++++++++++++++++++++++++++++++++++
> 3 files changed, 206 insertions(+)
>
Couple additional comments if we are getting a new rev anyways
[...]
> diff --git a/kernel/bpf/syscall.c b/kernel/bpf/syscall.c
> index cc714c9d5b4cc..d0d3d0e0eaca4 100644
> --- a/kernel/bpf/syscall.c
> +++ b/kernel/bpf/syscall.c
> @@ -1127,6 +1127,124 @@ static int map_get_next_key(union bpf_attr *attr)
> return err;
> }
>
> +static int __generic_map_lookup_batch(struct bpf_map *map,
> + const union bpf_attr *attr,
> + union bpf_attr __user *uattr,
> + bool do_delete)
> +{
> + void __user *ubatch = u64_to_user_ptr(attr->batch.in_batch);
> + void __user *uobatch = u64_to_user_ptr(attr->batch.out_batch);
> + void __user *values = u64_to_user_ptr(attr->batch.values);
> + void __user *keys = u64_to_user_ptr(attr->batch.keys);
> + void *buf, *prev_key, *key, *value;
> + u32 value_size, cp, max_count;
> + bool first_key = false;
> + int err, retry = 3;
^^^^^^^^^^
define magic value maybe MAP_LOOKUP_RETRIES
> +
> + if (attr->batch.elem_flags & ~BPF_F_LOCK)
> + return -EINVAL;
> + }
[...]
> +
> + value_size = bpf_map_value_size(map);
> +
> + max_count = attr->batch.count;
> + if (!max_count)
> + return 0;
> +
> + err = -ENOMEM;
> + buf = kmalloc(map->key_size + value_size, GFP_USER | __GFP_NOWARN);
Should we also set __GFP_NORETRY or __GFP_RETRY_MAYFAIL perhaps?
> + if (!buf)
> + goto err_put;
> +
> + err = -EFAULT;
> + first_key = false;
> + if (ubatch && copy_from_user(buf, ubatch, map->key_size))
> + goto free_buf;
> + key = buf;
> + value = key + map->key_size;
> + if (!ubatch) {
> + prev_key = NULL;
> + first_key = true;
> + }
> +
> +
nit: extra newline not needed
> + for (cp = 0; cp < max_count; cp++) {
> + if (cp || first_key) {
> + rcu_read_lock();
> + err = map->ops->map_get_next_key(map, prev_key, key);
> + rcu_read_unlock();
> + if (err)
> + break;
> + }
> + err = bpf_map_copy_value(map, key, value,
> + attr->batch.elem_flags, do_delete);
> +
> + if (err == -ENOENT) {
> + if (retry) {
> + retry--;
> + continue;
> + }
> + err = -EINTR;
> + break;
> + }
> +
> + if (err)
> + goto free_buf;
> +
> + if (copy_to_user(keys + cp * map->key_size, key,
> + map->key_size)) {
> + err = -EFAULT;
> + goto free_buf;
> + }
> + if (copy_to_user(values + cp * value_size, value, value_size)) {
> + err = -EFAULT;
> + goto free_buf;
You could do the same here as in the retry==0 above case, break and report
back up to user cp values?
> + }
> +
> + prev_key = key;
> + retry = 3;
^^^^^^^^^
same nit as above, use define so we can tune this if needed.
> + }
> + if (!err) {
> + rcu_read_lock();
> + err = map->ops->map_get_next_key(map, prev_key, key);
> + rcu_read_unlock();
> + }
> +
> + if ((copy_to_user(&uattr->batch.count, &cp, sizeof(cp)) ||
> + (copy_to_user(uobatch, key, map->key_size))))
> + err = -EFAULT;
> +
> +free_buf:
> + kfree(buf);
> +err_put:
> + return err;
> +}
next prev parent reply other threads:[~2019-11-22 17:25 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2019-11-19 19:30 [PATCH v2 bpf-next 0/9] add bpf batch ops to process more than 1 elem Brian Vazquez
2019-11-19 19:30 ` [PATCH v2 bpf-next 1/9] bpf: add bpf_map_{value_size,update_value,map_copy_value} functions Brian Vazquez
2019-11-22 16:36 ` John Fastabend
2019-11-19 19:30 ` [PATCH v2 bpf-next 2/9] bpf: add generic support for lookup and lookup_and_delete batch ops Brian Vazquez
2019-11-21 17:36 ` Yonghong Song
2019-11-21 21:36 ` Brian Vazquez
2019-11-22 0:34 ` Yonghong Song
2019-11-22 17:25 ` John Fastabend [this message]
2019-11-19 19:30 ` [PATCH v2 bpf-next 3/9] bpf: add generic support for update and delete " Brian Vazquez
2019-11-21 18:00 ` Yonghong Song
2019-11-22 5:50 ` Brian Vazquez
2019-11-22 6:56 ` Yonghong Song
2019-11-19 19:30 ` [PATCH v2 bpf-next 4/9] bpf: add lookup and updated batch ops to arraymap Brian Vazquez
2019-11-19 19:30 ` [PATCH v2 bpf-next 5/9] bpf: add batch ops to all htab bpf map Brian Vazquez
2019-11-21 18:27 ` Yonghong Song
2019-11-21 21:27 ` Brian Vazquez
2019-11-19 19:30 ` [PATCH v2 bpf-next 6/9] tools/bpf: sync uapi header bpf.h Brian Vazquez
2019-11-19 19:30 ` [PATCH v2 bpf-next 7/9] libbpf: add libbpf support to batch ops Brian Vazquez
2019-11-21 18:30 ` Yonghong Song
2019-11-19 19:30 ` [PATCH v2 bpf-next 8/9] selftests/bpf: add batch ops testing for hmap and hmap_percpu Brian Vazquez
2019-11-21 18:36 ` Yonghong Song
2019-11-21 21:16 ` Brian Vazquez
2019-11-19 19:30 ` [PATCH v2 bpf-next 9/9] selftests/bpf: add batch ops testing to array bpf map Brian Vazquez
2019-11-21 18:43 ` Yonghong Song
2019-11-21 21:14 ` Brian Vazquez
2019-11-22 0:22 ` Yonghong Song
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5dd81a0ca016a_690a2ae784a225c459@john-XPS-13-9370.notmuch \
--to=john.fastabend@gmail.com \
--cc=ast@kernel.org \
--cc=bpf@vger.kernel.org \
--cc=brianvv.kernel@gmail.com \
--cc=brianvv@google.com \
--cc=daniel@iogearbox.net \
--cc=davem@davemloft.net \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=ppenkov@google.com \
--cc=sdf@google.com \
--cc=willemb@google.com \
--cc=yhs@fb.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®