From: Devarsh Thakkar <devarsht@ti.com>
To: Jayesh Choudhary <j-choudhary@ti.com>, <jyri.sarha@iki.fi>,
<maarten.lankhorst@linux.intel.com>, <mripard@kernel.org>,
<tzimmermann@suse.de>, <dri-devel@lists.freedesktop.org>,
<tomi.valkeinen@ideasonboard.com>, <mwalle@kernel.org>
Cc: <airlied@gmail.com>, <simona@ffwll.ch>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v3 3/3] drm/tidss: oldi: Add atomic_check hook for oldi bridge
Date: Tue, 1 Jul 2025 19:22:20 +0530 [thread overview]
Message-ID: <5ed30153-53e0-4f1f-9c45-2f2530b9034e@ti.com> (raw)
In-Reply-To: <20250701095541.190422-4-j-choudhary@ti.com>
On 01/07/25 15:25, Jayesh Choudhary wrote:
> Since OLDI consumes DSS VP clock directly as serial clock, certain
> checks cannot be performed in tidss driver which should be checked
> in oldi driver. Add check for mode clock and set the curr_max_pclk
> field for tidss in case the VP is OLDI.
>
> Signed-off-by: Jayesh Choudhary <j-choudhary@ti.com>
> ---
> drivers/gpu/drm/tidss/tidss_oldi.c | 24 ++++++++++++++++++++++++
> 1 file changed, 24 insertions(+)
>
> diff --git a/drivers/gpu/drm/tidss/tidss_oldi.c b/drivers/gpu/drm/tidss/tidss_oldi.c
> index 63e07c8edeaa..a1f5fb39b32c 100644
> --- a/drivers/gpu/drm/tidss/tidss_oldi.c
> +++ b/drivers/gpu/drm/tidss/tidss_oldi.c
> @@ -309,6 +309,29 @@ static u32 *tidss_oldi_atomic_get_input_bus_fmts(struct drm_bridge *bridge,
> return input_fmts;
> }
>
> +static int tidss_oldi_bridge_atomic_check(struct drm_bridge *bridge,
> + struct drm_bridge_state *bridge_state,
> + struct drm_crtc_state *crtc_state,
> + struct drm_connector_state *conn_state)
> +{
> + struct tidss_oldi *oldi = drm_bridge_to_tidss_oldi(bridge);
> + struct drm_display_mode *adjusted_mode;
> + unsigned long round_clock;
> +
> + adjusted_mode = &crtc_state->adjusted_mode;
> +
> + if (adjusted_mode->clock > oldi->tidss->curr_max_pclk[oldi->parent_vp]) {
> + round_clock = clk_round_rate(oldi->serial, adjusted_mode->clock * 7 * 1000);
> +
> + if (dispc_pclk_diff(adjusted_mode->clock * 7 * 1000, round_clock) > 5)
> + return -EINVAL;
> +
> + oldi->tidss->curr_max_pclk[oldi->parent_vp] = round_clock;
> + }
> +
> + return 0;
> +}
> +
> static const struct drm_bridge_funcs tidss_oldi_bridge_funcs = {
> .attach = tidss_oldi_bridge_attach,
> .atomic_pre_enable = tidss_oldi_atomic_pre_enable,
> @@ -317,6 +340,7 @@ static const struct drm_bridge_funcs tidss_oldi_bridge_funcs = {
> .atomic_duplicate_state = drm_atomic_helper_bridge_duplicate_state,
> .atomic_destroy_state = drm_atomic_helper_bridge_destroy_state,
> .atomic_reset = drm_atomic_helper_bridge_reset,
> + .atomic_check = tidss_oldi_bridge_atomic_check,
Nitpick: looks like some mismatch in naming convention.
We don't use bridge for other atomic calls for e.g.
tidss_oldi_atomic_pre_enable, tidss_oldi_atomic_post_disable so maybe
change those too ?
With suggested change,
Reviewed-by: Devarsh Thakkar <devarsht@ti.com>
Regards
Devarsh
> };
>
> static int get_oldi_mode(struct device_node *oldi_tx, int *companion_instance)
next prev parent reply other threads:[~2025-07-01 13:52 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-07-01 9:55 [PATCH v3 0/3] Decouple max_pclk check from constant display feats Jayesh Choudhary
2025-07-01 9:55 ` [PATCH v3 1/3] drm/tidss: oldi: Add property to identify OLDI supported VP Jayesh Choudhary
2025-07-01 12:04 ` Devarsh Thakkar
2025-07-01 9:55 ` [PATCH v3 2/3] drm/tidss: Remove max_pclk_khz from tidss display features Jayesh Choudhary
2025-07-01 13:12 ` Devarsh Thakkar
2025-07-02 6:35 ` Jayesh Choudhary
2025-07-01 9:55 ` [PATCH v3 3/3] drm/tidss: oldi: Add atomic_check hook for oldi bridge Jayesh Choudhary
2025-07-01 13:52 ` Devarsh Thakkar [this message]
2025-07-02 6:21 ` Jayesh Choudhary
2025-07-01 13:30 ` [PATCH v3 0/3] Decouple max_pclk check from constant display feats Devarsh Thakkar
2025-07-02 7:01 ` Jayesh Choudhary
2025-07-02 8:37 ` Devarsh Thakkar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=5ed30153-53e0-4f1f-9c45-2f2530b9034e@ti.com \
--to=devarsht@ti.com \
--cc=airlied@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=j-choudhary@ti.com \
--cc=jyri.sarha@iki.fi \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=mwalle@kernel.org \
--cc=simona@ffwll.ch \
--cc=tomi.valkeinen@ideasonboard.com \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®