mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Johannes Berg <johannes@sipsolutions.net>
To: David Lin <yu-hao.lin@nxp.com>, linux-wireless@vger.kernel.org
Cc: linux-kernel@vger.kernel.org, briannorris@chromium.org,
	kvalo@kernel.org,  francesco@dolcini.it,
	tsung-hsien.hsieh@nxp.com
Subject: Re: [PATCH 00/43] wifi: nxpwifi: create nxpwifi to support iw61x
Date: Fri, 21 Jun 2024 20:20:08 +0200	[thread overview]
Message-ID: <5f5c42585e168e252a5fa3f43325aaa360f6d27a.camel@sipsolutions.net> (raw)
In-Reply-To: <20240621075208.513497-1-yu-hao.lin@nxp.com>

On Fri, 2024-06-21 at 15:51 +0800, David Lin wrote:
> 
>   wifi: nxpwifi: add ioctl.h

even the name here sounds questionable :)

>  48 files changed, 34928 insertions(+)
> 

This is ... huge. I don't know who could possibly review it at all.

A quick look suggests that it's got a bunch of things we probably really
don't want to do that way any more, like

using semaphores in a wifi driver:

> +#include <linux/semaphore.h>

having a bunch of (sometimes wrong!) element definitions in a driver:

> +struct ieee_types_aid {
...
> +	u16 aid;

embedding a (default?) wireless_dev when clearly the driver supports
more than one netdev/wdev:

> +	struct wireless_dev wdev;

Having multiple own workqueues is probably also unreasonable:

> +	struct workqueue_struct *dfs_cac_workqueue;
> +	struct workqueue_struct *dfs_chan_sw_workqueue;
> +	struct workqueue_struct *workqueue;
> +	struct workqueue_struct *rx_workqueue;
> +	struct workqueue_struct *host_mlme_workqueue;

as is a misnamed mutex, but really you could use wiphy work and likely
not have a mutex at all:

> +	/* mutex for scan */
> +	struct mutex async_mutex;

(even mac80211 only has one mutex left, and that's for a specific case
where otherwise we have some issues!)

questionable locking schemes, as evidenced simply by "is something
locked" variables existing:

> +	bool rx_locked;
> +	bool main_locked;

locking code, rather than data?

> +	/* spin lock for main process */
> +	spinlock_t main_proc_lock;

but also simple things like not wanting to use ERR_PTR()?

> +static int nxpwifi_register(void *card, struct device *dev,
> +			    struct nxpwifi_if_ops *if_ops, void **padapter)

(padapter is an out parameter)

Why random numbers for cookies instead of just assigning from a static
variable:

> +		*cookie = get_random_u32() | 1;

Open-coding -EPERM?

> +	if (nxpwifi_deinit_priv_params(priv))
> +		return -1;

Using -EFAULT for FW errors seems like a really bad idea:

> +	if (nxpwifi_drv_get_data_rate(priv, &rate)) {
> +		nxpwifi_dbg(priv->adapter, ERROR,
> +			    "getting data rate error\n");
> +		return -EFAULT;


But I really just scrolled through this briefly, this wasn't a real
review. I don't know who could do a real review, but as is, it looks
like someone _should_.

johannes

  parent reply	other threads:[~2024-06-21 18:20 UTC|newest]

Thread overview: 57+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-06-21  7:51 David Lin
2024-06-21  7:51 ` [PATCH 01/43] wifi: nxpwifi: add 11ac.c David Lin
2024-06-28  8:22   ` Abel Vesa
2024-07-01  0:46     ` [EXT] " David Lin
2024-06-21  7:51 ` [PATCH 02/43] wifi: nxpwifi: add 11ac.h David Lin
2024-06-21  7:51 ` [PATCH 03/43] wifi: nxpwifi: add 11h.c David Lin
2024-06-21  7:51 ` [PATCH 04/43] wifi: nxpwifi: add 11n.c David Lin
2024-06-21  7:51 ` [PATCH 05/43] wifi: nxpwifi: add 11n.h David Lin
2024-06-21  7:51 ` [PATCH 06/43] wifi: nxpwifi: add 11n_aggr.c David Lin
2024-06-21  7:51 ` [PATCH 07/43] wifi: nxpwifi: add 11n_aggr.h David Lin
2024-06-21  7:51 ` [PATCH 08/43] wifi: nxpwifi: add 11n_rxreorder.c David Lin
2024-06-21  7:51 ` [PATCH 09/43] wifi: nxpwifi: add 11n_rxreorder.h David Lin
2024-06-21  7:51 ` [PATCH 10/43] wifi: nxpwifi: add cfg80211.c David Lin
2024-06-21  7:51 ` [PATCH 11/43] wifi: nxpwifi: add cfg80211.h David Lin
2024-06-21  7:51 ` [PATCH 12/43] wifi: nxpwifi: add cfp.c David Lin
2024-06-21  7:51 ` [PATCH 13/43] wifi: nxpwifi: add cmdevt.c David Lin
2024-06-21  7:51 ` [PATCH 14/43] wifi: nxpwifi: add cmdevt.h David Lin
2024-06-21  7:51 ` [PATCH 15/43] wifi: nxpwifi: add debugfs.c David Lin
2024-06-21  7:51 ` [PATCH 16/43] wifi: nxpwifi: add decl.h David Lin
2024-06-21  7:51 ` [PATCH 17/43] wifi: nxpwifi: add ethtool.c David Lin
2024-06-21  7:51 ` [PATCH 18/43] wifi: nxpwifi: add fw.h David Lin
2024-06-21  7:51 ` [PATCH 19/43] wifi: nxpwifi: add ie.c David Lin
2024-06-21  7:51 ` [PATCH 20/43] wifi: nxpwifi: add init.c David Lin
2024-06-21  7:51 ` [PATCH 21/43] wifi: nxpwifi: add ioctl.h David Lin
2024-06-21  7:51 ` [PATCH 22/43] wifi: nxpwifi: add join.c David Lin
2024-06-21  7:51 ` [PATCH 23/43] wifi: nxpwifi: add main.c David Lin
2024-06-21  7:51 ` [PATCH 24/43] wifi: nxpwifi: add main.h David Lin
2024-06-21  7:51 ` [PATCH 25/43] wifi: nxpwifi: add scan.c David Lin
2024-06-21  7:51 ` [PATCH 26/43] wifi: nxpwifi: add sdio.c David Lin
2024-06-26 11:40   ` [EXTERNAL] " Nemanov, Michael
2024-06-27  3:37     ` [EXT] " David Lin
2024-06-27  6:26       ` Nemanov, Michael
2024-06-27  6:33         ` [EXT] " David Lin
2024-06-21  7:51 ` [PATCH 27/43] wifi: nxpwifi: add sdio.h David Lin
2024-06-21  7:51 ` [PATCH 28/43] wifi: nxpwifi: add sta_cmd.c David Lin
2024-06-21  7:51 ` [PATCH 29/43] wifi: nxpwifi: add sta_event.c David Lin
2024-06-21  7:51 ` [PATCH 30/43] wifi: nxpwifi: add sta_ioctl.c David Lin
2024-06-21  7:51 ` [PATCH 31/43] wifi: nxpwifi: add sta_rx.c David Lin
2024-06-21  7:51 ` [PATCH 32/43] wifi: nxpwifi: add sta_tx.c David Lin
2024-06-21  7:51 ` [PATCH 33/43] wifi: nxpwifi: add txrx.c David Lin
2024-06-21  7:51 ` [PATCH 34/43] wifi: nxpwifi: add uap_cmd.c David Lin
2024-06-21  7:52 ` [PATCH 35/43] wifi: nxpwifi: add uap_event.c David Lin
2024-06-21  7:52 ` [PATCH 36/43] wifi: nxpwifi: add uap_txrx.c David Lin
2024-06-21  7:52 ` [PATCH 37/43] wifi: nxpwifi: add util.c David Lin
2024-06-21  7:52 ` [PATCH 38/43] wifi: nxpwifi: add util.h David Lin
2024-06-21  7:52 ` [PATCH 39/43] wifi: nxpwifi: add wmm.c David Lin
2024-06-21  7:52 ` [PATCH 40/43] wifi: nxpwifi: add wmm.h David Lin
2024-06-21  7:52 ` [PATCH 41/43] wifi: nxpwifi: add nxp sdio vendor id and iw61x device id David Lin
2024-06-21  7:52 ` [PATCH 42/43] wifi: nxpwifi: add Makefile and Kconfig files for nxpwifi compilation David Lin
2024-06-26  0:19   ` kernel test robot
2024-06-26  0:24   ` kernel test robot
2024-06-28  4:46   ` kernel test robot
2024-06-21  7:52 ` [PATCH 43/43] wifi: nxpwifi: add nxpwifi related information to MAINTAINERS David Lin
2024-06-21 17:53 ` [PATCH 00/43] wifi: nxpwifi: create nxpwifi to support iw61x Brian Norris
2024-06-21 18:20 ` Johannes Berg [this message]
2024-07-01  1:08   ` [EXT] " David Lin
     [not found] <PAWPR04MB9910AE0CBBFAE748D265EAE09CFE2@PAWPR04MB9910.eurprd04.prod.outlook.com>
2025-02-14  5:52 ` Jeff Chen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=5f5c42585e168e252a5fa3f43325aaa360f6d27a.camel@sipsolutions.net \
    --to=johannes@sipsolutions.net \
    --cc=briannorris@chromium.org \
    --cc=francesco@dolcini.it \
    --cc=kvalo@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=tsung-hsien.hsieh@nxp.com \
    --cc=yu-hao.lin@nxp.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®