From: "Huang, Kai" <kai.huang@intel.com>
To: "Hansen, Dave" <dave.hansen@intel.com>,
"seanjc@google.com" <seanjc@google.com>,
"bp@alien8.de" <bp@alien8.de>,
"peterz@infradead.org" <peterz@infradead.org>,
"hpa@zytor.com" <hpa@zytor.com>,
"mingo@redhat.com" <mingo@redhat.com>,
"Williams, Dan J" <dan.j.williams@intel.com>,
"kirill.shutemov@linux.intel.com"
<kirill.shutemov@linux.intel.com>,
"pbonzini@redhat.com" <pbonzini@redhat.com>,
"tglx@linutronix.de" <tglx@linutronix.de>
Cc: "Gao, Chao" <chao.gao@intel.com>,
"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
"binbin.wu@linux.intel.com" <binbin.wu@linux.intel.com>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"Edgecombe, Rick P" <rick.p.edgecombe@intel.com>,
"x86@kernel.org" <x86@kernel.org>,
"Yamahata, Isaku" <isaku.yamahata@intel.com>
Subject: Re: [PATCH v2 07/10] x86/virt/tdx: Start to track all global metadata in one structure
Date: Tue, 6 Aug 2024 11:29:07 +0000 [thread overview]
Message-ID: <62724437435e0cc6d5637ce7a4cb919b0b8bfea6.camel@intel.com> (raw)
In-Reply-To: <66b19dc6ddbcf_4fc7294fd@dwillia2-xfh.jf.intel.com.notmuch>
On Mon, 2024-08-05 at 20:51 -0700, Williams, Dan J wrote:
> Kai Huang wrote:
> > The TDX module provides a set of "global metadata fields". They report
> > things like TDX module version, supported features, and fields related
> > to create/run TDX guests and so on.
> >
> > Currently the kernel only reads "TD Memory Region" (TDMR) related fields
> > for module initialization. There are immediate needs which require the
> > TDX module initialization to read more global metadata including module
> > version, supported features and "Convertible Memory Regions" (CMRs).
> >
> > Also, KVM will need to read more metadata fields to support baseline TDX
> > guests. In the longer term, other TDX features like TDX Connect (which
> > supports assigning trusted IO devices to TDX guest) may also require
> > other kernel components such as pci/vt-d to access global metadata.
> >
> > To meet all those requirements, the idea is the TDX host core-kernel to
> > to provide a centralized, canonical, and read-only structure for the
> > global metadata that comes out from the TDX module for all kernel
> > components to use.
> >
> > As the first step, introduce a new 'struct tdx_sysinfo' to track all
> > global metadata fields.
> >
> > TDX categories global metadata fields into different "Class"es. E.g.,
> > the current TDMR related fields are under class "TDMR Info". Instead of
> > making 'struct tdx_sysinfo' a plain structure to contain all metadata
> > fields, organize them in smaller structures based on the "Class".
> >
> > This allows those metadata fields to be used in finer granularity thus
> > makes the code more clear. E.g., the current construct_tdmr() can just
> > take the structure which contains "TDMR Info" metadata fields.
> >
> > Start with moving 'struct tdx_tdmr_sysinfo' to 'struct tdx_sysinfo', and
> > rename 'struct tdx_tdmr_sysinfo' to 'struct tdx_sysinfo_tdmr_info' to
> > make it consistent with the "class name".
>
> How about 'struct tdx_sys_info' and 'struct tdx_sys_tdmr_info' to avoid
> duplicating 'info' in the symbol name?
Fine to me. Will do.
>
> Do pure renames indpendent of logic changes to make patches like
> this easier to read.
>
> I would also move the pure rename to the front of the patches so the
> reviewer spends as minimal amount of time with the deprecated name in
> the set.
OK. I'll split out the pure rename patch and move it to earlier place.
[...]
> > +
> > +/* Class "TDMR Info" */
> > +struct tdx_sysinfo_tdmr_info {
> > + u16 max_tdmrs;
> > + u16 max_reserved_per_tdmr;
> > + u16 pamt_entry_size[TDX_PS_NR];
> > +};
> > +
> > +struct tdx_sysinfo {
> > + struct tdx_sysinfo_tdmr_info tdmr_info;
> > +};
>
> I would just call this member 'tdmr' since the 'info' is already applied
> by being in tdx_sys_info.
Yeah fine to me. Thanks.
next prev parent reply other threads:[~2024-08-06 11:29 UTC|newest]
Thread overview: 44+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-07-17 3:40 [PATCH v2 00/10] TDX host: metadata reading tweaks, bug fix and info dump Kai Huang
2024-07-17 3:40 ` [PATCH v2 01/10] x86/virt/tdx: Rename _offset to _member for TD_SYSINFO_MAP() macro Kai Huang
2024-08-05 22:37 ` Dan Williams
2024-07-17 3:40 ` [PATCH v2 02/10] x86/virt/tdx: Unbind global metadata read with 'struct tdx_tdmr_sysinfo' Kai Huang
2024-08-05 23:32 ` Dan Williams
2024-08-06 0:09 ` Huang, Kai
2024-08-06 1:13 ` Dan Williams
2024-08-07 12:09 ` Huang, Kai
2024-08-26 15:38 ` Adrian Hunter
2024-08-26 22:40 ` Huang, Kai
2024-08-27 4:54 ` Adrian Hunter
2024-08-27 7:22 ` Huang, Kai
2024-07-17 3:40 ` [PATCH v2 03/10] x86/virt/tdx: Support global metadata read for all element sizes Kai Huang
2024-08-05 23:45 ` Dan Williams
2024-07-17 3:40 ` [PATCH v2 04/10] x86/virt/tdx: Abstract reading multiple global metadata fields as a helper Kai Huang
2024-07-17 3:40 ` [PATCH v2 05/10] x86/virt/tdx: Move field mapping table of getting TDMR info to function local Kai Huang
2024-08-05 23:48 ` Dan Williams
2024-07-17 3:40 ` [PATCH v2 06/10] x86/virt/tdx: Refine a comment to reflect the latest TDX spec Kai Huang
2024-08-06 3:43 ` Dan Williams
2024-08-06 11:23 ` Huang, Kai
2024-08-06 19:06 ` Dan Williams
2024-08-06 21:01 ` Huang, Kai
2024-07-17 3:40 ` [PATCH v2 07/10] x86/virt/tdx: Start to track all global metadata in one structure Kai Huang
2024-08-06 3:51 ` Dan Williams
2024-08-06 11:29 ` Huang, Kai [this message]
2024-07-17 3:40 ` [PATCH v2 08/10] x86/virt/tdx: Print TDX module basic information Kai Huang
2024-08-06 4:19 ` Dan Williams
2024-08-06 11:51 ` Huang, Kai
2024-08-06 12:48 ` Huang, Kai
2024-08-07 21:56 ` Dan Williams
2024-08-07 22:32 ` Huang, Kai
2024-08-08 10:31 ` Chenyi Qiang
2024-08-08 23:52 ` Huang, Kai
2024-07-17 3:40 ` [PATCH v2 09/10] x86/virt/tdx: Reduce TDMR's reserved areas by using CMRs to find memory holes Kai Huang
2024-08-06 4:47 ` Dan Williams
2024-08-06 12:17 ` Huang, Kai
2024-08-20 18:38 ` Adrian Hunter
2024-08-27 7:24 ` Huang, Kai
2024-07-17 3:40 ` [PATCH v2 10/10] x86/virt/tdx: Don't initialize module that doesn't support NO_RBP_MOD feature Kai Huang
2024-08-06 4:55 ` Dan Williams
2024-08-06 12:18 ` Huang, Kai
2024-08-05 12:03 ` [PATCH v2 00/10] TDX host: metadata reading tweaks, bug fix and info dump Huang, Kai
2024-08-05 22:36 ` Dan Williams
2024-08-08 0:19 ` Huang, Kai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=62724437435e0cc6d5637ce7a4cb919b0b8bfea6.camel@intel.com \
--to=kai.huang@intel.com \
--cc=binbin.wu@linux.intel.com \
--cc=bp@alien8.de \
--cc=chao.gao@intel.com \
--cc=dan.j.williams@intel.com \
--cc=dave.hansen@intel.com \
--cc=hpa@zytor.com \
--cc=isaku.yamahata@intel.com \
--cc=kirill.shutemov@linux.intel.com \
--cc=kvm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=pbonzini@redhat.com \
--cc=peterz@infradead.org \
--cc=rick.p.edgecombe@intel.com \
--cc=seanjc@google.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®