mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Huang, Kai" <kai.huang@intel.com>
To: "Hansen, Dave" <dave.hansen@intel.com>,
	"seanjc@google.com" <seanjc@google.com>,
	"bp@alien8.de" <bp@alien8.de>,
	"peterz@infradead.org" <peterz@infradead.org>,
	"hpa@zytor.com" <hpa@zytor.com>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"Williams, Dan J" <dan.j.williams@intel.com>,
	"kirill.shutemov@linux.intel.com"
	<kirill.shutemov@linux.intel.com>,
	"pbonzini@redhat.com" <pbonzini@redhat.com>,
	"tglx@linutronix.de" <tglx@linutronix.de>
Cc: "Gao, Chao" <chao.gao@intel.com>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"binbin.wu@linux.intel.com" <binbin.wu@linux.intel.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"Edgecombe, Rick P" <rick.p.edgecombe@intel.com>,
	"x86@kernel.org" <x86@kernel.org>,
	"Yamahata, Isaku" <isaku.yamahata@intel.com>
Subject: Re: [PATCH v2 10/10] x86/virt/tdx: Don't initialize module that doesn't support NO_RBP_MOD feature
Date: Tue, 6 Aug 2024 12:18:29 +0000	[thread overview]
Message-ID: <cc6e40872469ccfc58e7648f12bba5a0b1a54c65.camel@intel.com> (raw)
In-Reply-To: <66b1aca950924_4fc7294f2@dwillia2-xfh.jf.intel.com.notmuch>

On Mon, 2024-08-05 at 21:55 -0700, Williams, Dan J wrote:
> Kai Huang wrote:
> > Old TDX modules can clobber RBP in the TDH.VP.ENTER SEAMCALL.  However
> > RBP is used as frame pointer in the x86_64 calling convention, and
> > clobbering RBP could result in bad things like being unable to unwind
> > the stack if any non-maskable exceptions (NMI, #MC etc) happens in that
> > gap.
> > 
> > A new "NO_RBP_MOD" feature was introduced to more recent TDX modules to
> > not clobber RBP.  This feature is reported in the TDX_FEATURES0 global
> > metadata field via bit 18.
> > 
> > Don't initialize the TDX module if this feature is not supported [1].
> > 
> > Link: https://lore.kernel.org/all/c0067319-2653-4cbd-8fee-1ccf21b1e646@suse.com/T/#mef98469c51e2382ead2c537ea189752360bd2bef [1]
> > Signed-off-by: Kai Huang <kai.huang@intel.com>
> > Reviewed-by: Nikolay Borisov <nik.borisov@suse.com>
> > ---
> > 
> > v1 -> v2:
> >  - Add tag from Nikolay.
> > 
> > ---
> >  arch/x86/virt/vmx/tdx/tdx.c | 17 +++++++++++++++++
> >  arch/x86/virt/vmx/tdx/tdx.h |  1 +
> >  2 files changed, 18 insertions(+)
> > 
> > diff --git a/arch/x86/virt/vmx/tdx/tdx.c b/arch/x86/virt/vmx/tdx/tdx.c
> > index 3c19295f1f8f..ec6156728423 100644
> > --- a/arch/x86/virt/vmx/tdx/tdx.c
> > +++ b/arch/x86/virt/vmx/tdx/tdx.c
> > @@ -484,6 +484,18 @@ static int get_tdx_sysinfo(struct tdx_sysinfo *sysinfo)
> >  	return get_tdx_tdmr_sysinfo(&sysinfo->tdmr_info);
> >  }
> >  
> > +static int check_module_compatibility(struct tdx_sysinfo *sysinfo)
> 
> How about check_features()? Almost everything having to do with TDX
> concerns the TDX module, so using "module" in a symbol name rarely adds
> any useful context.

Yeah fine to me.  Will do.
> 
> > +{
> > +	u64 tdx_features0 = sysinfo->module_info.tdx_features0;
> > +
> > +	if (!(tdx_features0 & TDX_FEATURES0_NO_RBP_MOD)) {
> > +		pr_err("NO_RBP_MOD feature is not supported\n");
> 
> A user would have no idea with this error message how about something
> like:
> 
> pr_err("frame pointer (RBP) clobber bug present, upgrade TDX module\n");

Yeah this is certainly better.  Will do.  Thanks!

  reply	other threads:[~2024-08-06 12:18 UTC|newest]

Thread overview: 44+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-07-17  3:40 [PATCH v2 00/10] TDX host: metadata reading tweaks, bug fix and info dump Kai Huang
2024-07-17  3:40 ` [PATCH v2 01/10] x86/virt/tdx: Rename _offset to _member for TD_SYSINFO_MAP() macro Kai Huang
2024-08-05 22:37   ` Dan Williams
2024-07-17  3:40 ` [PATCH v2 02/10] x86/virt/tdx: Unbind global metadata read with 'struct tdx_tdmr_sysinfo' Kai Huang
2024-08-05 23:32   ` Dan Williams
2024-08-06  0:09     ` Huang, Kai
2024-08-06  1:13       ` Dan Williams
2024-08-07 12:09         ` Huang, Kai
2024-08-26 15:38           ` Adrian Hunter
2024-08-26 22:40             ` Huang, Kai
2024-08-27  4:54               ` Adrian Hunter
2024-08-27  7:22                 ` Huang, Kai
2024-07-17  3:40 ` [PATCH v2 03/10] x86/virt/tdx: Support global metadata read for all element sizes Kai Huang
2024-08-05 23:45   ` Dan Williams
2024-07-17  3:40 ` [PATCH v2 04/10] x86/virt/tdx: Abstract reading multiple global metadata fields as a helper Kai Huang
2024-07-17  3:40 ` [PATCH v2 05/10] x86/virt/tdx: Move field mapping table of getting TDMR info to function local Kai Huang
2024-08-05 23:48   ` Dan Williams
2024-07-17  3:40 ` [PATCH v2 06/10] x86/virt/tdx: Refine a comment to reflect the latest TDX spec Kai Huang
2024-08-06  3:43   ` Dan Williams
2024-08-06 11:23     ` Huang, Kai
2024-08-06 19:06       ` Dan Williams
2024-08-06 21:01         ` Huang, Kai
2024-07-17  3:40 ` [PATCH v2 07/10] x86/virt/tdx: Start to track all global metadata in one structure Kai Huang
2024-08-06  3:51   ` Dan Williams
2024-08-06 11:29     ` Huang, Kai
2024-07-17  3:40 ` [PATCH v2 08/10] x86/virt/tdx: Print TDX module basic information Kai Huang
2024-08-06  4:19   ` Dan Williams
2024-08-06 11:51     ` Huang, Kai
2024-08-06 12:48       ` Huang, Kai
2024-08-07 21:56       ` Dan Williams
2024-08-07 22:32         ` Huang, Kai
2024-08-08 10:31   ` Chenyi Qiang
2024-08-08 23:52     ` Huang, Kai
2024-07-17  3:40 ` [PATCH v2 09/10] x86/virt/tdx: Reduce TDMR's reserved areas by using CMRs to find memory holes Kai Huang
2024-08-06  4:47   ` Dan Williams
2024-08-06 12:17     ` Huang, Kai
2024-08-20 18:38   ` Adrian Hunter
2024-08-27  7:24     ` Huang, Kai
2024-07-17  3:40 ` [PATCH v2 10/10] x86/virt/tdx: Don't initialize module that doesn't support NO_RBP_MOD feature Kai Huang
2024-08-06  4:55   ` Dan Williams
2024-08-06 12:18     ` Huang, Kai [this message]
2024-08-05 12:03 ` [PATCH v2 00/10] TDX host: metadata reading tweaks, bug fix and info dump Huang, Kai
2024-08-05 22:36 ` Dan Williams
2024-08-08  0:19   ` Huang, Kai

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=cc6e40872469ccfc58e7648f12bba5a0b1a54c65.camel@intel.com \
    --to=kai.huang@intel.com \
    --cc=binbin.wu@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=chao.gao@intel.com \
    --cc=dan.j.williams@intel.com \
    --cc=dave.hansen@intel.com \
    --cc=hpa@zytor.com \
    --cc=isaku.yamahata@intel.com \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=kvm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=pbonzini@redhat.com \
    --cc=peterz@infradead.org \
    --cc=rick.p.edgecombe@intel.com \
    --cc=seanjc@google.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®