From: "Paul Menage" <menage@google.com>
To: "Dmitry Adamushko" <dmitry.adamushko@gmail.com>
Cc: vatsa@linux.vnet.ibm.com,
"Andrew Morton" <akpm@linux-foundation.org>,
ckrm-tech@lists.sourceforge.net, linux-kernel@vger.kernel.org,
containers@lists.osdl.org,
"Jan Engelhardt" <jengelh@computergmbh.de>,
"Ingo Molnar" <mingo@elte.hu>
Subject: Re: [PATCH] Hookup group-scheduler with task container infrastructure
Date: Mon, 10 Sep 2007 15:45:15 -0700 [thread overview]
Message-ID: <6599ad830709101545s66fd338dob6932407db4e1002@mail.gmail.com> (raw)
In-Reply-To: <b647ffbd0709101537l9af4dc8x743b25c96e0f5235@mail.gmail.com>
On 9/10/07, Dmitry Adamushko <dmitry.adamushko@gmail.com> wrote:
> On 10/09/2007, Srivatsa Vaddagiri <vatsa@linux.vnet.ibm.com> wrote:
> > On Mon, Sep 10, 2007 at 10:22:59AM -0700, Andrew Morton wrote:
> > > objection ;) "cpuctlr" isn't memorable. Kernel code is write-rarely,
> > > read-often. "cpu_controller", please. The extra typing is worth it ;)
> >
> > Ok! Here's the modified patch (against 2.6.23-rc4-mm1).
>
> as everyone seems to be in a quest for a better name... I think, the
> obvious one would be just 'group_sched'.
>
But "sched" on its own could refer to CPU scheduling, I/O scheduling,
network scheduling, ...
And "group" is more or less implied by the fact that it's in the
containers/control groups filesystem.
So "group_sched" isn't really all that informative. The name should
definitely contain either "cpu" or "cfs".
Paul
next prev parent reply other threads:[~2007-09-10 22:45 UTC|newest]
Thread overview: 30+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-09-10 17:10 Srivatsa Vaddagiri
2007-09-10 17:05 ` Jan Engelhardt
2007-09-10 17:23 ` Srivatsa Vaddagiri
2007-09-10 17:22 ` Andrew Morton
2007-09-10 17:41 ` Jan Engelhardt
2007-09-10 17:46 ` Srivatsa Vaddagiri
2007-09-10 22:28 ` Dmitry Adamushko
2007-09-11 4:41 ` Srivatsa Vaddagiri
2007-09-11 9:53 ` Dmitry Adamushko
2007-09-12 11:42 ` Srivatsa Vaddagiri
2007-09-12 12:10 ` Srivatsa Vaddagiri
2007-09-12 16:25 ` Dmitry Adamushko
2007-09-13 12:33 ` Srivatsa Vaddagiri
2007-09-14 9:41 ` Ingo Molnar
2007-09-14 15:59 ` Srivatsa Vaddagiri
2007-09-14 16:22 ` Srivatsa Vaddagiri
2007-09-10 22:37 ` Dmitry Adamushko
2007-09-10 22:45 ` Paul Menage [this message]
2007-09-11 7:20 ` Cedric Le Goater
2007-09-11 15:22 ` Randy Dunlap
2007-09-11 15:37 ` Jan Engelhardt
2007-09-11 15:51 ` Srivatsa Vaddagiri
2007-09-11 15:53 ` Randy Dunlap
2007-09-11 15:44 ` Paul Menage
2007-09-10 17:28 ` Srivatsa Vaddagiri
2007-09-10 17:42 ` Jan Engelhardt
2007-09-10 18:38 ` [Devel] " Paul Menage
2007-09-11 4:44 ` Srivatsa Vaddagiri
2007-09-18 8:19 ` KAMEZAWA Hiroyuki
2007-09-18 10:44 ` Srivatsa Vaddagiri
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6599ad830709101545s66fd338dob6932407db4e1002@mail.gmail.com \
--to=menage@google.com \
--cc=akpm@linux-foundation.org \
--cc=ckrm-tech@lists.sourceforge.net \
--cc=containers@lists.osdl.org \
--cc=dmitry.adamushko@gmail.com \
--cc=jengelh@computergmbh.de \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=vatsa@linux.vnet.ibm.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome