From: "Paul Menage" <menage@google.com>
To: "Matt Helsley" <matthltc@us.ibm.com>
Cc: Linux-Kernel <linux-kernel@vger.kernel.org>,
"Cedric Le Goater" <clg@fr.ibm.com>,
"Oren Laadan" <orenl@cs.columbia.edu>,
"Linus Torvalds" <torvalds@linux-foundation.org>,
"Pavel Machek" <pavel@ucw.cz>,
linux-pm@lists.linux-foundation.org,
"Linux Containers" <containers@lists.linux-foundation.org>
Subject: Re: [RFC][PATCH 5/5] Add a Signal Control Group Subsystem
Date: Thu, 24 Apr 2008 23:01:46 -0700 [thread overview]
Message-ID: <6599ad830804242301s6a00dd75ye212a28f97072b68@mail.gmail.com> (raw)
In-Reply-To: <20080424064758.113999091@us.ibm.com>
I don't think you need cgroup_signal.h. It's only included in
cgroup_signal.c, and doesn't really contain any useful definitions
anyway. You should just use a cgroup_subsys_state object as your state
object, since you'll never need to do anything with it anyway.
>+static struct cgroup_subsys_state *signal_create(
>+ struct cgroup_subsys *ss, struct cgroup *cgroup)
>+{
>+ struct stateless *dummy;
>+
>+ if (!capable(CAP_SYS_ADMIN))
>+ return ERR_PTR(-EPERM);
This is unnecessary.
>+
+ dummy = kzalloc(sizeof(struct stateless), GFP_KERNEL);
+ if (!dummy)
+ return ERR_PTR(-ENOMEM);
+ return &dummy->css;
+}
This function could be simplified to:
struct cgroup_subsys_state *css;
css = kzalloc(sizeof(*css), GFP_KERNEL);
return css ?: ERR_PTR(-ENOMEM);
>+static int signal_can_attach(struct cgroup_subsys *ss,
>+ struct cgroup *new_cgroup,
>+ struct task_struct *task)
>+{
>+ return 0;
>+}
No need for a can_attach() method if it just returns 0 - that's the default.
>+static int signal_kill(struct cgroup *cgroup, int signum)
>+{
>+ struct cgroup_iter it;
>+ struct task_struct *task;
>+ int retval = 0;
>+
>+ cgroup_iter_start(cgroup, &it);
>+ while ((task = cgroup_iter_next(cgroup, &it))) {
>+ retval = send_sig(signum, task, 1);
>+ if (retval)
>+ break;
>+ }
>+ cgroup_iter_end(cgroup, &it);
>+
>+ return retval;
>+}
cgroup_iter_start() takes a read lock - is send_sig() guaranteed not to sleep?
>+static ssize_t signal_write(struct cgroup *cgroup,
>+ struct cftype *cft,
>+ struct file *file,
>+ const char __user *userbuf,
>+ size_t nbytes, loff_t *unused_ppos)
This should just be a write_u64() method - cgroups will handle the
copying/parsing for you. See e.g.
kernel/sched.c:cpu_shares_write_u64()
>+static struct cftype kill_file = {
>+ .name = "kill",
>+ .write = signal_write,
>+ .private = 0,
>+};
I agree with PaulJ that "signal.send" would be a nicer name for this
than "signal.kill"
next prev parent reply other threads:[~2008-04-25 6:02 UTC|newest]
Thread overview: 27+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-04-24 6:47 [RFC][PATCH 0/5] Container Freezer: Reuse Suspend Freezer Matt Helsley
2008-04-24 6:47 ` [RFC][PATCH 1/5] Container Freezer: Add TIF_FREEZE flag to all architectures Matt Helsley
2008-04-24 8:09 ` Pavel Machek
2008-04-24 6:47 ` [RFC][PATCH 2/5] Container Freezer: Make refrigerator always available Matt Helsley
2008-04-25 11:04 ` Pavel Machek
2008-04-25 12:07 ` Cedric Le Goater
2008-04-26 13:02 ` Rafael J. Wysocki
2008-04-26 23:32 ` [RFC][PATCH] Freezer: NOSIG flag (was: Re: [RFC][PATCH 2/5] Container Freezer: Make refrigerator always available) Rafael J. Wysocki
2008-04-30 9:08 ` [RFC][PATCH 2/5] Container Freezer: Make refrigerator always available Matt Helsley
2008-04-24 6:47 ` [RFC][PATCH 3/5] Container Freezer: Implement freezer cgroup subsystem Matt Helsley
2008-04-25 5:51 ` Paul Menage
2008-04-28 4:03 ` Serge E. Hallyn
2008-04-30 10:39 ` Matt Helsley
2008-04-30 21:28 ` Matt Helsley
2008-04-30 22:30 ` Matt Helsley
2008-04-24 6:48 ` [RFC][PATCH 4/5] Container Freezer: Skip frozen cgroups during power management resume Matt Helsley
2008-04-24 6:48 ` [RFC][PATCH 5/5] Add a Signal Control Group Subsystem Matt Helsley
2008-04-24 19:30 ` Paul Jackson
2008-04-30 7:48 ` Matt Helsley
2008-04-30 8:18 ` Paul Jackson
2008-04-25 6:01 ` Paul Menage [this message]
2008-04-30 8:29 ` Matt Helsley
2008-04-25 11:41 ` Cedric Le Goater
2008-04-30 18:44 ` Matt Helsley
[not found] <20080423142517.062433911@us.ibm.com>
[not found] ` <20080423142518.703428301@us.ibm.com>
2008-04-23 15:17 ` [RFC PATCH " Cedric Le Goater
2008-04-23 15:37 ` Paul Menage
2008-04-24 7:00 ` Matt Helsley
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6599ad830804242301s6a00dd75ye212a28f97072b68@mail.gmail.com \
--to=menage@google.com \
--cc=clg@fr.ibm.com \
--cc=containers@lists.linux-foundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@lists.linux-foundation.org \
--cc=matthltc@us.ibm.com \
--cc=orenl@cs.columbia.edu \
--cc=pavel@ucw.cz \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®