From: Dan Williams <dan.j.williams@intel.com>
To: Robert Richter <rrichter@amd.com>,
Alison Schofield <alison.schofield@intel.com>,
Vishal Verma <vishal.l.verma@intel.com>,
"Ira Weiny" <ira.weiny@intel.com>,
Dan Williams <dan.j.williams@intel.com>,
Jonathan Cameron <Jonathan.Cameron@huawei.com>,
Dave Jiang <dave.jiang@intel.com>,
Davidlohr Bueso <dave@stgolabs.net>
Cc: <linux-cxl@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
Gregory Price <gourry@gourry.net>,
"Fabio M. De Francesco" <fabio.m.de.francesco@linux.intel.com>,
Terry Bowman <terry.bowman@amd.com>,
Robert Richter <rrichter@amd.com>
Subject: Re: [PATCH v6 09/14] cxl/region: Factor out code to find the root decoder
Date: Fri, 9 May 2025 09:26:29 -0700 [thread overview]
Message-ID: <681e2cb5ca5a9_27eca0294d7@dwillia2-xfh.jf.intel.com.notmuch> (raw)
In-Reply-To: <20250509150700.2817697-10-rrichter@amd.com>
Robert Richter wrote:
> In function cxl_add_to_region() there is code to determine the root
> decoder associated to an endpoint decoder. Factor out that code for
> later reuse. This has the benefit of reducing cxl_add_to_region()'s
> function complexity.
>
> The reference count must be decremented after using the root decoder.
> cxl_find_root_decoder() is paired with the put_cxl_root_decoder
> cleanup helper that can be used for this.
[..]
>
> diff --git a/drivers/cxl/core/region.c b/drivers/cxl/core/region.c
> index 59d0d6becbd1..45f5d2c7dfdf 100644
> --- a/drivers/cxl/core/region.c
> +++ b/drivers/cxl/core/region.c
[..]
> @@ -3384,29 +3407,17 @@ static struct cxl_region *construct_region(struct cxl_root_decoder *cxlrd,
>
> int cxl_add_to_region(struct cxl_endpoint_decoder *cxled)
> {
> - struct cxl_memdev *cxlmd = cxled_to_memdev(cxled);
> - struct cxl_port *port = cxled_to_port(cxled);
> - struct cxl_root *cxl_root __free(put_cxl_root) = find_cxl_root(port);
> + struct cxl_root_decoder *cxlrd __free(put_cxl_root_decoder) = NULL;
Please avoid the "obj __free(...) = NULL" pattern. Per the documentation
in include/linux/cleanup.h.
> struct range *hpa = &cxled->cxld.hpa_range;
> - struct cxl_decoder *cxld = &cxled->cxld;
> - struct device *cxlrd_dev, *region_dev;
> - struct cxl_root_decoder *cxlrd;
> + struct device *region_dev;
> struct cxl_region_params *p;
> struct cxl_region *cxlr;
> bool attach = false;
> int rc;
>
> - cxlrd_dev = device_find_child(&cxl_root->port.dev, &cxld->hpa_range,
> - match_root_decoder_by_range);
> - if (!cxlrd_dev) {
> - dev_err(cxlmd->dev.parent,
> - "%s:%s no CXL window for range %#llx:%#llx\n",
> - dev_name(&cxlmd->dev), dev_name(&cxld->dev),
> - cxld->hpa_range.start, cxld->hpa_range.end);
> + cxlrd = cxl_find_root_decoder(cxled);
...i.e. always instantiate and asssign a scope-based cleanup variable in
one statement.
cxlrd __free(put_cxl_root_decoder) = cxl_find_root_decoder(cxled);
Otherwise, this looks good.
next prev parent reply other threads:[~2025-05-09 16:26 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-09 15:06 [PATCH v6 00/14] cxl: Address translation support, part 1: Cleanups and refactoring Robert Richter
2025-05-09 15:06 ` [PATCH v6 01/14] cxl: Remove else after return Robert Richter
2025-05-09 15:06 ` [PATCH v6 02/14] cxl/pci: Moving code in cxl_hdm_decode_init() Robert Richter
2025-05-09 15:06 ` [PATCH v6 03/14] cxl/pci: Add comments to cxl_hdm_decode_init() Robert Richter
2025-05-09 15:06 ` [PATCH v6 04/14] cxl: Introduce parent_port_of() helper Robert Richter
2025-05-09 15:06 ` [PATCH v6 05/14] cxl/region: Rename function to cxl_port_pick_region_decoder() Robert Richter
2025-05-09 15:06 ` [PATCH v6 06/14] cxl/region: Avoid duplicate call of cxl_port_pick_region_decoder() Robert Richter
2025-05-09 15:06 ` [PATCH v6 07/14] cxl/region: Move find_cxl_root() to cxl_add_to_region() Robert Richter
2025-05-09 15:06 ` [PATCH v6 08/14] cxl/port: Replace put_cxl_root() by a cleanup helper Robert Richter
2025-05-09 15:06 ` [PATCH v6 09/14] cxl/region: Factor out code to find the root decoder Robert Richter
2025-05-09 16:26 ` Dan Williams [this message]
2025-05-09 15:06 ` [PATCH v6 10/14] cxl/region: Factor out code to find a root decoder's region Robert Richter
2025-05-09 16:29 ` Dan Williams
2025-05-09 15:06 ` [PATCH v6 11/14] cxl/region: Add function to find a port's switch decoder by range Robert Richter
2025-05-09 15:06 ` [PATCH v6 12/14] cxl/region: Add a dev_warn() on registration failure Robert Richter
2025-05-09 15:06 ` [PATCH v6 13/14] cxl/region: Add a dev_err() on missing target list entries Robert Richter
2025-05-09 15:06 ` [PATCH v6 14/14] cxl: Add a dev_dbg() when a decoder was added to a port Robert Richter
2025-05-09 16:03 ` [PATCH v6 00/14] cxl: Address translation support, part 1: Cleanups and refactoring Dave Jiang
2025-05-09 17:11 ` Dave Jiang
2025-05-12 16:27 ` Robert Richter
2025-05-09 16:32 ` Dan Williams
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=681e2cb5ca5a9_27eca0294d7@dwillia2-xfh.jf.intel.com.notmuch \
--to=dan.j.williams@intel.com \
--cc=Jonathan.Cameron@huawei.com \
--cc=alison.schofield@intel.com \
--cc=dave.jiang@intel.com \
--cc=dave@stgolabs.net \
--cc=fabio.m.de.francesco@linux.intel.com \
--cc=gourry@gourry.net \
--cc=ira.weiny@intel.com \
--cc=linux-cxl@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=rrichter@amd.com \
--cc=terry.bowman@amd.com \
--cc=vishal.l.verma@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®