mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dan Williams <dan.j.williams@intel.com>
To: Robert Richter <rrichter@amd.com>,
	Alison Schofield <alison.schofield@intel.com>,
	Vishal Verma <vishal.l.verma@intel.com>,
	"Ira Weiny" <ira.weiny@intel.com>,
	Dan Williams <dan.j.williams@intel.com>,
	Jonathan Cameron <Jonathan.Cameron@huawei.com>,
	Dave Jiang <dave.jiang@intel.com>,
	Davidlohr Bueso <dave@stgolabs.net>
Cc: <linux-cxl@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
	Gregory Price <gourry@gourry.net>,
	"Fabio M. De Francesco" <fabio.m.de.francesco@linux.intel.com>,
	Terry Bowman <terry.bowman@amd.com>,
	Robert Richter <rrichter@amd.com>
Subject: Re: [PATCH v6 00/14] cxl: Address translation support, part 1: Cleanups and refactoring
Date: Fri, 9 May 2025 09:32:45 -0700	[thread overview]
Message-ID: <681e2e2dd78d4_27eca029482@dwillia2-xfh.jf.intel.com.notmuch> (raw)
In-Reply-To: <20250509150700.2817697-1-rrichter@amd.com>

Robert Richter wrote:
> This series is the first part of adding support for CXL address
> translation. It contains cleanup and code refactoring in preparation
> of the actual implementation that will be sent in part 2. Cleanup and
> code refactoring have been split in a separate series to reduce the
> number of patches of the series. Even without address translation on
> top this rework improves esp. the region code, cleans it up,
> simplifies it and adds debugging messages to better analyze region
> creation failures:
> 
[..]
> 
> v6:
>  * added tags to SOB chain,
>  * added more occurences to remove-else-after-return (Alison),
>  * updated description of cxl_port_pick_region_decoder() (Fabio),
[..]

Aside from the "obj __free(...) = NULL" anti-pattern to clean up, for
the series, you can add:

Acked-by: Dan Williams <dan.j.williams@intel.com>

      parent reply	other threads:[~2025-05-09 16:33 UTC|newest]

Thread overview: 21+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-09 15:06 Robert Richter
2025-05-09 15:06 ` [PATCH v6 01/14] cxl: Remove else after return Robert Richter
2025-05-09 15:06 ` [PATCH v6 02/14] cxl/pci: Moving code in cxl_hdm_decode_init() Robert Richter
2025-05-09 15:06 ` [PATCH v6 03/14] cxl/pci: Add comments to cxl_hdm_decode_init() Robert Richter
2025-05-09 15:06 ` [PATCH v6 04/14] cxl: Introduce parent_port_of() helper Robert Richter
2025-05-09 15:06 ` [PATCH v6 05/14] cxl/region: Rename function to cxl_port_pick_region_decoder() Robert Richter
2025-05-09 15:06 ` [PATCH v6 06/14] cxl/region: Avoid duplicate call of cxl_port_pick_region_decoder() Robert Richter
2025-05-09 15:06 ` [PATCH v6 07/14] cxl/region: Move find_cxl_root() to cxl_add_to_region() Robert Richter
2025-05-09 15:06 ` [PATCH v6 08/14] cxl/port: Replace put_cxl_root() by a cleanup helper Robert Richter
2025-05-09 15:06 ` [PATCH v6 09/14] cxl/region: Factor out code to find the root decoder Robert Richter
2025-05-09 16:26   ` Dan Williams
2025-05-09 15:06 ` [PATCH v6 10/14] cxl/region: Factor out code to find a root decoder's region Robert Richter
2025-05-09 16:29   ` Dan Williams
2025-05-09 15:06 ` [PATCH v6 11/14] cxl/region: Add function to find a port's switch decoder by range Robert Richter
2025-05-09 15:06 ` [PATCH v6 12/14] cxl/region: Add a dev_warn() on registration failure Robert Richter
2025-05-09 15:06 ` [PATCH v6 13/14] cxl/region: Add a dev_err() on missing target list entries Robert Richter
2025-05-09 15:06 ` [PATCH v6 14/14] cxl: Add a dev_dbg() when a decoder was added to a port Robert Richter
2025-05-09 16:03 ` [PATCH v6 00/14] cxl: Address translation support, part 1: Cleanups and refactoring Dave Jiang
2025-05-09 17:11   ` Dave Jiang
2025-05-12 16:27     ` Robert Richter
2025-05-09 16:32 ` Dan Williams [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=681e2e2dd78d4_27eca029482@dwillia2-xfh.jf.intel.com.notmuch \
    --to=dan.j.williams@intel.com \
    --cc=Jonathan.Cameron@huawei.com \
    --cc=alison.schofield@intel.com \
    --cc=dave.jiang@intel.com \
    --cc=dave@stgolabs.net \
    --cc=fabio.m.de.francesco@linux.intel.com \
    --cc=gourry@gourry.net \
    --cc=ira.weiny@intel.com \
    --cc=linux-cxl@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=rrichter@amd.com \
    --cc=terry.bowman@amd.com \
    --cc=vishal.l.verma@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®