* [PATCH v7 1/2] drm: Introduce pending_hp to drm_connector
2026-02-17 19:00 [PATCH v7 0/2] Pass down hot-plug CONNECTOR ID to user-space Nicolas Frattaroli
@ 2026-02-17 19:00 ` Nicolas Frattaroli
2026-02-17 19:00 ` [PATCH v7 2/2] drm: Send per-connector hotplug events Nicolas Frattaroli
2026-03-11 15:51 ` [PATCH v7 0/2] Pass down hot-plug CONNECTOR ID to user-space Nicolas Frattaroli
2 siblings, 0 replies; 4+ messages in thread
From: Nicolas Frattaroli @ 2026-02-17 19:00 UTC (permalink / raw)
To: Ville Syrjälä,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter, Louis Chauvet, Haneen Mohammed,
Melissa Wen, Daniel Stone, Ian Forbes, Dmitry Baryshkov
Cc: dri-devel, linux-kernel, kernel, Nicolas Frattaroli, Marius Vlad
From: Marius Vlad <marius.vlad@collabora.com>
Introduce a new boolean variable used to track whether a connector has
changed its status since the last hotplug event for it was sent to
userspace. It is used by both the polling and HPD path.
A subsequent change will make use of this new member to propagate
per-connector udev hotplug events to userspace, rather than sending a
global hotplug event.
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Signed-off-by: Nicolas Frattaroli <nicolas.frattaroli@collabora.com>
---
drivers/gpu/drm/drm_connector.c | 1 +
drivers/gpu/drm/drm_probe_helper.c | 17 +++++++++++++++++
drivers/gpu/drm/drm_sysfs.c | 2 ++
include/drm/drm_connector.h | 3 +++
4 files changed, 23 insertions(+)
diff --git a/drivers/gpu/drm/drm_connector.c b/drivers/gpu/drm/drm_connector.c
index aec05adbc889..67497d0e41f1 100644
--- a/drivers/gpu/drm/drm_connector.c
+++ b/drivers/gpu/drm/drm_connector.c
@@ -274,6 +274,7 @@ static int drm_connector_init_only(struct drm_device *dev,
/* provide ddc symlink in sysfs */
connector->ddc = ddc;
+ connector->pending_hp = false;
INIT_LIST_HEAD(&connector->head);
INIT_LIST_HEAD(&connector->global_connector_list_entry);
diff --git a/drivers/gpu/drm/drm_probe_helper.c b/drivers/gpu/drm/drm_probe_helper.c
index d4dc8cb45bce..f8cbd6713960 100644
--- a/drivers/gpu/drm/drm_probe_helper.c
+++ b/drivers/gpu/drm/drm_probe_helper.c
@@ -732,6 +732,17 @@ EXPORT_SYMBOL(drm_helper_probe_single_connector_modes);
*/
void drm_kms_helper_hotplug_event(struct drm_device *dev)
{
+ struct drm_connector *connector;
+ struct drm_connector_list_iter conn_iter;
+
+ mutex_lock(&dev->mode_config.mutex);
+ drm_connector_list_iter_begin(dev, &conn_iter);
+ drm_for_each_connector_iter(connector, &conn_iter) {
+ connector->pending_hp = false;
+ }
+ drm_connector_list_iter_end(&conn_iter);
+ mutex_unlock(&dev->mode_config.mutex);
+
drm_sysfs_hotplug_event(dev);
drm_client_dev_hotplug(dev);
}
@@ -748,6 +759,10 @@ void drm_kms_helper_connector_hotplug_event(struct drm_connector *connector)
{
struct drm_device *dev = connector->dev;
+ mutex_lock(&dev->mode_config.mutex);
+ connector->pending_hp = false;
+ mutex_unlock(&dev->mode_config.mutex);
+
drm_sysfs_connector_hotplug_event(connector);
drm_client_dev_hotplug(dev);
}
@@ -837,6 +852,7 @@ static void output_poll_execute(struct work_struct *work)
old_epoch_counter, connector->epoch_counter);
changed = true;
+ connector->pending_hp = true;
}
}
drm_connector_list_iter_end(&conn_iter);
@@ -1101,6 +1117,7 @@ bool drm_helper_hpd_irq_event(struct drm_device *dev)
first_changed_connector = connector;
}
+ connector->pending_hp = true;
changed++;
}
}
diff --git a/drivers/gpu/drm/drm_sysfs.c b/drivers/gpu/drm/drm_sysfs.c
index b01ffa4d6509..53076c2afd12 100644
--- a/drivers/gpu/drm/drm_sysfs.c
+++ b/drivers/gpu/drm/drm_sysfs.c
@@ -216,6 +216,8 @@ static ssize_t status_store(struct device *device,
connector->base.id, connector->name,
old_force, connector->force);
+ connector->pending_hp = true;
+
connector->funcs->fill_modes(connector,
dev->mode_config.max_width,
dev->mode_config.max_height);
diff --git a/include/drm/drm_connector.h b/include/drm/drm_connector.h
index c18be8c19de0..cd9787c54425 100644
--- a/include/drm/drm_connector.h
+++ b/include/drm/drm_connector.h
@@ -2191,6 +2191,9 @@ struct drm_connector {
/** @force: a DRM_FORCE_<foo> state for forced mode sets */
enum drm_connector_force force;
+ /** @pending_hp: true if connector changed since last hotplug event */
+ bool pending_hp;
+
/**
* @edid_override: Override EDID set via debugfs.
*
--
2.53.0
^ permalink raw reply [flat|nested] 4+ messages in thread* [PATCH v7 2/2] drm: Send per-connector hotplug events
2026-02-17 19:00 [PATCH v7 0/2] Pass down hot-plug CONNECTOR ID to user-space Nicolas Frattaroli
2026-02-17 19:00 ` [PATCH v7 1/2] drm: Introduce pending_hp to drm_connector Nicolas Frattaroli
@ 2026-02-17 19:00 ` Nicolas Frattaroli
2026-03-11 15:51 ` [PATCH v7 0/2] Pass down hot-plug CONNECTOR ID to user-space Nicolas Frattaroli
2 siblings, 0 replies; 4+ messages in thread
From: Nicolas Frattaroli @ 2026-02-17 19:00 UTC (permalink / raw)
To: Ville Syrjälä,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter, Louis Chauvet, Haneen Mohammed,
Melissa Wen, Daniel Stone, Ian Forbes, Dmitry Baryshkov
Cc: dri-devel, linux-kernel, kernel, Nicolas Frattaroli, Marius Vlad
From: Marius Vlad <marius.vlad@collabora.com>
Use the new pending_hp member of drm_connector to always send
per-connector hotplug events for those connectors that need it, rather
than sending a global event, or only an event for one connector.
On the HPD (Hot Plug Detect) path this change notifies all connectors,
rather than just first changed connector.
The polling path is changed to no longer send a connector-less hotplug
event, but similarly send a hotplug event for each changed connector.
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Signed-off-by: Nicolas Frattaroli <nicolas.frattaroli@collabora.com>
---
drivers/gpu/drm/drm_probe_helper.c | 22 +++++++++++++++++-----
1 file changed, 17 insertions(+), 5 deletions(-)
diff --git a/drivers/gpu/drm/drm_probe_helper.c b/drivers/gpu/drm/drm_probe_helper.c
index f8cbd6713960..5c39f27ada1d 100644
--- a/drivers/gpu/drm/drm_probe_helper.c
+++ b/drivers/gpu/drm/drm_probe_helper.c
@@ -860,8 +860,14 @@ static void output_poll_execute(struct work_struct *work)
mutex_unlock(&dev->mode_config.mutex);
out:
- if (changed)
- drm_kms_helper_hotplug_event(dev);
+ if (changed) {
+ drm_connector_list_iter_begin(dev, &conn_iter);
+ drm_for_each_connector_iter(connector, &conn_iter) {
+ if (connector->pending_hp)
+ drm_kms_helper_connector_hotplug_event(connector);
+ }
+ drm_connector_list_iter_end(&conn_iter);
+ }
if (repoll)
schedule_delayed_work(delayed_work, DRM_OUTPUT_POLL_PERIOD);
@@ -1124,10 +1130,16 @@ bool drm_helper_hpd_irq_event(struct drm_device *dev)
drm_connector_list_iter_end(&conn_iter);
mutex_unlock(&dev->mode_config.mutex);
- if (changed == 1)
+ if (changed == 1) {
drm_kms_helper_connector_hotplug_event(first_changed_connector);
- else if (changed > 0)
- drm_kms_helper_hotplug_event(dev);
+ } else if (changed > 0) {
+ drm_connector_list_iter_begin(dev, &conn_iter);
+ drm_for_each_connector_iter(connector, &conn_iter) {
+ if (connector->pending_hp)
+ drm_kms_helper_connector_hotplug_event(connector);
+ }
+ drm_connector_list_iter_end(&conn_iter);
+ }
if (first_changed_connector)
drm_connector_put(first_changed_connector);
--
2.53.0
^ permalink raw reply [flat|nested] 4+ messages in thread* Re: [PATCH v7 0/2] Pass down hot-plug CONNECTOR ID to user-space
2026-02-17 19:00 [PATCH v7 0/2] Pass down hot-plug CONNECTOR ID to user-space Nicolas Frattaroli
2026-02-17 19:00 ` [PATCH v7 1/2] drm: Introduce pending_hp to drm_connector Nicolas Frattaroli
2026-02-17 19:00 ` [PATCH v7 2/2] drm: Send per-connector hotplug events Nicolas Frattaroli
@ 2026-03-11 15:51 ` Nicolas Frattaroli
2 siblings, 0 replies; 4+ messages in thread
From: Nicolas Frattaroli @ 2026-03-11 15:51 UTC (permalink / raw)
To: Ville Syrjälä,
Maarten Lankhorst, Maxime Ripard, Thomas Zimmermann,
David Airlie, Simona Vetter, Louis Chauvet, Haneen Mohammed,
Melissa Wen, Daniel Stone, Ian Forbes, Dmitry Baryshkov
Cc: dri-devel, linux-kernel, kernel, Marius Vlad
On Tuesday, 17 February 2026 20:00:22 Central European Standard Time Nicolas Frattaroli wrote:
> I will be taking over this series from Marius Vlad.
>
> This series addresses a shortcoming whereby a hot plug event is sent
> without it being passed the actual connector that caused it. This takes
> into consideration both the polling path and the HPD (Hot Plug Detect)
> path. It also adds support for the vkms driver (using ConfigFS) for
> propagating the connector ID when changing the connector's status.
>
> The motivation is that user-space applications such as Weston would
> previously receive non-connector-specific hotplug events, and then have
> to figure out themselves which connector needs to have a modeset
> executed on. This notably did not work when the hotplug events came in
> too fast, resulting in Weston missing an on-off-on transition of a
> connector, seeing that its state was unchanged from "on" so can't be the
> one that was hotplugged, and skipping reinitialising it as it looks
> through the other connectors that could've caused it.
>
> The real world implication is that on setups with slightly sketchy HDMI
> connections, a brief flicker in the HPD signal could result in video
> output bidding farewell entirely until a manual proper re-plug was
> performed.
>
> By sending connector specific hotplug events, this ambiguity is
> resolved without any change to the user-space API.
>
> Signed-off-by: Nicolas Frattaroli <nicolas.frattaroli@collabora.com>
> ---
> Changes in v7:
> - Drop the two vkms patches, as I don't want them to be blocked on
> review. I still think they're correct, but they're not essential and
> don't need to block this series.
> - Link to v6: https://lore.kernel.org/r/20260123-hot-plug-passup-v6-0-aaaf61d960bb@collabora.com
>
> Changes in v6:
> - Rewrote cover letter to explain the motivation for this series more
> plainly
> - Rename "status_changed" to "pending_hp"
> - Set "pending_hp" in the existing path that would also affect
> epoch_counter
> - No longer set the boolean in drm_helper_probe_single_connector_modes,
> as it does not appear to be necessary
> - Reword commits to better justify the changes
> - Link to v5: https://lore.kernel.org/r/20251111162338.15141-1-marius.vlad@collabora.com/
>
> Changes in v5:
> - vkms: add support for sending the CONNECTOR ID when hot-plugging through
> ConfigFS - as reported by Louis, vkms can now make use of ConfigFS to
> simulate connector status.
> - vkms: add a small change to ignore previous/old drm connector status
> when sending out hot-plug uevent.
> - Link to v4: https://lore.kernel.org/r/20251103174558.7709-1-marius.vlad@collabora.com/
>
> Changes in v4:
> - removed the "This patch" bit - Dmitry
> - added a short note when the flag is set and cleared - Dmitry
> - address double dead-locking detected - kbot: https://lore.kernel.org/dri-devel/202509251410.fdfbcac3-lkp@intel.com/
> - virtual connectors do not seem have any kind of hotplug - added
> polling in vkms - as noted by Ian
> - Link to v3: https://lore.kernel.org/r/20250923083636.4749-1-marius.vlad@collabora.com/
>
> Changes in v3:
> - Address comments from Dmitry:
> - guard connector status write with mode_config.mutex
> - avoid setting up the connector status and immediately unset it. Do the
> unset in drm_kms_helper_hotplug_event/drm_kms_helper_connector_hotplug_event
> - Link to v2: https://lore.kernel.org/r/20250729165708.9947-1-marius.vlad@collabora.com/
>
> Changes in v2:
> - Address comments from Daniel:
> - split patch into 2, one that introduces a bool to track connector
> connection status change and a patch that uses that to be able to send
> hot plug events with the proper CONNECTOR ID to udev and further pass
> that down to user-space
> - nuke out mutex when iterating connector list
> - fix typo
> - Link to v1: https://lore.kernel.org/r/20250627131751.2004-1-marius.vlad@collabora.com/
>
> Marius Vlad (4):
> drm: Introduce a new connector status
> drm: Propagate connector status change
> vkms: Do not send hotplug events for same connector status
> vkms: Pass the vkms connector as opposed to the vkms device
>
> drivers/gpu/drm/drm_connector.c | 1 +
> drivers/gpu/drm/drm_probe_helper.c | 39 +++++++++++++++++++++++----
> drivers/gpu/drm/drm_sysfs.c | 1 +
> drivers/gpu/drm/vkms/vkms_configfs.c | 12 +++++++--
> drivers/gpu/drm/vkms/vkms_connector.c | 6 ++---
> drivers/gpu/drm/vkms/vkms_connector.h | 4 +--
> include/drm/drm_connector.h | 3 +++
> 7 files changed, 54 insertions(+), 12 deletions(-)
>
> --
> 2.47.2
Oh dear, I didn't even realize I left a bogus diffstat in the cover
letter when importing. :(
>
> ---
> Marius Vlad (2):
> drm: Introduce pending_hp to drm_connector
> drm: Send per-connector hotplug events
>
> drivers/gpu/drm/drm_connector.c | 1 +
> drivers/gpu/drm/drm_probe_helper.c | 39 +++++++++++++++++++++++++++++++++-----
> drivers/gpu/drm/drm_sysfs.c | 2 ++
> include/drm/drm_connector.h | 3 +++
> 4 files changed, 40 insertions(+), 5 deletions(-)
> ---
> base-commit: e66c64e4f12e55cad35c680f1e328a7c7ee92cab
> change-id: 20260121-hot-plug-passup-f8ed03f7c202
>
> Best regards,
>
It's been 3 weeks since v7, and 6 weeks since v6 which is the same
code except with 2 more patches that have been dropped in v7. I don't
want to be too annoying, but I'll be happy to receive feedback on the
new approach so I know whether I'm taking this in the wrong direction.
Kind regards,
Nicolas Frattaroli
^ permalink raw reply [flat|nested] 4+ messages in thread