mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Changwoo Min <multics69@gmail.com>
To: tj@kernel.org, void@manifault.com
Cc: linux-kernel@vger.kernel.org, kernel-team@meta.com,
	sched-ext@meta.com, arighi@nvidia.com, me@mostlynerdless.de,
	ggherdovich@suse.com, dschatzberg@meta.com, yougmark94@gmail.com,
	changwoo@igalia.com, kernel-dev@igalia.com
Subject: Re: [PATCHSET sched_ext/for-6.13] sched_ext: Rename dispatch and consume kfuncs
Date: Mon, 11 Nov 2024 10:40:55 +0900	[thread overview]
Message-ID: <69a3473d-2923-45a9-b38e-0121544f0303@gmail.com> (raw)
In-Reply-To: <20241110200308.103681-1-tj@kernel.org>

Hello,

On 24. 11. 11. 05:02, Tejun Heo wrote:
> Hello,
> 
> [v1] -> v2: Comment and documentation updates.
> 
> In sched_ext API, a repeatedly reported pain point is the overuse of the
> verb "dispatch" and confusion around "consume":
> 
> - ops.dispatch()
> - scx_bpf_dispatch[_vtime]()
> - scx_bpf_consume()
> - scx_bpf_dispatch[_vtime]_from_dsq*()
> 
> This overloading of the term is historical. Originally, there were only
> built-in DSQs and moving a task into a DSQ always dispatched it for
> execution. Using the verb "dispatch" for the kfuncs to move tasks into these
> DSQs made sense.
> 
> Later, user DSQs were added and scx_bpf_dispatch[_vtime]() updated to be
> able to insert tasks into any DSQ. The only allowed DSQ to DSQ transfer was
> from a non-local DSQ to a local DSQ and this operation was named "consume".
> This was already confusing as a task could be dispatched to a user DSQ from
> ops.enqueue() and then the DSQ would have to be consumed in ops.dispatch().
> Later addition of scx_bpf_dispatch_from_dsq*() made the confusion even worse
> as "dispatch" in this context meant moving a task to an arbitrary DSQ from a
> user DSQ.
> 
> Clean up the API with the following renames:
> 
> 1. scx_bpf_dispatch[_vtime]()		-> scx_bpf_dsq_insert[_vtime]()
> 2. scx_bpf_consume()			-> scx_bpf_dsq_move_to_local()
> 3. scx_bpf_dispatch[_vtime]_from_dsq*()	-> scx_bpf_dsq_move[_vtime]*()
> 
> This patchset is on top of sched_ext/for-6.13 72b85bf6a7f6 ("sched_ext:
> scx_bpf_dispatch_from_dsq_set_*() are allowed from unlocked context") and
> contains the following patches:
> 
>   0001-sched_ext-Rename-scx_bpf_dispatch-_vtime-to-scx_bpf_.patch
>   0002-sched_ext-Rename-scx_bpf_consume-to-scx_bpf_dsq_move.patch
>   0003-sched_ext-Rename-scx_bpf_dispatch-_vtime-_from_dsq-s.patch
> 
> and is always available in the following git branch:
> 
>   git://git.kernel.org/pub/scm/linux/kernel/git/tj/sched_ext.git scx-api-rename-dispatch-v2
> 
> diffstat follows. Thanks.

Looks good to me. Thanks!

Acked-by: Changwoo Min <changwoo@igalia.com>


Regards,
Changwoo Min

  parent reply	other threads:[~2024-11-11  1:41 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-11-10 20:02 Tejun Heo
2024-11-10 20:02 ` [PATCH 1/3] sched_ext: Rename scx_bpf_dispatch[_vtime]() to scx_bpf_dsq_insert[_vtime]() Tejun Heo
2024-11-10 20:02 ` [PATCH 2/3] sched_ext: Rename scx_bpf_consume() to scx_bpf_dsq_move_to_local() Tejun Heo
2024-11-10 20:02 ` [PATCH 3/3] sched_ext: Rename scx_bpf_dispatch[_vtime]_from_dsq*() -> scx_bpf_dsq_move[_vtime]*() Tejun Heo
2024-11-11 16:02   ` Giovanni Gherdovich
2024-11-10 20:17 ` [PATCHSET sched_ext/for-6.13] sched_ext: Rename dispatch and consume kfuncs Andrea Righi
2024-11-11  1:40 ` Changwoo Min [this message]
2024-11-11  8:51   ` Johannes Bechberger
2024-11-11 17:07 ` Tejun Heo
2024-11-12 16:56 ` David Vernet
  -- strict thread matches above, loose matches on Subject: below --
2024-11-09 19:48 Tejun Heo
2024-11-10 11:45 ` Andrea Righi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=69a3473d-2923-45a9-b38e-0121544f0303@gmail.com \
    --to=multics69@gmail.com \
    --cc=arighi@nvidia.com \
    --cc=changwoo@igalia.com \
    --cc=dschatzberg@meta.com \
    --cc=ggherdovich@suse.com \
    --cc=kernel-dev@igalia.com \
    --cc=kernel-team@meta.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=me@mostlynerdless.de \
    --cc=sched-ext@meta.com \
    --cc=tj@kernel.org \
    --cc=void@manifault.com \
    --cc=yougmark94@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®