From: Giovanni Gherdovich <giovanni.gherdovich@suse.com>
To: Tejun Heo <tj@kernel.org>
Cc: linux-kernel@vger.kernel.org, kernel-team@meta.com,
sched-ext@meta.com, arighi@nvidia.com, multics69@gmail.com,
me@mostlynerdless.de, dschatzberg@meta.com, yougmark94@gmail.com,
void@manifault.com
Subject: Re: [PATCH 3/3] sched_ext: Rename scx_bpf_dispatch[_vtime]_from_dsq*() -> scx_bpf_dsq_move[_vtime]*()
Date: Mon, 11 Nov 2024 17:02:10 +0100 [thread overview]
Message-ID: <d86b8a16-6e1d-4580-83b6-fb186d8b8996@suse.com> (raw)
In-Reply-To: <20241110200308.103681-4-tj@kernel.org>
Hello,
On Sun Nov 10, 2024 21:02, Tejun Heo wrote:
> In sched_ext API, a repeatedly reported pain point is the overuse of the
> verb "dispatch" and confusion around "consume": [...]
>
> Clean up the API with the following renames:
>
> 1. scx_bpf_dispatch[_vtime]() -> scx_bpf_dsq_insert[_vtime]()
> 2. scx_bpf_consume() -> scx_bpf_dsq_move_to_local()
> 3. scx_bpf_dispatch[_vtime]_from_dsq*() -> scx_bpf_dsq_move[_vtime]*()
>
> This patch performs the third set of renames. Compatibility is maintained
> by: [...]
Thanks Tejun.
For the whole series,
Acked-by: Giovanni Gherdovich <ggherdovich@suse.com>
Giovanni
next prev parent reply other threads:[~2024-11-11 16:02 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-11-10 20:02 [PATCHSET sched_ext/for-6.13] sched_ext: Rename dispatch and consume kfuncs Tejun Heo
2024-11-10 20:02 ` [PATCH 1/3] sched_ext: Rename scx_bpf_dispatch[_vtime]() to scx_bpf_dsq_insert[_vtime]() Tejun Heo
2024-11-10 20:02 ` [PATCH 2/3] sched_ext: Rename scx_bpf_consume() to scx_bpf_dsq_move_to_local() Tejun Heo
2024-11-10 20:02 ` [PATCH 3/3] sched_ext: Rename scx_bpf_dispatch[_vtime]_from_dsq*() -> scx_bpf_dsq_move[_vtime]*() Tejun Heo
2024-11-11 16:02 ` Giovanni Gherdovich [this message]
2024-11-10 20:17 ` [PATCHSET sched_ext/for-6.13] sched_ext: Rename dispatch and consume kfuncs Andrea Righi
2024-11-11 1:40 ` Changwoo Min
2024-11-11 8:51 ` Johannes Bechberger
2024-11-11 17:07 ` Tejun Heo
2024-11-12 16:56 ` David Vernet
-- strict thread matches above, loose matches on Subject: below --
2024-11-09 19:48 Tejun Heo
2024-11-09 19:48 ` [PATCH 3/3] sched_ext: Rename scx_bpf_dispatch[_vtime]_from_dsq*() -> scx_bpf_dsq_move[_vtime]*() Tejun Heo
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d86b8a16-6e1d-4580-83b6-fb186d8b8996@suse.com \
--to=giovanni.gherdovich@suse.com \
--cc=arighi@nvidia.com \
--cc=dschatzberg@meta.com \
--cc=kernel-team@meta.com \
--cc=linux-kernel@vger.kernel.org \
--cc=me@mostlynerdless.de \
--cc=multics69@gmail.com \
--cc=sched-ext@meta.com \
--cc=tj@kernel.org \
--cc=void@manifault.com \
--cc=yougmark94@gmail.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®