From: neil.armstrong@linaro.org
To: Johan Hovold <johan+linaro@kernel.org>, Vinod Koul <vkoul@kernel.org>
Cc: Kishon Vijay Abraham I <kishon@kernel.org>,
Ivaylo Ivanov <ivo.ivanov.ivanov1@gmail.com>,
Abel Vesa <abel.vesa@linaro.org>,
linux-phy@lists.infradead.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 5/7] phy: phy-snps-eusb2: fix optional phy lookup parameter
Date: Mon, 26 May 2025 10:27:48 +0200 [thread overview]
Message-ID: <6de7286f-802a-4de2-9030-6937e85a5aee@linaro.org> (raw)
In-Reply-To: <20250523084839.11015-6-johan+linaro@kernel.org>
On 23/05/2025 10:48, Johan Hovold wrote:
> The devm_of_phy_optional_get() takes an optional name argument as its
> third parameter and not an index like the recently replaced
> devm_of_phy_get_by_index().
>
> Replace 0 with an explicit NULL for consistency and readability.
>
> Signed-off-by: Johan Hovold <johan+linaro@kernel.org>
> ---
> drivers/phy/phy-snps-eusb2.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/phy/phy-snps-eusb2.c b/drivers/phy/phy-snps-eusb2.c
> index 232c5e8a554f..328e67ebfe03 100644
> --- a/drivers/phy/phy-snps-eusb2.c
> +++ b/drivers/phy/phy-snps-eusb2.c
> @@ -581,7 +581,7 @@ static int snps_eusb2_hsphy_probe(struct platform_device *pdev)
> return dev_err_probe(dev, ret,
> "failed to get regulator supplies\n");
>
> - phy->repeater = devm_of_phy_optional_get(dev, np, 0);
> + phy->repeater = devm_of_phy_optional_get(dev, np, NULL);
> if (IS_ERR(phy->repeater))
> return dev_err_probe(dev, PTR_ERR(phy->repeater),
> "failed to get repeater\n");
Reviewed-by: Neil Armstrong <neil.armstrong@linaro.org>
next prev parent reply other threads:[~2025-05-26 8:27 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-05-23 8:48 [PATCH 0/7] phy: phy-snps-eusb2: fixes and cleanups Johan Hovold
2025-05-23 8:48 ` [PATCH 1/7] phy: phy-snps-eusb2: fix clock imbalance on phy_exit() Johan Hovold
2025-05-25 13:17 ` Ivaylo Ivanov
2025-05-26 7:49 ` neil.armstrong
2025-05-23 8:48 ` [PATCH 2/7] phy: phy-snps-eusb2: fix repeater imbalance on phy_init() failure Johan Hovold
2025-05-26 7:49 ` Neil Armstrong
2025-05-23 8:48 ` [PATCH 3/7] phy: phy-snps-eusb2: rename phy_init() clock error label Johan Hovold
2025-05-26 7:49 ` neil.armstrong
2025-05-23 8:48 ` [PATCH 4/7] phy: phy-snps-eusb2: clean up error messages Johan Hovold
2025-05-26 7:50 ` neil.armstrong
2025-05-23 8:48 ` [PATCH 5/7] phy: phy-snps-eusb2: fix optional phy lookup parameter Johan Hovold
2025-05-26 8:27 ` neil.armstrong [this message]
2025-05-23 8:48 ` [PATCH 6/7] phy: phy-snps-eusb2: drop unnecessary loop index declarations Johan Hovold
2025-05-26 8:27 ` neil.armstrong
2025-05-23 8:48 ` [PATCH 7/7] phy: phy-snps-eusb2: clean up id table sentinel Johan Hovold
2025-05-23 8:57 ` [PATCH 0/7] phy: phy-snps-eusb2: fixes and cleanups Abel Vesa
2025-06-15 16:53 ` Vinod Koul
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=6de7286f-802a-4de2-9030-6937e85a5aee@linaro.org \
--to=neil.armstrong@linaro.org \
--cc=abel.vesa@linaro.org \
--cc=ivo.ivanov.ivanov1@gmail.com \
--cc=johan+linaro@kernel.org \
--cc=kishon@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-phy@lists.infradead.org \
--cc=vkoul@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®