mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Binbin Wu <binbin.wu@linux.intel.com>
To: Peter Fang <peter.fang@intel.com>
Cc: Dave Hansen <dave.hansen@linux.intel.com>,
	Kiryl Shutsemau <kas@kernel.org>,
	Rick Edgecombe <rick.p.edgecombe@intel.com>,
	Kuppuswamy Sathyanarayanan
	<sathyanarayanan.kuppuswamy@linux.intel.com>,
	Thomas Gleixner <tglx@kernel.org>, Ingo Molnar <mingo@redhat.com>,
	Borislav Petkov <bp@alien8.de>,
	x86@kernel.org, "H. Peter Anvin" <hpa@zytor.com>,
	linux-kernel@vger.kernel.org, linux-coco@lists.linux.dev,
	kvm@vger.kernel.org, Xiaoyao Li <xiaoyao.li@intel.com>,
	Tony Lindgren <tony.lindgren@linux.intel.com>,
	Sean Christopherson <seanjc@google.com>,
	Artem Bityutskiy <artem.bityutskiy@intel.com>
Subject: Re: [PATCH v5 2/6] virt: tdx-guest: Give the Quote buffer an explicit type
Date: Tue, 29 Sep 2026 15:43:17 +0800	[thread overview]
Message-ID: <6df0a7cf-e88f-409b-8601-1e98367e4930@linux.intel.com> (raw)
In-Reply-To: <artrprfgz7Q5CEz7@intel.com>



On 9/29/2026 3:41 PM, Peter Fang wrote:
> On Tue, Sep 29, 2026 at 10:13:32AM +0800, Binbin Wu wrote:
>> On 9/28/2026 6:08 PM, Peter Fang wrote:
>>> The Quote buffer is always a "struct tdx_quote_buf", but its global
>>> pointer is a "void *". A function would have to convert it back to make
>>> sense of it.
>>>
>>> Declare the global with its actual type, and give it a better name.
>>>
>>> This creates variable shadowing in wait_for_quote_completion(), so
>>> rename its parameter for clarity.
>>>
>>> AI was used under supervision to collect/apply feedback, review code and
>>> workshop logs.
>>>
>>> Signed-off-by: Peter Fang <peter.fang@intel.com>
>>
>> Reviewed-by: Binbin Wu <binbin.wu@linux.intel.com>
> 
> Thanks Binbin!
> 
>>
>> One nit below.
>>
>>> ---
>>> v5:
>>>  - New patch. [Dave]
>>> ---
>>>  drivers/virt/coco/tdx-guest/tdx-guest.c | 35 ++++++++++++-------------
>>>  1 file changed, 17 insertions(+), 18 deletions(-)
>>>
>>> diff --git a/drivers/virt/coco/tdx-guest/tdx-guest.c b/drivers/virt/coco/tdx-guest/tdx-guest.c
>>> index d0303e31e816..896eb0a09c4a 100644
>>> --- a/drivers/virt/coco/tdx-guest/tdx-guest.c
>>> +++ b/drivers/virt/coco/tdx-guest/tdx-guest.c
>>> @@ -192,7 +192,7 @@ struct tdx_quote_buf {
>>>  };
>>>  
>>>  /* Quote data buffer */
>>
>> The comment should be updated as well.
>>
>> "Quote buffer" or "Quote request buffer"?
> 
> Hmm... I think with this refactoring, either one becomes kind of
> redundant. I was thinking of adding something like "GHCI Quote buffer",
> but that's pretty much documented by struct tdx_quote_buf itself.

Agree.

> 
> How about I just drop the comment?

It's OK for me.

> 
>>
>>> -static void *quote_data;
>>> +static struct tdx_quote_buf *quote_buf;
>>>  


  reply	other threads:[~2026-09-29  7:43 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-28 10:08 [PATCH v5 0/6] tdx-guest: Make Quote buffer size dynamic Peter Fang
2026-09-28 10:08 ` [PATCH v5 1/6] x86/tdx: Take the Quote buffer as a generic pointer Peter Fang
2026-09-28 19:04   ` Edgecombe, Rick P
2026-09-28 20:37     ` Peter Fang
2026-09-28 20:10   ` Kuppuswamy Sathyanarayanan
2026-09-28 10:08 ` [PATCH v5 2/6] virt: tdx-guest: Give the Quote buffer an explicit type Peter Fang
2026-09-28 19:14   ` Edgecombe, Rick P
2026-09-28 20:16   ` Kuppuswamy Sathyanarayanan
2026-09-29  2:13   ` Binbin Wu
2026-09-29  7:41     ` Peter Fang
2026-09-29  7:43       ` Binbin Wu [this message]
2026-09-28 10:08 ` [PATCH v5 3/6] virt: tdx-guest: Calculate the Quote buffer size safely Peter Fang
2026-09-28 15:50   ` Dave Hansen
2026-09-28 20:53     ` Peter Fang
2026-09-28 10:08 ` [PATCH v5 4/6] virt: tdx-guest: Add a helper for the Quote buffer size Peter Fang
2026-09-28 16:13   ` Dave Hansen
2026-09-28 19:13     ` Edgecombe, Rick P
2026-09-29 10:32       ` Peter Fang
2026-09-29 15:45         ` Edgecombe, Rick P
2026-09-29 16:03           ` Peter Fang
2026-09-29 10:08     ` Peter Fang
2026-09-28 18:23   ` Edgecombe, Rick P
2026-09-29 16:38     ` Peter Fang
2026-09-28 10:08 ` [PATCH v5 5/6] x86/tdx: Add a helper to query maximum Quote size Peter Fang
2026-09-28 18:35   ` Edgecombe, Rick P
2026-09-28 21:00     ` Peter Fang
2026-09-28 18:50   ` Edgecombe, Rick P
2026-09-28 21:13     ` Peter Fang
2026-09-28 21:25       ` Edgecombe, Rick P
2026-09-28 21:25         ` Edgecombe, Rick P
2026-09-28 22:47           ` Peter Fang
2026-09-28 23:01         ` Peter Fang
2026-09-29 10:40       ` Peter Fang
2026-09-28 20:32   ` Kuppuswamy Sathyanarayanan
2026-09-29  9:18     ` Peter Fang
2026-09-29 14:18       ` Dave Hansen
2026-09-29 15:38         ` Peter Fang
2026-09-28 10:08 ` [PATCH v5 6/6] virt: tdx-guest: Make the Quote buffer size dynamic Peter Fang
2026-09-28 20:37   ` Kuppuswamy Sathyanarayanan
2026-09-29  7:23     ` Peter Fang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=6df0a7cf-e88f-409b-8601-1e98367e4930@linux.intel.com \
    --to=binbin.wu@linux.intel.com \
    --cc=artem.bityutskiy@intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peter.fang@intel.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=sathyanarayanan.kuppuswamy@linux.intel.com \
    --cc=seanjc@google.com \
    --cc=tglx@kernel.org \
    --cc=tony.lindgren@linux.intel.com \
    --cc=x86@kernel.org \
    --cc=xiaoyao.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®