mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Peter Fang <peter.fang@intel.com>
To: "Edgecombe, Rick P" <rick.p.edgecombe@intel.com>
Cc: "sathyanarayanan.kuppuswamy@linux.intel.com"
	<sathyanarayanan.kuppuswamy@linux.intel.com>,
	"kas@kernel.org" <kas@kernel.org>,
	"dave.hansen@linux.intel.com" <dave.hansen@linux.intel.com>,
	"seanjc@google.com" <seanjc@google.com>,
	"bp@alien8.de" <bp@alien8.de>, "x86@kernel.org" <x86@kernel.org>,
	"binbin.wu@linux.intel.com" <binbin.wu@linux.intel.com>,
	"hpa@zytor.com" <hpa@zytor.com>,
	"mingo@redhat.com" <mingo@redhat.com>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"Li, Xiaoyao" <xiaoyao.li@intel.com>,
	"tglx@kernel.org" <tglx@kernel.org>,
	"kvm@vger.kernel.org" <kvm@vger.kernel.org>,
	"linux-coco@lists.linux.dev" <linux-coco@lists.linux.dev>,
	"Bityutskiy, Artem" <artem.bityutskiy@intel.com>,
	"tony.lindgren@linux.intel.com" <tony.lindgren@linux.intel.com>
Subject: Re: [PATCH v5 4/6] virt: tdx-guest: Add a helper for the Quote buffer size
Date: Tue, 29 Sep 2026 09:38:33 -0700	[thread overview]
Message-ID: <arvpiaIvGWhWNv4E@intel.com> (raw)
In-Reply-To: <27febde6bbd1142222f0a21db4e5180e0bd3261c.camel@intel.com>

On Mon, Sep 28, 2026 at 11:23:42AM -0700, Edgecombe, Rick P wrote:
> On Mon, 2026-09-28 at 03:08 -0700, Peter Fang wrote:
> > +static size_t get_quote_buf_size(void)
> > +{
> > +	static size_t quote_buf_size;
> > +
> > +	if (quote_buf_size)
> > +		return quote_buf_size;
> > +
> > +	quote_buf_size = PAGE_ALIGN(TDX_DEFAULT_QUOTE_SIZE);
> > +
> > +	return quote_buf_size;
> > +}
> > +
> 
> This makes no sense, at the point of this patch. It lazily sets a global to a
> constant value. Function scoped static is also weird.
> 
> I think you are doing it this way so that later you can plug in the dynamic
> read. But later it still doesn't make sense why to lazily fetch it. Why not just
> read it in the tdx_guest_init() to a global? If the read fails, set to
> TDX_DEFAULT_QUOTE_SIZE. Then you are done. All callers of tdx_guest_init() just
> refer to the global. Why not?

After some offline discussion with Dave and Rick, the conclusion was
that KISS is better. Just read this metadata field each time and assume
the TDX module won't change it (because it shouldn't). That also gets
rid of the static variable.

  reply	other threads:[~2026-09-29 16:38 UTC|newest]

Thread overview: 40+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-28 10:08 [PATCH v5 0/6] tdx-guest: Make Quote buffer size dynamic Peter Fang
2026-09-28 10:08 ` [PATCH v5 1/6] x86/tdx: Take the Quote buffer as a generic pointer Peter Fang
2026-09-28 19:04   ` Edgecombe, Rick P
2026-09-28 20:37     ` Peter Fang
2026-09-28 20:10   ` Kuppuswamy Sathyanarayanan
2026-09-28 10:08 ` [PATCH v5 2/6] virt: tdx-guest: Give the Quote buffer an explicit type Peter Fang
2026-09-28 19:14   ` Edgecombe, Rick P
2026-09-28 20:16   ` Kuppuswamy Sathyanarayanan
2026-09-29  2:13   ` Binbin Wu
2026-09-29  7:41     ` Peter Fang
2026-09-29  7:43       ` Binbin Wu
2026-09-28 10:08 ` [PATCH v5 3/6] virt: tdx-guest: Calculate the Quote buffer size safely Peter Fang
2026-09-28 15:50   ` Dave Hansen
2026-09-28 20:53     ` Peter Fang
2026-09-28 10:08 ` [PATCH v5 4/6] virt: tdx-guest: Add a helper for the Quote buffer size Peter Fang
2026-09-28 16:13   ` Dave Hansen
2026-09-28 19:13     ` Edgecombe, Rick P
2026-09-29 10:32       ` Peter Fang
2026-09-29 15:45         ` Edgecombe, Rick P
2026-09-29 16:03           ` Peter Fang
2026-09-29 10:08     ` Peter Fang
2026-09-28 18:23   ` Edgecombe, Rick P
2026-09-29 16:38     ` Peter Fang [this message]
2026-09-28 10:08 ` [PATCH v5 5/6] x86/tdx: Add a helper to query maximum Quote size Peter Fang
2026-09-28 18:35   ` Edgecombe, Rick P
2026-09-28 21:00     ` Peter Fang
2026-09-28 18:50   ` Edgecombe, Rick P
2026-09-28 21:13     ` Peter Fang
2026-09-28 21:25       ` Edgecombe, Rick P
2026-09-28 21:25         ` Edgecombe, Rick P
2026-09-28 22:47           ` Peter Fang
2026-09-28 23:01         ` Peter Fang
2026-09-29 10:40       ` Peter Fang
2026-09-28 20:32   ` Kuppuswamy Sathyanarayanan
2026-09-29  9:18     ` Peter Fang
2026-09-29 14:18       ` Dave Hansen
2026-09-29 15:38         ` Peter Fang
2026-09-28 10:08 ` [PATCH v5 6/6] virt: tdx-guest: Make the Quote buffer size dynamic Peter Fang
2026-09-28 20:37   ` Kuppuswamy Sathyanarayanan
2026-09-29  7:23     ` Peter Fang

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=arvpiaIvGWhWNv4E@intel.com \
    --to=peter.fang@intel.com \
    --cc=artem.bityutskiy@intel.com \
    --cc=binbin.wu@linux.intel.com \
    --cc=bp@alien8.de \
    --cc=dave.hansen@linux.intel.com \
    --cc=hpa@zytor.com \
    --cc=kas@kernel.org \
    --cc=kvm@vger.kernel.org \
    --cc=linux-coco@lists.linux.dev \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rick.p.edgecombe@intel.com \
    --cc=sathyanarayanan.kuppuswamy@linux.intel.com \
    --cc=seanjc@google.com \
    --cc=tglx@kernel.org \
    --cc=tony.lindgren@linux.intel.com \
    --cc=x86@kernel.org \
    --cc=xiaoyao.li@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®