mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RFC PATCH 0/5] Add "func_no_repete" tracing option
@ 2021-03-04  9:01 Yordan Karadzhov (VMware)
  2021-03-04  9:01 ` [RFC PATCH 1/5] tracing: Define new ftrace event "func_repeats" Yordan Karadzhov (VMware)
                   ` (4 more replies)
  0 siblings, 5 replies; 9+ messages in thread
From: Yordan Karadzhov (VMware) @ 2021-03-04  9:01 UTC (permalink / raw)
  To: linux-kernel; +Cc: tglx, peterz, rostedt, Yordan Karadzhov (VMware)

The new option for function tracing aims to save space on the ring
buffer and to make it more readable in the case when a single function
is called number of times consecutively:

	while (cond)
		do_func();

Instead of having an identical records for each call of the function
we will record only the first call, followed by an event showing the
number of repeats.

Yordan Karadzhov (VMware) (5):
  tracing: Define new ftrace event "func_repeats"
  tracing: Add "last_func_repeats" to struct trace_array
  tracing: Add method for recording "func_repeats" events
  tracing: Unify the logic for function tracing options
  tracing: Add "func_no_repeats" option for function tracing

 kernel/trace/trace.c           |  22 ++++
 kernel/trace/trace.h           |  24 ++++
 kernel/trace/trace_entries.h   |  16 +++
 kernel/trace/trace_functions.c | 219 +++++++++++++++++++++++++++++----
 kernel/trace/trace_output.c    |  44 +++++++
 5 files changed, 298 insertions(+), 27 deletions(-)

-- 
2.25.1


^ permalink raw reply	[flat|nested] 9+ messages in thread

end of thread, other threads:[~2021-03-08 18:17 UTC | newest]

Thread overview: 9+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-03-04  9:01 [RFC PATCH 0/5] Add "func_no_repete" tracing option Yordan Karadzhov (VMware)
2021-03-04  9:01 ` [RFC PATCH 1/5] tracing: Define new ftrace event "func_repeats" Yordan Karadzhov (VMware)
2021-03-04 16:38   ` Steven Rostedt
2021-03-08 14:57     ` Yordan Karadzhov (VMware)
2021-03-08 18:15       ` Steven Rostedt
2021-03-04  9:01 ` [RFC PATCH 2/5] tracing: Add "last_func_repeats" to struct trace_array Yordan Karadzhov (VMware)
2021-03-04  9:01 ` [RFC PATCH 3/5] tracing: Add method for recording "func_repeats" events Yordan Karadzhov (VMware)
2021-03-04  9:01 ` [RFC PATCH 4/5] tracing: Unify the logic for function tracing options Yordan Karadzhov (VMware)
2021-03-04  9:01 ` [RFC PATCH 5/5] tracing: Add "func_no_repeats" option for function tracing Yordan Karadzhov (VMware)

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®