From: Philipp Hortmann <philipp.g.hortmann@gmail.com>
To: Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: [PATCH 05/11] staging: rtl8192e: Remove entry .tx_fill_cmd_d.. from struct rtl819x_ops
Date: Sun, 19 Feb 2023 22:16:00 +0100 [thread overview]
Message-ID: <713a48fcd6d56c3cc4e32aea0eeba881e0d092c5.1676840647.git.philipp.g.hortmann@gmail.com> (raw)
In-Reply-To: <cover.1676840647.git.philipp.g.hortmann@gmail.com>
Remove entry .tx_fill_cmd_descriptor and replace it with function name
rtl92e_fill_tx_cmd_desc. This increases readability of the code.
Signed-off-by: Philipp Hortmann <philipp.g.hortmann@gmail.com>
---
drivers/staging/rtl8192e/rtl8192e/rtl_core.c | 3 +--
drivers/staging/rtl8192e/rtl8192e/rtl_core.h | 4 ----
2 files changed, 1 insertion(+), 6 deletions(-)
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
index dd1f4a3c4bf9..372bb4810c31 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.c
@@ -28,7 +28,6 @@ static char *ifname = "wlan%d";
static const struct rtl819x_ops rtl819xp_ops = {
.nic_type = NIC_8192E,
.link_change = rtl92e_link_change,
- .tx_fill_cmd_descriptor = rtl92e_fill_tx_cmd_desc,
.rx_query_status_descriptor = rtl92e_get_rx_stats,
.rx_command_packet_handler = NULL,
.stop_adapter = rtl92e_stop_adapter,
@@ -1577,7 +1576,7 @@ static void _rtl92e_tx_cmd(struct net_device *dev, struct sk_buff *skb)
tcb_desc = (struct cb_desc *)(skb->cb + MAX_DEV_ADDR_SIZE);
- priv->ops->tx_fill_cmd_descriptor(dev, entry, tcb_desc, skb);
+ rtl92e_fill_tx_cmd_desc(dev, entry, tcb_desc, skb);
__skb_queue_tail(&ring->queue, skb);
spin_unlock_irqrestore(&priv->irq_th_lock, flags);
diff --git a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
index 0d4ae3a310da..5af14837df31 100644
--- a/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
+++ b/drivers/staging/rtl8192e/rtl8192e/rtl_core.h
@@ -207,10 +207,6 @@ struct rtl819x_ops {
enum nic_t nic_type;
void (*init_before_adapter_start)(struct net_device *dev);
void (*link_change)(struct net_device *dev);
- void (*tx_fill_cmd_descriptor)(struct net_device *dev,
- struct tx_desc_cmd *entry,
- struct cb_desc *cb_desc,
- struct sk_buff *skb);
bool (*rx_query_status_descriptor)(struct net_device *dev,
struct rtllib_rx_stats *stats,
struct rx_desc *pdesc,
--
2.39.2
next prev parent reply other threads:[~2023-02-19 21:16 UTC|newest]
Thread overview: 12+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-02-19 21:15 [PATCH 00/11] staging: rtl8192e: Remove entries from struct rtl819x_ops start with .get_eeprom_size Philipp Hortmann
2023-02-19 21:15 ` [PATCH 01/11] staging: rtl8192e: Remove entry .get_eeprom_size from struct rtl819x_ops Philipp Hortmann
2023-02-19 21:15 ` [PATCH 02/11] staging: rtl8192e: Remove entry .init_adapter_.. " Philipp Hortmann
2023-02-19 21:15 ` [PATCH 03/11] staging: rtl8192e: Remove entry .initialize_ad.. " Philipp Hortmann
2023-02-19 21:15 ` [PATCH 04/11] staging: rtl8192e: Remove entry .tx_fill_descr.. " Philipp Hortmann
2023-02-19 21:16 ` Philipp Hortmann [this message]
2023-02-19 21:16 ` [PATCH 06/11] staging: rtl8192e: Remove entry .rx_query_stat.. " Philipp Hortmann
2023-02-19 21:16 ` [PATCH 07/11] staging: rtl8192e: Remove entry .stop_adapter " Philipp Hortmann
2023-02-19 21:16 ` [PATCH 08/11] staging: rtl8192e: Remove entry .update_ratr_t.. " Philipp Hortmann
2023-02-19 21:16 ` [PATCH 09/11] staging: rtl8192e: Remove entry .irq_enable " Philipp Hortmann
2023-02-19 21:16 ` [PATCH 10/11] staging: rtl8192e: Remove entry .irq_disable " Philipp Hortmann
2023-02-19 21:16 ` [PATCH 11/11] staging: rtl8192e: Remove entry .rx_enable " Philipp Hortmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=713a48fcd6d56c3cc4e32aea0eeba881e0d092c5.1676840647.git.philipp.g.hortmann@gmail.com \
--to=philipp.g.hortmann@gmail.com \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®