From: Jia Zhu <zhujia.zj@bytedance.com>
To: linux-erofs@lists.ozlabs.org, xiang@kernel.org, chao@kernel.org,
linux-fsdevel@vger.kernel.org, linux-kernel@vger.kernel.org,
yinxin.x@bytedance.com, jefflexu@linux.alibaba.com,
huyue2@coolpad.com
Subject: Re: [External] Re: [PATCH V3 4/6] erofs: introduce fscache-based domain
Date: Thu, 15 Sep 2022 16:00:58 +0800 [thread overview]
Message-ID: <748071b4-446a-410e-6c75-e8846b990c47@bytedance.com> (raw)
In-Reply-To: <YyHVQGftl/0Bf4kW@B-P7TQMD6M-0146.lan>
在 2022/9/14 21:21, Gao Xiang 写道:
> On Wed, Sep 14, 2022 at 06:50:39PM +0800, Jia Zhu wrote:
>> A new fscache-based shared domain mode is going to be introduced for
>> erofs. In which case, same data blobs in same domain will be shared
>> and reused to reduce on-disk space usage.
>>
>> As the first step, we use pseudo mnt to manage and maintain domain's
>> lifecycle.
>>
>> The implementation of sharing blobs will be introduced in subsequent
>> patches.
>>
>> Signed-off-by: Jia Zhu <zhujia.zj@bytedance.com>
>> ---
>> fs/erofs/fscache.c | 134 ++++++++++++++++++++++++++++++++++++++------
>> fs/erofs/internal.h | 9 +++
>> 2 files changed, 127 insertions(+), 16 deletions(-)
>>
>> diff --git a/fs/erofs/fscache.c b/fs/erofs/fscache.c
>> index 4159cf781924..b2100dc67cde 100644
>> --- a/fs/erofs/fscache.c
>> +++ b/fs/erofs/fscache.c
>> @@ -1,10 +1,14 @@
>> // SPDX-License-Identifier: GPL-2.0-or-later
>> /*
>> * Copyright (C) 2022, Alibaba Cloud
>> + * Copyright (C) 2022, Bytedance Inc. All rights reserved.
>> */
>> #include <linux/fscache.h>
>> #include "internal.h"
>>
>> +static DEFINE_MUTEX(erofs_domain_list_lock);
>> +static LIST_HEAD(erofs_domain_list);
>> +
>> static struct netfs_io_request *erofs_fscache_alloc_request(struct address_space *mapping,
>> loff_t start, size_t len)
>> {
>> @@ -417,6 +421,106 @@ const struct address_space_operations erofs_fscache_access_aops = {
>> .readahead = erofs_fscache_readahead,
>> };
>>
>> +static
>> +struct erofs_domain *erofs_fscache_domain_get(struct erofs_domain *domain)
>> +{
>> + refcount_inc(&domain->ref);
>> + return domain;
>> +}
>
> We can just open-code that.
Thanks, I'll revise it.
>
>> +
>> +static void erofs_fscache_domain_put(struct erofs_domain *domain)
>> +{
>> + if (!domain)
>> + return;
>> + if (refcount_dec_and_test(&domain->ref)) {
>> + fscache_relinquish_volume(domain->volume, NULL, false);
>> + mutex_lock(&erofs_domain_list_lock);
>> + list_del(&domain->list);
>> + mutex_unlock(&erofs_domain_list_lock);
>> + kfree(domain->domain_id);
>> + kfree(domain);
>> + }
>> +}
>> +
>> +static int erofs_fscache_register_volume(struct super_block *sb)
>> +{
>> + struct erofs_sb_info *sbi = EROFS_SB(sb);
>> + char *domain_id = sbi->opt.domain_id;
>> + struct fscache_volume *volume;
>> + char *name;
>> + int ret = 0;
>> +
>> + if (domain_id)
>> + name = kasprintf(GFP_KERNEL, "erofs,%s", domain_id);
>> + else
>> + name = kasprintf(GFP_KERNEL, "erofs,%s", sbi->opt.fsid);
>
> I think we could just use
>
> name = kasprintf(GFP_KERNEL, "erofs,%s",
> domain_id ? domain_id : sbi->opt.fsid);
>
> here.
Thanks.
>
>> + if (!name)
>> + return -ENOMEM;
>> +
>> + volume = fscache_acquire_volume(name, NULL, NULL, 0);
>> + if (IS_ERR_OR_NULL(volume)) {
>> + erofs_err(sb, "failed to register volume for %s", name);
>> + ret = volume ? PTR_ERR(volume) : -EOPNOTSUPP;
>> + volume = NULL;
>> + }
>> +
>> + sbi->volume = volume;
>> + kfree(name);
>> + return ret;
>> +}
>> +
>> +static int erofs_fscache_init_domain(struct super_block *sb)
>> +{
>> + int err;
>> + struct erofs_domain *domain;
>> + struct erofs_sb_info *sbi = EROFS_SB(sb);
>> +
>> + domain = kzalloc(sizeof(struct erofs_domain), GFP_KERNEL);
>> + if (!domain)
>> + return -ENOMEM;
>> +
>> + domain->domain_id = kstrdup(sbi->opt.domain_id, GFP_KERNEL);
>> + if (!domain->domain_id) {
>> + kfree(domain);
>> + return -ENOMEM;
>> + }
>> + sbi->domain = domain;
>> + err = erofs_fscache_register_volume(sb);
>> + if (err)
>> + goto out;
>> +
>> + domain->volume = sbi->volume;
>> + refcount_set(&domain->ref, 1);
>> + mutex_init(&domain->mutex);
>> + list_add(&domain->list, &erofs_domain_list);
>> + return 0;
>> +out:
>> + kfree(domain->domain_id);
>> + kfree(domain);
>> + sbi->domain = NULL;
>> + return err;
>> +}
>> +
>> +static int erofs_fscache_register_domain(struct super_block *sb)
>> +{
>> + int err;
>> + struct erofs_domain *domain;
>> + struct erofs_sb_info *sbi = EROFS_SB(sb);
>> +
>> + mutex_lock(&erofs_domain_list_lock);
>> + list_for_each_entry(domain, &erofs_domain_list, list) {
>> + if (!strcmp(domain->domain_id, sbi->opt.domain_id)) {
>> + sbi->domain = erofs_fscache_domain_get(domain);
>> + sbi->volume = domain->volume;
>> + mutex_unlock(&erofs_domain_list_lock);
>> + return 0;
>> + }
>> + }
>> + err = erofs_fscache_init_domain(sb);
>
> why introduce erofs_fscache_init_domain?
>
To make error handling path simpler, avoid lots of 'goto' and 'unlock'
>> + mutex_unlock(&erofs_domain_list_lock);
>> + return err;
>> +}
>> +
>> struct erofs_fscache *erofs_fscache_register_cookie(struct super_block *sb,
>> char *name, bool need_inode)
>> {
>> @@ -486,24 +590,16 @@ void erofs_fscache_unregister_cookie(struct erofs_fscache *ctx)
>> int erofs_fscache_register_fs(struct super_block *sb)
>> {
>> struct erofs_sb_info *sbi = EROFS_SB(sb);
>> - struct fscache_volume *volume;
>> struct erofs_fscache *fscache;
>> - char *name;
>> - int ret = 0;
>> + int ret;
>>
>> - name = kasprintf(GFP_KERNEL, "erofs,%s", sbi->opt.fsid);
>> - if (!name)
>> - return -ENOMEM;
>> + if (sbi->opt.domain_id)
>> + ret = erofs_fscache_register_domain(sb);
>> + else
>> + ret = erofs_fscache_register_volume(sb);
>>
>> - volume = fscache_acquire_volume(name, NULL, NULL, 0);
>> - if (IS_ERR_OR_NULL(volume)) {
>> - erofs_err(sb, "failed to register volume for %s", name);
>> - ret = volume ? PTR_ERR(volume) : -EOPNOTSUPP;
>> - volume = NULL;
>> - }
>> -
>> - sbi->volume = volume;
>> - kfree(name);
>> + if (ret)
>> + return ret;
>>
>> fscache = erofs_fscache_register_cookie(sb, sbi->opt.fsid, true);
>> if (IS_ERR(fscache))
>> @@ -518,7 +614,13 @@ void erofs_fscache_unregister_fs(struct super_block *sb)
>> struct erofs_sb_info *sbi = EROFS_SB(sb);
>>
>> erofs_fscache_unregister_cookie(sbi->s_fscache);
>> - fscache_relinquish_volume(sbi->volume, NULL, false);
>> sbi->s_fscache = NULL;
>> +
>> + if (sbi->domain)
>> + erofs_fscache_domain_put(sbi->domain);
>> + else
>> + fscache_relinquish_volume(sbi->volume, NULL, false);
>> +
>
> How about using one helper and pass in sb directly instead?
Thanks for your suggestion, I'll revise it in next version.
>
> Thanks,
> Gao Xiang
next prev parent reply other threads:[~2022-09-15 8:01 UTC|newest]
Thread overview: 21+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-09-14 10:50 [PATCH V3 0/6] Introduce erofs shared domain Jia Zhu
2022-09-14 10:50 ` [PATCH V3 1/6] erofs: use kill_anon_super() to kill super in fscache mode Jia Zhu
2022-09-15 2:28 ` JeffleXu
2022-09-15 6:07 ` [External] " Jia Zhu
2022-09-14 10:50 ` [PATCH V3 2/6] erofs: code clean up for fscache Jia Zhu
2022-09-15 2:26 ` JeffleXu
2022-09-15 6:45 ` JeffleXu
2022-09-14 10:50 ` [PATCH V3 3/6] erofs: introduce 'domain_id' mount option Jia Zhu
2022-09-15 7:30 ` JeffleXu
2022-09-15 7:43 ` [External] " Jia Zhu
2022-09-14 10:50 ` [PATCH V3 4/6] erofs: introduce fscache-based domain Jia Zhu
2022-09-14 13:21 ` Gao Xiang
2022-09-15 3:29 ` JeffleXu
2022-09-15 8:00 ` Jia Zhu [this message]
2022-09-15 3:27 ` JeffleXu
2022-09-14 10:50 ` [PATCH V3 5/6] erofs: introduce a pseudo mnt to manage shared cookies Jia Zhu
2022-09-15 5:43 ` JeffleXu
2022-09-14 10:50 ` [PATCH V3 6/6] erofs: Support sharing cookies in the same domain Jia Zhu
2022-09-14 13:30 ` Gao Xiang
2022-09-15 6:53 ` JeffleXu
2022-09-15 7:26 ` [External] " Jia Zhu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=748071b4-446a-410e-6c75-e8846b990c47@bytedance.com \
--to=zhujia.zj@bytedance.com \
--cc=chao@kernel.org \
--cc=huyue2@coolpad.com \
--cc=jefflexu@linux.alibaba.com \
--cc=linux-erofs@lists.ozlabs.org \
--cc=linux-fsdevel@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=xiang@kernel.org \
--cc=yinxin.x@bytedance.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®