* [PATCH v3] staging: rtl8712: rename tmpVal to avg_val
@ 2024-03-13 7:13 Ayush Tiwari
2024-03-13 7:31 ` Dan Carpenter
2024-03-13 7:59 ` Julia Lawall
0 siblings, 2 replies; 3+ messages in thread
From: Ayush Tiwari @ 2024-03-13 7:13 UTC (permalink / raw)
To: Larry.Finger, florian.c.schilhabel, gregkh, linux-kernel, linux-staging
Cc: outreachy
Rename local variable tmpVal to avg_val in function process_link_qual
to give intuitive meaning to variable and match the common kernel
coding style.
Signed-off-by: Ayush Tiwari <ayushtiw0110@gmail.com>
Changes in v3: changed variable name tmpVal to avg_val
Changes in v2: added a period in message
---
drivers/staging/rtl8712/rtl8712_recv.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/drivers/staging/rtl8712/rtl8712_recv.c b/drivers/staging/rtl8712/rtl8712_recv.c
index a3c4713c59b3..1fabc5137a4c 100644
--- a/drivers/staging/rtl8712/rtl8712_recv.c
+++ b/drivers/staging/rtl8712/rtl8712_recv.c
@@ -861,7 +861,7 @@ static void query_rx_phy_status(struct _adapter *padapter,
static void process_link_qual(struct _adapter *padapter,
union recv_frame *prframe)
{
- u32 last_evm = 0, tmpVal;
+ u32 last_evm = 0, avg_val;
struct rx_pkt_attrib *pattrib;
struct smooth_rssi_data *sqd = &padapter->recvpriv.signal_qual_data;
@@ -883,8 +883,8 @@ static void process_link_qual(struct _adapter *padapter,
sqd->index = 0;
/* <1> Showed on UI for user, in percentage. */
- tmpVal = sqd->total_val / sqd->total_num;
- padapter->recvpriv.signal = (u8)tmpVal;
+ avg_val = sqd->total_val / sqd->total_num;
+ padapter->recvpriv.signal = (u8)avg_val;
}
}
--
2.40.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH v3] staging: rtl8712: rename tmpVal to avg_val
2024-03-13 7:13 [PATCH v3] staging: rtl8712: rename tmpVal to avg_val Ayush Tiwari
@ 2024-03-13 7:31 ` Dan Carpenter
2024-03-13 7:59 ` Julia Lawall
1 sibling, 0 replies; 3+ messages in thread
From: Dan Carpenter @ 2024-03-13 7:31 UTC (permalink / raw)
To: Ayush Tiwari
Cc: Larry.Finger, florian.c.schilhabel, gregkh, linux-kernel,
linux-staging, outreachy
On Wed, Mar 13, 2024 at 12:43:18PM +0530, Ayush Tiwari wrote:
> Rename local variable tmpVal to avg_val in function process_link_qual
> to give intuitive meaning to variable and match the common kernel
> coding style.
>
> Signed-off-by: Ayush Tiwari <ayushtiw0110@gmail.com>
>
> Changes in v3: changed variable name tmpVal to avg_val
> Changes in v2: added a period in message
It's not an average, it's a percent.
regards,
dan carpenter
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH v3] staging: rtl8712: rename tmpVal to avg_val
2024-03-13 7:13 [PATCH v3] staging: rtl8712: rename tmpVal to avg_val Ayush Tiwari
2024-03-13 7:31 ` Dan Carpenter
@ 2024-03-13 7:59 ` Julia Lawall
1 sibling, 0 replies; 3+ messages in thread
From: Julia Lawall @ 2024-03-13 7:59 UTC (permalink / raw)
To: Ayush Tiwari
Cc: Larry.Finger, florian.c.schilhabel, gregkh, linux-kernel,
linux-staging, outreachy
On Wed, 13 Mar 2024, Ayush Tiwari wrote:
> Rename local variable tmpVal to avg_val in function process_link_qual
> to give intuitive meaning to variable and match the common kernel
> coding style.
>
> Signed-off-by: Ayush Tiwari <ayushtiw0110@gmail.com>
>
> Changes in v3: changed variable name tmpVal to avg_val
> Changes in v2: added a period in message
This information should be below the ---. Then it will be removed when
the patch is applied. This information is only meaningful to the mailing
list. The git history won't contain the previous versions, so the change
comments won't be meaningful.
julia
> ---
> drivers/staging/rtl8712/rtl8712_recv.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/staging/rtl8712/rtl8712_recv.c b/drivers/staging/rtl8712/rtl8712_recv.c
> index a3c4713c59b3..1fabc5137a4c 100644
> --- a/drivers/staging/rtl8712/rtl8712_recv.c
> +++ b/drivers/staging/rtl8712/rtl8712_recv.c
> @@ -861,7 +861,7 @@ static void query_rx_phy_status(struct _adapter *padapter,
> static void process_link_qual(struct _adapter *padapter,
> union recv_frame *prframe)
> {
> - u32 last_evm = 0, tmpVal;
> + u32 last_evm = 0, avg_val;
> struct rx_pkt_attrib *pattrib;
> struct smooth_rssi_data *sqd = &padapter->recvpriv.signal_qual_data;
>
> @@ -883,8 +883,8 @@ static void process_link_qual(struct _adapter *padapter,
> sqd->index = 0;
>
> /* <1> Showed on UI for user, in percentage. */
> - tmpVal = sqd->total_val / sqd->total_num;
> - padapter->recvpriv.signal = (u8)tmpVal;
> + avg_val = sqd->total_val / sqd->total_num;
> + padapter->recvpriv.signal = (u8)avg_val;
> }
> }
>
> --
> 2.40.1
>
>
>
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2024-03-13 7:59 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-03-13 7:13 [PATCH v3] staging: rtl8712: rename tmpVal to avg_val Ayush Tiwari
2024-03-13 7:31 ` Dan Carpenter
2024-03-13 7:59 ` Julia Lawall
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®