mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Marcin Nowakowski <marcin.nowakowski@imgtec.com>
To: Steven Rostedt <rostedt@goodmis.org>
Cc: Ingo Molnar <mingo@redhat.com>, <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits
Date: Fri, 9 Dec 2016 15:04:30 +0100	[thread overview]
Message-ID: <80063f6e-575f-843b-c5c5-22ad7b1e24e8@imgtec.com> (raw)
In-Reply-To: <20161209090316.41beafcc@gandalf.local.home>


On 09.12.2016 15:03, Steven Rostedt wrote:
> On Fri, 9 Dec 2016 09:00:52 -0500
> Steven Rostedt <rostedt@goodmis.org> wrote:
>
>> On Fri, 9 Dec 2016 13:25:51 +0100
>> Marcin Nowakowski <marcin.nowakowski@imgtec.com> wrote:
>>
>>> The number of probe hits is stored in a percpu variable and therefore
>>> can't be read directly. Add a helper method trace_kprobe_nhit() that
>>> performs the required calculation.
>>
>> Can you please add the "why?" to this change log. Who needs this
>> functionality, and why?
>>
>
> I should have specified, even if the next patch uses the functionality,
> each patch's change log should stand on its own. In the future, when
> people do git blame, they wont be seeing patch series. They will only
> see the change log of the one change.

Sure, I will send an updated version with a better changelog.

Marcin

      reply	other threads:[~2016-12-09 14:04 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-12-09 12:25 Marcin Nowakowski
2016-12-09 12:25 ` [PATCH 2/2] kprobes/trace: Fix kprobe selftest for newer gcc Marcin Nowakowski
2016-12-09 14:00 ` [PATCH 1/2] tracing/kprobes: add a helper method to return number of probe hits Steven Rostedt
2016-12-09 14:03   ` Steven Rostedt
2016-12-09 14:04     ` Marcin Nowakowski [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=80063f6e-575f-843b-c5c5-22ad7b1e24e8@imgtec.com \
    --to=marcin.nowakowski@imgtec.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=rostedt@goodmis.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®