From: Philipp Hortmann <philipp.g.hortmann@gmail.com>
To: Forest Bond <forest@alittletooquiet.net>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: [PATCH 01/13] staging: vt6655: Rename byRegOfs to reg_offset in four macros
Date: Wed, 13 Jul 2022 06:58:56 +0200 [thread overview]
Message-ID: <82f65d22ac8cd75b2c7790c13be3d0068968925b.1657657918.git.philipp.g.hortmann@gmail.com> (raw)
In-Reply-To: <cover.1657657918.git.philipp.g.hortmann@gmail.com>
Fix name of a variable in four macros that use CamelCase which is not
accepted by checkpatch.pl
Signed-off-by: Philipp Hortmann <philipp.g.hortmann@gmail.com>
---
drivers/staging/vt6655/mac.h | 24 ++++++++++++------------
1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/drivers/staging/vt6655/mac.h b/drivers/staging/vt6655/mac.h
index 5c14a76ed799..b3803143673c 100644
--- a/drivers/staging/vt6655/mac.h
+++ b/drivers/staging/vt6655/mac.h
@@ -537,32 +537,32 @@
/*--------------------- Export Macros ------------------------------*/
-#define MACvRegBitsOn(iobase, byRegOfs, byBits) \
+#define MACvRegBitsOn(iobase, reg_offset, byBits) \
do { \
unsigned char byData; \
- byData = ioread8(iobase + byRegOfs); \
- iowrite8(byData | (byBits), iobase + byRegOfs); \
+ byData = ioread8(iobase + reg_offset); \
+ iowrite8(byData | (byBits), iobase + reg_offset); \
} while (0)
-#define MACvWordRegBitsOn(iobase, byRegOfs, wBits) \
+#define MACvWordRegBitsOn(iobase, reg_offset, wBits) \
do { \
unsigned short wData; \
- wData = ioread16(iobase + byRegOfs); \
- iowrite16(wData | (wBits), iobase + byRegOfs); \
+ wData = ioread16(iobase + reg_offset); \
+ iowrite16(wData | (wBits), iobase + reg_offset); \
} while (0)
-#define MACvRegBitsOff(iobase, byRegOfs, byBits) \
+#define MACvRegBitsOff(iobase, reg_offset, byBits) \
do { \
unsigned char byData; \
- byData = ioread8(iobase + byRegOfs); \
- iowrite8(byData & ~(byBits), iobase + byRegOfs); \
+ byData = ioread8(iobase + reg_offset); \
+ iowrite8(byData & ~(byBits), iobase + reg_offset); \
} while (0)
-#define MACvWordRegBitsOff(iobase, byRegOfs, wBits) \
+#define MACvWordRegBitsOff(iobase, reg_offset, wBits) \
do { \
unsigned short wData; \
- wData = ioread16(iobase + byRegOfs); \
- iowrite16(wData & ~(wBits), iobase + byRegOfs); \
+ wData = ioread16(iobase + reg_offset); \
+ iowrite16(wData & ~(wBits), iobase + reg_offset); \
} while (0)
#define MACvReceive0(iobase) \
--
2.37.0
next prev parent reply other threads:[~2022-07-13 4:59 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-13 4:58 [PATCH 00/13] staging: vt6655: Convert four macros to functions Philipp Hortmann
2022-07-13 4:58 ` Philipp Hortmann [this message]
2022-07-13 4:59 ` [PATCH 02/13] staging: vt6655: Rename byBits to bit_mask in two macros Philipp Hortmann
2022-07-13 4:59 ` [PATCH 03/13] staging: vt6655: Rename wBits " Philipp Hortmann
2022-07-13 4:59 ` [PATCH 04/13] staging: vt6655: Rename byData to reg_value " Philipp Hortmann
2022-07-13 5:00 ` [PATCH 05/13] staging: vt6655: Rename wData " Philipp Hortmann
2022-07-13 5:00 ` [PATCH 07/13] staging: vt6655: Rename MACvWordRegBitsOn Philipp Hortmann
2022-07-13 5:00 ` [PATCH 06/13] staging: vt6655: Rename MACvRegBitsOn Philipp Hortmann
2022-07-13 5:00 ` [PATCH 09/13] staging: vt6655: Rename MACvWordRegBitsOff Philipp Hortmann
2022-07-13 5:01 ` [PATCH 08/13] staging: vt6655: Rename MACvRegBitsOff Philipp Hortmann
2022-07-13 5:01 ` [PATCH 10/13] staging: vt6655: Convert macro vt6655_mac_reg_bits_on to function Philipp Hortmann
2022-07-13 5:01 ` [PATCH 11/13] staging: vt6655: Convert macro vt6655_mac_word_reg_bits_on " Philipp Hortmann
2022-07-13 5:02 ` [PATCH 12/13] staging: vt6655: Convert macro vt6655_mac_reg_bits_off " Philipp Hortmann
2022-07-13 5:02 ` [PATCH 13/13] staging: vt6655: Convert macro vt6655_mac_word_reg_bits_off " Philipp Hortmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=82f65d22ac8cd75b2c7790c13be3d0068968925b.1657657918.git.philipp.g.hortmann@gmail.com \
--to=philipp.g.hortmann@gmail.com \
--cc=forest@alittletooquiet.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®