From: Philipp Hortmann <philipp.g.hortmann@gmail.com>
To: Forest Bond <forest@alittletooquiet.net>,
Greg Kroah-Hartman <gregkh@linuxfoundation.org>,
linux-staging@lists.linux.dev, linux-kernel@vger.kernel.org
Subject: [PATCH 09/13] staging: vt6655: Rename MACvWordRegBitsOff
Date: Wed, 13 Jul 2022 07:00:57 +0200 [thread overview]
Message-ID: <b8d4b72ddfdefb6b8a73fb95f6851e0f365118ba.1657657918.git.philipp.g.hortmann@gmail.com> (raw)
In-Reply-To: <cover.1657657918.git.philipp.g.hortmann@gmail.com>
Fix name of a macro that uses CamelCase which is not
accepted by checkpatch.pl
Signed-off-by: Philipp Hortmann <philipp.g.hortmann@gmail.com>
---
drivers/staging/vt6655/card.c | 12 ++++++------
drivers/staging/vt6655/mac.h | 2 +-
drivers/staging/vt6655/rf.c | 2 +-
3 files changed, 8 insertions(+), 8 deletions(-)
diff --git a/drivers/staging/vt6655/card.c b/drivers/staging/vt6655/card.c
index ec70a1f611d4..846469cc06bb 100644
--- a/drivers/staging/vt6655/card.c
+++ b/drivers/staging/vt6655/card.c
@@ -352,18 +352,18 @@ void CARDbRadioPowerOff(struct vnt_private *priv)
switch (priv->byRFType) {
case RF_RFMD2959:
- MACvWordRegBitsOff(priv->port_offset, MAC_REG_SOFTPWRCTL,
- SOFTPWRCTL_TXPEINV);
+ vt6655_mac_word_reg_bits_off(priv->port_offset, MAC_REG_SOFTPWRCTL,
+ SOFTPWRCTL_TXPEINV);
vt6655_mac_word_reg_bits_on(priv->port_offset, MAC_REG_SOFTPWRCTL,
SOFTPWRCTL_SWPE1);
break;
case RF_AIROHA:
case RF_AL2230S:
- MACvWordRegBitsOff(priv->port_offset, MAC_REG_SOFTPWRCTL,
- SOFTPWRCTL_SWPE2);
- MACvWordRegBitsOff(priv->port_offset, MAC_REG_SOFTPWRCTL,
- SOFTPWRCTL_SWPE3);
+ vt6655_mac_word_reg_bits_off(priv->port_offset, MAC_REG_SOFTPWRCTL,
+ SOFTPWRCTL_SWPE2);
+ vt6655_mac_word_reg_bits_off(priv->port_offset, MAC_REG_SOFTPWRCTL,
+ SOFTPWRCTL_SWPE3);
break;
}
diff --git a/drivers/staging/vt6655/mac.h b/drivers/staging/vt6655/mac.h
index 16f2b77e1371..4d328b724559 100644
--- a/drivers/staging/vt6655/mac.h
+++ b/drivers/staging/vt6655/mac.h
@@ -558,7 +558,7 @@ do { \
iowrite8(reg_value & ~(bit_mask), iobase + reg_offset); \
} while (0)
-#define MACvWordRegBitsOff(iobase, reg_offset, bit_mask) \
+#define vt6655_mac_word_reg_bits_off(iobase, reg_offset, bit_mask) \
do { \
unsigned short reg_value; \
reg_value = ioread16(iobase + reg_offset); \
diff --git a/drivers/staging/vt6655/rf.c b/drivers/staging/vt6655/rf.c
index 6953afc0be34..1fadc2fc4412 100644
--- a/drivers/staging/vt6655/rf.c
+++ b/drivers/staging/vt6655/rf.c
@@ -212,7 +212,7 @@ static bool RFbAL2230Init(struct vnt_private *priv)
vt6655_mac_word_reg_bits_on(iobase, MAC_REG_SOFTPWRCTL,
(SOFTPWRCTL_SWPECTI | SOFTPWRCTL_TXPEINV));
/* PLL Off */
- MACvWordRegBitsOff(iobase, MAC_REG_SOFTPWRCTL, SOFTPWRCTL_SWPE3);
+ vt6655_mac_word_reg_bits_off(iobase, MAC_REG_SOFTPWRCTL, SOFTPWRCTL_SWPE3);
/* patch abnormal AL2230 frequency output */
IFRFbWriteEmbedded(priv, (0x07168700 + (BY_AL2230_REG_LEN << 3) + IFREGCTL_REGW));
--
2.37.0
next prev parent reply other threads:[~2022-07-13 5:01 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2022-07-13 4:58 [PATCH 00/13] staging: vt6655: Convert four macros to functions Philipp Hortmann
2022-07-13 4:58 ` [PATCH 01/13] staging: vt6655: Rename byRegOfs to reg_offset in four macros Philipp Hortmann
2022-07-13 4:59 ` [PATCH 02/13] staging: vt6655: Rename byBits to bit_mask in two macros Philipp Hortmann
2022-07-13 4:59 ` [PATCH 03/13] staging: vt6655: Rename wBits " Philipp Hortmann
2022-07-13 4:59 ` [PATCH 04/13] staging: vt6655: Rename byData to reg_value " Philipp Hortmann
2022-07-13 5:00 ` [PATCH 05/13] staging: vt6655: Rename wData " Philipp Hortmann
2022-07-13 5:00 ` [PATCH 07/13] staging: vt6655: Rename MACvWordRegBitsOn Philipp Hortmann
2022-07-13 5:00 ` [PATCH 06/13] staging: vt6655: Rename MACvRegBitsOn Philipp Hortmann
2022-07-13 5:00 ` Philipp Hortmann [this message]
2022-07-13 5:01 ` [PATCH 08/13] staging: vt6655: Rename MACvRegBitsOff Philipp Hortmann
2022-07-13 5:01 ` [PATCH 10/13] staging: vt6655: Convert macro vt6655_mac_reg_bits_on to function Philipp Hortmann
2022-07-13 5:01 ` [PATCH 11/13] staging: vt6655: Convert macro vt6655_mac_word_reg_bits_on " Philipp Hortmann
2022-07-13 5:02 ` [PATCH 12/13] staging: vt6655: Convert macro vt6655_mac_reg_bits_off " Philipp Hortmann
2022-07-13 5:02 ` [PATCH 13/13] staging: vt6655: Convert macro vt6655_mac_word_reg_bits_off " Philipp Hortmann
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=b8d4b72ddfdefb6b8a73fb95f6851e0f365118ba.1657657918.git.philipp.g.hortmann@gmail.com \
--to=philipp.g.hortmann@gmail.com \
--cc=forest@alittletooquiet.net \
--cc=gregkh@linuxfoundation.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-staging@lists.linux.dev \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®