From: Chao Yu <chao@kernel.org>
To: Nanzhe Zhao <zhaonanzhe@xiaomi.com>
Cc: chao@kernel.org, linux-f2fs-devel@lists.sourceforge.net,
Barry Song <baohua@kernel.org>, Juan Yescas <jyescas@google.com>,
Dev Jain <Dev.Jain@arm.com>,
linux-kernel@vger.kernel.org,
David Hildenbrand <David.Hildenbrand@arm.com>,
Bo Zhang <zhangbo56@xiaomi.com>,
Kalesh Singh <kaleshsingh@google.com>,
Ryan Roberts <Ryan.Roberts@arm.com>,
Jaegeuk Kim <jaegeuk@kernel.org>,
Pengfei Li <lipengfei28@xiaomi.com>
Subject: Re: [f2fs-dev] [RFC PATCH v2 02/10] f2fs: carry subpage offset and count in write IO
Date: Fri, 10 Jul 2026 11:04:23 +0800 [thread overview]
Message-ID: <835e14b7-17d7-4f9c-b84b-593a0f2d5982@kernel.org> (raw)
In-Reply-To: <20260710011534.2307696-1-zhaonanzhe@xiaomi.com>
On 7/10/26 09:15, Nanzhe Zhao wrote:
>> How about cleaning up w/ below macros?
>>
>> #define F2FS_FOLIO_INDEX(folio, fio) (folio->index + fio->folio_offset)
>> #define F2FS_FOLIO_BLKCNT(fio) (fio->folio_blkcnt ? fio->folio_blkcnt : 1)
>
> F2FS_FOLIO_XXX naming seems a bit weird to me :). It does not show that
> we want to use the folio subpage index associated with fio, or the blkcnt
> recorded in fio. I think names like F2FS_FIO_LBLK and F2FS_FIO_BLKCNT
> may be better?
Looks fine to me. :)
Thanks,
next prev parent reply other threads:[~2026-07-10 3:04 UTC|newest]
Thread overview: 19+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-06-22 16:08 [f2fs-dev] [RFC PATCH v2 00/10] f2fs: support & optimize large folios for writable files Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 01/10] f2fs: extend folio state for large folio write path Nanzhe Zhao
2026-06-30 7:37 ` Chao Yu
[not found] ` <20260710011534.2307696-2-zhaonanzhe@xiaomi.com>
2026-07-10 3:05 ` Chao Yu
2026-07-06 7:43 ` Nanzhe Zhao
2026-07-06 7:53 ` Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 02/10] f2fs: carry subpage offset and count in write IO Nanzhe Zhao
2026-06-30 8:38 ` Chao Yu
2026-07-10 1:15 ` Nanzhe Zhao
2026-07-10 3:04 ` Chao Yu [this message]
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 03/10] f2fs: support regular file buffered writes on large folios Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 04/10] f2fs: support atomic file large folios buffered write Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 05/10] f2fs: support large folio writeback Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 06/10] f2fs: prepare mmap write faults for large folios Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 07/10] f2fs: make GC migration large-folio aware Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 08/10] f2fs: allow large folio support to writeable files Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 09/10] f2fs: optimize small block size large folio read Nanzhe Zhao
2026-06-22 16:08 ` [f2fs-dev] [RFC PATCH v2 10/10] f2fs: support partial uptodate " Nanzhe Zhao
2026-07-01 2:51 ` [f2fs-dev] [RFC PATCH v2 00/10] f2fs: support & optimize large folios for writable files Chao Yu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=835e14b7-17d7-4f9c-b84b-593a0f2d5982@kernel.org \
--to=chao@kernel.org \
--cc=David.Hildenbrand@arm.com \
--cc=Dev.Jain@arm.com \
--cc=Ryan.Roberts@arm.com \
--cc=baohua@kernel.org \
--cc=jaegeuk@kernel.org \
--cc=jyescas@google.com \
--cc=kaleshsingh@google.com \
--cc=linux-f2fs-devel@lists.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=lipengfei28@xiaomi.com \
--cc=zhangbo56@xiaomi.com \
--cc=zhaonanzhe@xiaomi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome