mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Muchun Song <muchun.song@linux.dev>
To: "David Hildenbrand (Arm)" <david@kernel.org>
Cc: Muchun Song <songmuchun@bytedance.com>,
	Madhavan Srinivasan <maddy@linux.ibm.com>,
	Mike Rapoport <rppt@kernel.org>,
	Andrew Morton <akpm@linux-foundation.org>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Nicholas Piggin <npiggin@gmail.com>,
	Christophe Leroy <chleroy@kernel.org>,
	Lorenzo Stoakes <ljs@kernel.org>,
	"Liam R . Howlett" <liam@infradead.org>,
	Vlastimil Babka <vbabka@kernel.org>,
	Suren Baghdasaryan <surenb@google.com>,
	Michal Hocko <mhocko@suse.com>, Qi Zheng <qi.zheng@linux.dev>,
	linuxppc-dev@lists.ozlabs.org, linux-kernel@vger.kernel.org,
	linux-mm@kvack.org
Subject: Re: [PATCH v2 0/6] mm: Unify device DAX and HugeTLB vmemmap population paths
Date: Mon, 28 Sep 2026 21:49:55 +0800	[thread overview]
Message-ID: <8385F749-0F72-494E-9CA2-2E433A066712@linux.dev> (raw)
In-Reply-To: <607759bf-59f2-4ad6-b95b-e780ed2acba3@kernel.org>



> On Sep 28, 2026, at 20:44, David Hildenbrand (Arm) <david@kernel.org> wrote:
> 
> On 9/24/26 09:52, Muchun Song wrote:
>> This series is split out from the earlier, larger series "mm: Generalize
>> HVO for HugeTLB and device DAX" [1]. While the parent series generalizes
>> vmemmap optimization across HugeTLB and device DAX, this subset addresses
>> a single, self-contained step: unifying their vmemmap population paths.
>> 
>> After the preceding Device DAX conversion, both HugeTLB and Device DAX
>> describe optimized vmemmap mappings through memory-section metadata and
>> use per-zone shared tail vmemmap pages. The generic code, however, still
>> carries a Device DAX-specific population flag and compound-page population
>> path, along with arguments and helpers needed only by that path.
>> 
>> This series first removes VMEMMAP_POPULATE_DAX and moves selection and
>> reference handling for the shared tail page into the common vmemmap
>> population path. It then removes the generic Device DAX-specific
>> compound-page population path and routes section vmemmap population
>> through vmemmap_populate(). The powerpc radix path continues to use its
>> architecture-specific compound-page population implementation for
>> optimizable sections.
>> 
>> The remaining patches remove the unused ptpfn argument, open-code
>> vmemmap_populate_address() now that no caller needs its returned PTE, and
>> add a warning for inconsistent zone initialization of shared tail vmemmap
>> pages.
>> 
>> This is the fourth smaller step toward the broader HVO generalization.
>> After this series, HugeTLB and Device DAX use the same population model
>> instead of parallel generic paths, while powerpc keeps its
>> architecture-specific implementation.
>> 
>> [1] https://lore.kernel.org/all/20260513130542.35604-1-songmuchun@bytedance.com/
> 
> How does this series relate to
> 
> https://lore.kernel.org/r/20260927025441.741633-1-songmuchun@bytedance.com

This series is based on the v4 version [1] of the series you pointed out. When
I was sending the current series, the v4 version of that series had already
been in mm-new for some time, so I sent the v2 version of the current series.

However, a couple of days ago the kernel test bot reported an issue, and this
issue cannot be easily fixed with a simple fixup. So I updated that series to
a v5 version.

Therefore, the current series needs to be rebased on top of the v5 version of
the series you pointed out, and then sent as a new v3 version before it can be
properly applied or reviewed.

If you're planning to review this series, I'd suggest waiting for my rebased
version.

[1] https://lore.kernel.org/all/20260916064341.1825793-1-songmuchun@bytedance.com/

Thanks,
Muchun

> 
> ?
> 
> -- 
> Cheers,
> 
> David


  reply	other threads:[~2026-09-28 13:50 UTC|newest]

Thread overview: 16+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2026-09-24  7:52 Muchun Song
2026-09-24  7:52 ` [PATCH v2 1/6] mm/sparse-vmemmap: drop VMEMMAP_POPULATE_DAX Muchun Song
2026-09-24  7:52 ` [PATCH v2 2/6] mm/sparse-vmemmap: support device DAX in common vmemmap path Muchun Song
2026-09-28  1:49   ` Qi Zheng
2026-09-24  7:52 ` [PATCH v2 3/6] mm/sparse-vmemmap: drop Device DAX-specific population path Muchun Song
2026-09-24  7:52 ` [PATCH v2 4/6] mm/sparse-vmemmap: remove the unused ptpfn argument Muchun Song
2026-09-24  7:52 ` [PATCH v2 5/6] mm/sparse-vmemmap: open-code vmemmap_populate_address() Muchun Song
2026-09-24  7:52 ` [PATCH v2 6/6] mm/mm_init: add zone mismatch warning during page init Muchun Song
2026-09-28  1:59   ` Qi Zheng
2026-09-28 12:44 ` [PATCH v2 0/6] mm: Unify device DAX and HugeTLB vmemmap population paths David Hildenbrand (Arm)
2026-09-28 13:49   ` Muchun Song [this message]
2026-09-28 17:43     ` Ritesh Harjani
2026-09-28 19:03       ` David Hildenbrand (Arm)
2026-09-29  0:51         ` Muchun Song
2026-09-29  0:57       ` Muchun Song
2026-09-29  1:57         ` Ritesh Harjani

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=8385F749-0F72-494E-9CA2-2E433A066712@linux.dev \
    --to=muchun.song@linux.dev \
    --cc=akpm@linux-foundation.org \
    --cc=chleroy@kernel.org \
    --cc=david@kernel.org \
    --cc=liam@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=ljs@kernel.org \
    --cc=maddy@linux.ibm.com \
    --cc=mhocko@suse.com \
    --cc=mpe@ellerman.id.au \
    --cc=npiggin@gmail.com \
    --cc=qi.zheng@linux.dev \
    --cc=rppt@kernel.org \
    --cc=songmuchun@bytedance.com \
    --cc=surenb@google.com \
    --cc=vbabka@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®