From: "Yinghai Lu" <yhlu.kernel@gmail.com>
To: "Ingo Molnar" <mingo@elte.hu>, "Paul Jackson" <pj@sgi.com>,
"Mike Travis" <travis@sgi.com>
Cc: "Thomas Gleixner" <tglx@linutronix.de>,
"H. Peter Anvin" <hpa@zytor.com>,
"Suresh Siddha" <suresh.b.siddha@intel.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] x86: add apic probe for genapic 64bit v2
Date: Tue, 22 Jul 2008 01:09:43 -0700 [thread overview]
Message-ID: <86802c440807220109s63307f28uc0658402cb26cfea@mail.gmail.com> (raw)
In-Reply-To: <20080722071324.GA2664@elte.hu>
[-- Attachment #1: Type: text/plain, Size: 1347 bytes --]
On Tue, Jul 22, 2008 at 12:13 AM, Ingo Molnar <mingo@elte.hu> wrote:
>
> * Ingo Molnar <mingo@elte.hu> wrote:
>
>> > v2: fix compiling when CONFIG_ACPI is not set
>>
>> applied to tip/x86/x2apic - thanks Yinghai.
>>
>> > +static struct genapic *apic_probe[] __initdata = {
>> > + &apic_x2apic_uv_x,
>> > + &apic_x2apic_phys,
>> > + &apic_x2apic_cluster,
>> > + &apic_physflat,
>> > + NULL,
>> > +};
>>
>> very nice generalization!
>
> btw.:
>
> apic_probe[i]->acpi_madt_oem_check
>
> should probably be renamed to something more neutral like "->probe" -
> there's nothing ACPI about it and some weird boxes could use PCI or
> other probing mechanisms to discover the type of APIC they want to use.
32bit has acpi_madt_oem_check and mps_oem_check
64bit should only have acpi_madt_oem_check
>
> plus i guess genapic_32.h and genapic_64.h should be unified and struct
> apic_ops should be put into struct genapic?
yes.
hope to call acpi_madt_oem_check and mps_oem_check right after
acpi_boot_table_init
to decide apic_ops and genapic as early as possible.
Jack/Mike,
does your big box support SRAT? it seems it calling is_uv_system
before acpi_madt_oem_check is called.
I like to call early_acpi_boot_init, before acpi_numa_init so
acpi_madt_oem_check is called before srat is used. can you check
attached patch on your system?
YH
[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #2: early_madt_oem_check.patch --]
[-- Type: text/x-patch; name=early_madt_oem_check.patch, Size: 755 bytes --]
[PATCH] x86: call early_acpi_boot_init before acpi_numa_init
so could call acpi_madt_oem_check early to find out if it uv system.
and acpi_numa_init could call is_uv_system()
Signed-off-by: Yinghai Lu <yhlu.kernel@gmail.com>
---
arch/x86/kernel/setup.c | 4 ++++
1 file changed, 4 insertions(+)
Index: linux-2.6/arch/x86/kernel/setup.c
===================================================================
--- linux-2.6.orig/arch/x86/kernel/setup.c
+++ linux-2.6/arch/x86/kernel/setup.c
@@ -785,6 +785,10 @@ void __init setup_arch(char **cmdline_p)
acpi_boot_table_init();
#ifdef CONFIG_ACPI_NUMA
+#ifdef CONFIG_X86_64
+ /* try to call acpi_madt_oem_check here */
+ early_acpi_boot_init();
+#endif
/*
* Parse SRAT to discover nodes.
*/
next prev parent reply other threads:[~2008-07-22 8:10 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-07-22 1:36 [PATCH] x86: add apic probe for genapic 64bit Yinghai Lu
2008-07-22 5:08 ` [PATCH] x86: add apic probe for genapic 64bit v2 Yinghai Lu
2008-07-22 7:07 ` Ingo Molnar
2008-07-22 7:13 ` Ingo Molnar
2008-07-22 8:09 ` Yinghai Lu [this message]
2008-07-22 8:24 ` Ingo Molnar
2008-07-22 8:26 ` Yinghai Lu
2008-07-22 16:31 ` Mike Travis
2008-07-22 17:57 ` Suresh Siddha
2008-07-22 18:05 ` Yinghai Lu
2008-07-22 18:10 ` Suresh Siddha
2008-07-22 18:40 ` Yinghai Lu
2008-07-22 19:17 ` Suresh Siddha
2008-07-22 20:20 ` [PATCH] x86: move declaring x2apic_extra_bits Yinghai Lu
2008-07-24 11:00 ` Ingo Molnar
2008-07-26 2:39 ` [PATCH] x86: add apic probe for genapic 64bit - fix Yinghai Lu
2008-07-26 14:32 ` Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=86802c440807220109s63307f28uc0658402cb26cfea@mail.gmail.com \
--to=yhlu.kernel@gmail.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=pj@sgi.com \
--cc=suresh.b.siddha@intel.com \
--cc=tglx@linutronix.de \
--cc=travis@sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®