From: "Yinghai Lu" <yhlu.kernel@gmail.com>
To: "Ingo Molnar" <mingo@elte.hu>
Cc: "Paul Jackson" <pj@sgi.com>, "Mike Travis" <travis@sgi.com>,
"Thomas Gleixner" <tglx@linutronix.de>,
"H. Peter Anvin" <hpa@zytor.com>,
"Suresh Siddha" <suresh.b.siddha@intel.com>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH] x86: add apic probe for genapic 64bit v2
Date: Tue, 22 Jul 2008 01:26:36 -0700 [thread overview]
Message-ID: <86802c440807220126l6caed5t3ad1bbe7da730669@mail.gmail.com> (raw)
In-Reply-To: <20080722082410.GB2065@elte.hu>
On Tue, Jul 22, 2008 at 1:24 AM, Ingo Molnar <mingo@elte.hu> wrote:
>
> * Yinghai Lu <yhlu.kernel@gmail.com> wrote:
>
>> On Tue, Jul 22, 2008 at 12:13 AM, Ingo Molnar <mingo@elte.hu> wrote:
>> >
>> > * Ingo Molnar <mingo@elte.hu> wrote:
>> >
>> >> > v2: fix compiling when CONFIG_ACPI is not set
>> >>
>> >> applied to tip/x86/x2apic - thanks Yinghai.
>> >>
>> >> > +static struct genapic *apic_probe[] __initdata = {
>> >> > + &apic_x2apic_uv_x,
>> >> > + &apic_x2apic_phys,
>> >> > + &apic_x2apic_cluster,
>> >> > + &apic_physflat,
>> >> > + NULL,
>> >> > +};
>> >>
>> >> very nice generalization!
>> >
>> > btw.:
>> >
>> > apic_probe[i]->acpi_madt_oem_check
>> >
>> > should probably be renamed to something more neutral like "->probe" -
>> > there's nothing ACPI about it and some weird boxes could use PCI or
>> > other probing mechanisms to discover the type of APIC they want to use.
>>
>> 32bit has acpi_madt_oem_check and mps_oem_check
>> 64bit should only have acpi_madt_oem_check
>
> yeah.
>
> It's just a small detail: what i mean is that the method itself should
> eventually simply be renamed from "acpi_madt_oem_check" to "probe".
> There's nothing ACPI about this exept the fact that most current "is
> this the APIC driver we should be using" checks involve some sort of
> ACPI discovery. This is a Linux abstraction and as such a more generic
> name like "probe" sounds more appropriate.
OK
YH
next prev parent reply other threads:[~2008-07-22 8:26 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2008-07-22 1:36 [PATCH] x86: add apic probe for genapic 64bit Yinghai Lu
2008-07-22 5:08 ` [PATCH] x86: add apic probe for genapic 64bit v2 Yinghai Lu
2008-07-22 7:07 ` Ingo Molnar
2008-07-22 7:13 ` Ingo Molnar
2008-07-22 8:09 ` Yinghai Lu
2008-07-22 8:24 ` Ingo Molnar
2008-07-22 8:26 ` Yinghai Lu [this message]
2008-07-22 16:31 ` Mike Travis
2008-07-22 17:57 ` Suresh Siddha
2008-07-22 18:05 ` Yinghai Lu
2008-07-22 18:10 ` Suresh Siddha
2008-07-22 18:40 ` Yinghai Lu
2008-07-22 19:17 ` Suresh Siddha
2008-07-22 20:20 ` [PATCH] x86: move declaring x2apic_extra_bits Yinghai Lu
2008-07-24 11:00 ` Ingo Molnar
2008-07-26 2:39 ` [PATCH] x86: add apic probe for genapic 64bit - fix Yinghai Lu
2008-07-26 14:32 ` Ingo Molnar
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=86802c440807220126l6caed5t3ad1bbe7da730669@mail.gmail.com \
--to=yhlu.kernel@gmail.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=pj@sgi.com \
--cc=suresh.b.siddha@intel.com \
--cc=tglx@linutronix.de \
--cc=travis@sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®