From: "Yinghai Lu" <yhlu.kernel@gmail.com>
To: "Eric W. Biederman" <ebiederm@xmission.com>
Cc: "Ingo Molnar" <mingo@elte.hu>,
"Thomas Gleixner" <tglx@linutronix.de>,
"H. Peter Anvin" <hpa@zytor.com>,
"Dhaval Giani" <dhaval@linux.vnet.ibm.com>,
"Mike Travis" <travis@sgi.com>,
"Andrew Morton" <akpm@linux-foundation.org>,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 00/33] dyn_array and nr_irqs support v4
Date: Wed, 6 Aug 2008 13:57:45 -0700 [thread overview]
Message-ID: <86802c440808061357j425da86bj94165c47c669eb61@mail.gmail.com> (raw)
In-Reply-To: <m1y739j2z8.fsf@frodo.ebiederm.org>
On Wed, Aug 6, 2008 at 1:35 PM, Eric W. Biederman <ebiederm@xmission.com> wrote:
> "Yinghai Lu" <yhlu.kernel@gmail.com> writes:
>
>>> My suggestion for a non-breaking path:
>>> - Kill NR_IRQS in then generic code.
>>> With Alan's serial patch and my kstat patch it looks like we have
>>> the worst of that.
>>
>> will use Alan's patch.at first.
>> already reused your patch about kstat. and move kstat_irqs to irq_desc.
>
> Part of what I am thinking is that there should never be a patch
> that does s/NR_IRQS/nr_irqs/ that is just pointless noise.
for some platform like 32bit, may not like to mess up with
CONFIG_HAVE_SPARSE_IRQ, to have dyn_array to take small nr_irqs with
probing.
>
> Either we need a new abstraction like for_each_irq or to update the
> code to the current best practices.
already add for_each_irq_desc(irq, desc)...
| #ifndef CONFIG_HAVE_DYN_ARRAY
| /* could be removed if we get rid of all irq_desc reference */
| extern struct irq_desc irq_desc[NR_IRQS];
| #else
| extern struct irq_desc *irq_desc;
| #endif
|
| #define for_each_irq_desc(irq, desc) \
| for (irq = 0, desc = irq_desc; irq < nr_irqs; irq++, desc =
&irq_desc[irq])
|
|#else
|
|extern struct irq_desc *irq_descX;
|#define for_each_irq_desc(irqX, desc) \
| for (desc = irq_descX, irqX = desc->irq; desc && irqX != -1U;
desc = desc->next, irqX = desc ? desc->irq: -1U)
|
|#endif
>
> Which means the patches should be uncontroversial and mergeble on their
> own with no weird dependencies.
sure.
YH
next prev parent reply other threads:[~2008-08-06 20:58 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
[not found] <No>
2008-08-06 8:38 ` Yinghai Lu
2008-08-06 8:38 ` [PATCH 01/33] x86: add after_bootmem for 32bit Yinghai Lu
2008-08-06 8:38 ` [PATCH 02/33] x86: remove irq_vectors_limits Yinghai Lu
2008-08-06 17:37 ` [PATCH 00/33] dyn_array and nr_irqs support v4 Eric W. Biederman
2008-08-06 18:29 ` Yinghai Lu
2008-08-06 18:50 ` Yinghai Lu
2008-08-06 20:32 ` Eric W. Biederman
2008-08-06 20:52 ` Yinghai Lu
2008-08-06 20:35 ` Eric W. Biederman
2008-08-06 20:57 ` Yinghai Lu [this message]
2008-08-06 23:26 ` Alan Cox
2008-08-07 1:02 ` Eric W. Biederman
2008-08-07 10:12 ` Alan Cox
2008-08-07 10:51 ` Yinghai Lu
2008-08-07 10:57 ` Alan Cox
2008-08-07 18:12 ` H. Peter Anvin
2008-08-06 8:42 Yinghai Lu
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=86802c440808061357j425da86bj94165c47c669eb61@mail.gmail.com \
--to=yhlu.kernel@gmail.com \
--cc=akpm@linux-foundation.org \
--cc=dhaval@linux.vnet.ibm.com \
--cc=ebiederm@xmission.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@elte.hu \
--cc=tglx@linutronix.de \
--cc=travis@sgi.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome