* [PATCH] fs/file.c: __const_max is actually __const_min :-)
@ 2015-10-29 11:01 Rasmus Villemoes
2015-10-29 11:18 ` Albino B Neto
0 siblings, 1 reply; 3+ messages in thread
From: Rasmus Villemoes @ 2015-10-29 11:01 UTC (permalink / raw)
To: Alexander Viro; +Cc: Rasmus Villemoes, linux-fsdevel, linux-kernel
7f4b36f9bb930 "get rid of files_defer_init()" inexplicably changed a
min() to a __const_max() - but the __const_max macro actually gives
the minimum... So no functional change, just less confusing naming.
Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
---
fs/file.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/fs/file.c b/fs/file.c
index 6c672ad329e9..b2d74f6001eb 100644
--- a/fs/file.c
+++ b/fs/file.c
@@ -25,9 +25,9 @@
int sysctl_nr_open __read_mostly = 1024*1024;
int sysctl_nr_open_min = BITS_PER_LONG;
-/* our max() is unusable in constant expressions ;-/ */
-#define __const_max(x, y) ((x) < (y) ? (x) : (y))
-int sysctl_nr_open_max = __const_max(INT_MAX, ~(size_t)0/sizeof(void *)) &
+/* our min() is unusable in constant expressions ;-/ */
+#define __const_min(x, y) ((x) < (y) ? (x) : (y))
+int sysctl_nr_open_max = __const_min(INT_MAX, ~(size_t)0/sizeof(void *)) &
-BITS_PER_LONG;
static void *alloc_fdmem(size_t size)
--
2.6.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] fs/file.c: __const_max is actually __const_min :-)
2015-10-29 11:01 [PATCH] fs/file.c: __const_max is actually __const_min :-) Rasmus Villemoes
@ 2015-10-29 11:18 ` Albino B Neto
2015-11-23 21:37 ` Rasmus Villemoes
0 siblings, 1 reply; 3+ messages in thread
From: Albino B Neto @ 2015-10-29 11:18 UTC (permalink / raw)
To: Rasmus Villemoes; +Cc: Alexander Viro, linux-fsdevel, LKML
2015-10-29 9:01 GMT-02:00 Rasmus Villemoes <linux@rasmusvillemoes.dk>:
> 7f4b36f9bb930 "get rid of files_defer_init()" inexplicably changed a
> min() to a __const_max() - but the __const_max macro actually gives
> the minimum... So no functional change, just less confusing naming.
>
> Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
> ---
> fs/file.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/fs/file.c b/fs/file.c
> index 6c672ad329e9..b2d74f6001eb 100644
> --- a/fs/file.c
> +++ b/fs/file.c
> @@ -25,9 +25,9 @@
>
> int sysctl_nr_open __read_mostly = 1024*1024;
> int sysctl_nr_open_min = BITS_PER_LONG;
> -/* our max() is unusable in constant expressions ;-/ */
> -#define __const_max(x, y) ((x) < (y) ? (x) : (y))
> -int sysctl_nr_open_max = __const_max(INT_MAX, ~(size_t)0/sizeof(void *)) &
> +/* our min() is unusable in constant expressions ;-/ */
> +#define __const_min(x, y) ((x) < (y) ? (x) : (y))
> +int sysctl_nr_open_max = __const_min(INT_MAX, ~(size_t)0/sizeof(void *)) &
> -BITS_PER_LONG;
>
> static void *alloc_fdmem(size_t size)
Confused code or no ?
Albino
^ permalink raw reply [flat|nested] 3+ messages in thread* Re: [PATCH] fs/file.c: __const_max is actually __const_min :-)
2015-10-29 11:18 ` Albino B Neto
@ 2015-11-23 21:37 ` Rasmus Villemoes
0 siblings, 0 replies; 3+ messages in thread
From: Rasmus Villemoes @ 2015-11-23 21:37 UTC (permalink / raw)
To: Albino B Neto; +Cc: Alexander Viro, linux-fsdevel, LKML
On Thu, Oct 29 2015, Albino B Neto <bino@bino.us> wrote:
> 2015-10-29 9:01 GMT-02:00 Rasmus Villemoes <linux@rasmusvillemoes.dk>:
>> 7f4b36f9bb930 "get rid of files_defer_init()" inexplicably changed a
>> min() to a __const_max() - but the __const_max macro actually gives
>> the minimum... So no functional change, just less confusing naming.
>>
>> Signed-off-by: Rasmus Villemoes <linux@rasmusvillemoes.dk>
>> ---
>> fs/file.c | 6 +++---
>> 1 file changed, 3 insertions(+), 3 deletions(-)
>>
>> diff --git a/fs/file.c b/fs/file.c
>> index 6c672ad329e9..b2d74f6001eb 100644
>> --- a/fs/file.c
>> +++ b/fs/file.c
>> @@ -25,9 +25,9 @@
>>
>> int sysctl_nr_open __read_mostly = 1024*1024;
>> int sysctl_nr_open_min = BITS_PER_LONG;
>> -/* our max() is unusable in constant expressions ;-/ */
>> -#define __const_max(x, y) ((x) < (y) ? (x) : (y))
>> -int sysctl_nr_open_max = __const_max(INT_MAX, ~(size_t)0/sizeof(void *)) &
>> +/* our min() is unusable in constant expressions ;-/ */
>> +#define __const_min(x, y) ((x) < (y) ? (x) : (y))
>> +int sysctl_nr_open_max = __const_min(INT_MAX, ~(size_t)0/sizeof(void *)) &
>> -BITS_PER_LONG;
>>
>> static void *alloc_fdmem(size_t size)
>
> Confused code or no ?
The code is fine, the macro name sucks. Al, ping?
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2015-11-23 21:37 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-10-29 11:01 [PATCH] fs/file.c: __const_max is actually __const_min :-) Rasmus Villemoes
2015-10-29 11:18 ` Albino B Neto
2015-11-23 21:37 ` Rasmus Villemoes
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®