mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RFC] Rename SECTOR_SIZE to MSDOS_SECTOR_SIZE
@ 2004-10-27  6:08 Chris Wedgwood
  2004-10-27 13:03 ` OGAWA Hirofumi
  0 siblings, 1 reply; 2+ messages in thread
From: Chris Wedgwood @ 2004-10-27  6:08 UTC (permalink / raw)
  To: LKML; +Cc: Chris Wedgwood, hirofumi

The token SECTOR_SIZE is used in multiple places that have (almost)
the same defintion everywhere.

How do people feel about rename this vague token?



===== include/linux/msdos_fs.h 1.42 vs edited =====
--- 1.42/include/linux/msdos_fs.h	2004-10-20 01:12:10 -07:00
+++ edited/include/linux/msdos_fs.h	2004-10-26 17:10:24 -07:00
@@ -6,11 +6,11 @@
  */
 #include <asm/byteorder.h>
 
-#define SECTOR_SIZE	512		/* sector size (bytes) */
-#define SECTOR_BITS	9		/* log2(SECTOR_SIZE) */
+#define MSDOS_SECTOR_SIZE	512	/* sector size (bytes) */
+#define MSDOS_SECTOR_BITS	9	/* log2(SECTOR_SIZE) */
 #define MSDOS_DPB	(MSDOS_DPS)	/* dir entries per block */
 #define MSDOS_DPB_BITS	4		/* log2(MSDOS_DPB) */
-#define MSDOS_DPS	(SECTOR_SIZE / sizeof(struct msdos_dir_entry))
+#define MSDOS_DPS	(MSDOS_SECTOR_SIZE / sizeof(struct msdos_dir_entry))
 #define MSDOS_DPS_BITS	4		/* log2(MSDOS_DPS) */
 
 

^ permalink raw reply	[flat|nested] 2+ messages in thread

* Re: [RFC] Rename SECTOR_SIZE to MSDOS_SECTOR_SIZE
  2004-10-27  6:08 [RFC] Rename SECTOR_SIZE to MSDOS_SECTOR_SIZE Chris Wedgwood
@ 2004-10-27 13:03 ` OGAWA Hirofumi
  0 siblings, 0 replies; 2+ messages in thread
From: OGAWA Hirofumi @ 2004-10-27 13:03 UTC (permalink / raw)
  To: Chris Wedgwood; +Cc: LKML, Chris Wedgwood

cw@f00f.org (Chris Wedgwood) writes:

> -#define SECTOR_SIZE	512		/* sector size (bytes) */
> -#define SECTOR_BITS	9		/* log2(SECTOR_SIZE) */
> +#define MSDOS_SECTOR_SIZE	512	/* sector size (bytes) */
> +#define MSDOS_SECTOR_BITS	9	/* log2(SECTOR_SIZE) */
>  #define MSDOS_DPB	(MSDOS_DPS)	/* dir entries per block */
>  #define MSDOS_DPB_BITS	4		/* log2(MSDOS_DPB) */
> -#define MSDOS_DPS	(SECTOR_SIZE / sizeof(struct msdos_dir_entry))
> +#define MSDOS_DPS	(MSDOS_SECTOR_SIZE / sizeof(struct msdos_dir_entry))
>  #define MSDOS_DPS_BITS	4		/* log2(MSDOS_DPS) */

The fatfs doesn't use these (is separated by two blank lines).
These are for just backward compatibility.

To rename is not useful at all, please delete instead if it's needed.
-- 
OGAWA Hirofumi <hirofumi@mail.parknet.co.jp>

^ permalink raw reply	[flat|nested] 2+ messages in thread

end of thread, other threads:[~2004-10-27 13:06 UTC | newest]

Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2004-10-27  6:08 [RFC] Rename SECTOR_SIZE to MSDOS_SECTOR_SIZE Chris Wedgwood
2004-10-27 13:03 ` OGAWA Hirofumi

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®