From: Takashi Iwai <tiwai@suse.de>
To: Baojun Xu <baojun.xu@ti.com>
Cc: <broonie@kernel.org>, <andriy.shevchenko@linux.intel.com>,
<alsa-devel@alsa-project.org>, <shenghao-ding@ti.com>,
<13916275206@139.com>, <linux-sound@vger.kernel.org>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v1] ALSA: hda/tas2781: Normalize the volume kcontrol name
Date: Wed, 13 Aug 2025 17:44:30 +0200 [thread overview]
Message-ID: <87ectfw7j5.wl-tiwai@suse.de> (raw)
In-Reply-To: <20250813100842.12224-1-baojun.xu@ti.com>
On Wed, 13 Aug 2025 12:08:42 +0200,
Baojun Xu wrote:
>
> Change the name of the kcontrol from "Gain" to "Volume".
Could you describe "why this change is needed"?
thanks,
Takashi
>
> Signed-off-by: Baojun Xu <baojun.xu@ti.com>
> ---
> sound/hda/codecs/side-codecs/tas2781_hda_i2c.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c b/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c
> index 92aae19cfc8f..e4bc3bc756b0 100644
> --- a/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c
> +++ b/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c
> @@ -256,7 +256,7 @@ static const struct snd_kcontrol_new tas2770_snd_controls[] = {
> };
>
> static const struct snd_kcontrol_new tas2781_snd_controls[] = {
> - ACARD_SINGLE_RANGE_EXT_TLV("Speaker Analog Gain", TAS2781_AMP_LEVEL,
> + ACARD_SINGLE_RANGE_EXT_TLV("Speaker Analog Volume", TAS2781_AMP_LEVEL,
> 1, 0, 20, 0, tas2781_amp_getvol,
> tas2781_amp_putvol, amp_vol_tlv),
> ACARD_SINGLE_BOOL_EXT("Speaker Force Firmware Load", 0,
> --
> 2.43.0
>
next prev parent reply other threads:[~2025-08-13 15:44 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-08-13 10:08 Baojun Xu
2025-08-13 15:44 ` Takashi Iwai [this message]
2025-08-14 2:29 ` [EXTERNAL] " Xu, Baojun
2025-08-14 6:32 ` Takashi Iwai
2025-08-14 12:42 ` Takashi Iwai
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87ectfw7j5.wl-tiwai@suse.de \
--to=tiwai@suse.de \
--cc=13916275206@139.com \
--cc=alsa-devel@alsa-project.org \
--cc=andriy.shevchenko@linux.intel.com \
--cc=baojun.xu@ti.com \
--cc=broonie@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-sound@vger.kernel.org \
--cc=shenghao-ding@ti.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®