mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v1] ALSA: hda/tas2781: Normalize the volume kcontrol name
@ 2025-08-13 10:08 Baojun Xu
  2025-08-13 15:44 ` Takashi Iwai
  0 siblings, 1 reply; 5+ messages in thread
From: Baojun Xu @ 2025-08-13 10:08 UTC (permalink / raw)
  To: tiwai
  Cc: broonie, andriy.shevchenko, alsa-devel, shenghao-ding,
	13916275206, linux-sound, linux-kernel, baojun.xu

Change the name of the kcontrol from "Gain" to "Volume".

Signed-off-by: Baojun Xu <baojun.xu@ti.com>
---
 sound/hda/codecs/side-codecs/tas2781_hda_i2c.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c b/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c
index 92aae19cfc8f..e4bc3bc756b0 100644
--- a/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c
+++ b/sound/hda/codecs/side-codecs/tas2781_hda_i2c.c
@@ -256,7 +256,7 @@ static const struct snd_kcontrol_new tas2770_snd_controls[] = {
 };
 
 static const struct snd_kcontrol_new tas2781_snd_controls[] = {
-	ACARD_SINGLE_RANGE_EXT_TLV("Speaker Analog Gain", TAS2781_AMP_LEVEL,
+	ACARD_SINGLE_RANGE_EXT_TLV("Speaker Analog Volume", TAS2781_AMP_LEVEL,
 		1, 0, 20, 0, tas2781_amp_getvol,
 		tas2781_amp_putvol, amp_vol_tlv),
 	ACARD_SINGLE_BOOL_EXT("Speaker Force Firmware Load", 0,
-- 
2.43.0


^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2025-08-14 12:42 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-08-13 10:08 [PATCH v1] ALSA: hda/tas2781: Normalize the volume kcontrol name Baojun Xu
2025-08-13 15:44 ` Takashi Iwai
2025-08-14  2:29   ` [EXTERNAL] " Xu, Baojun
2025-08-14  6:32     ` Takashi Iwai
2025-08-14 12:42       ` Takashi Iwai

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®