mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Michael Ellerman <mpe@ellerman.id.au>
To: "Rafael J. Wysocki" <rafael@kernel.org>
Cc: "Gautham R. Shenoy" <ego@linux.vnet.ibm.com>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Paul Mackerras <paulus@samba.org>,
	"Rafael J. Wysocki" <rjw@rjwysocki.net>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	Michael Neuling <mikey@neuling.org>,
	Vaidyanathan Srinivasan <svaidy@linux.vnet.ibm.com>,
	"Shreyas B. Prabhu" <shreyasbp@gmail.com>,
	Shilpasri G Bhat <shilpa.bhat@linux.vnet.ibm.com>,
	Stewart Smith <stewart@linux.vnet.ibm.com>,
	Balbir Singh <bsingharora@gmail.com>,
	"Oliver O'Halloran" <oohall@gmail.com>,
	Rob Herring <robh+dt@kernel.org>,
	linuxppc-dev <linuxppc-dev@lists.ozlabs.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Linux PM <linux-pm@vger.kernel.org>,
	"devicetree\@vger.kernel.org" <devicetree@vger.kernel.org>,
	Mark Rutland <mark.rutland@arm.com>
Subject: Re: [PATCH v6 3/5] cpuidle:powernv: Add helper function to populate powernv idle states.
Date: Mon, 30 Jan 2017 22:17:50 +1100	[thread overview]
Message-ID: <87efzkx0dd.fsf@concordia.ellerman.id.au> (raw)
In-Reply-To: <CAJZ5v0j_vzsaNeYNBmKs3oMnXyVHF_3chRjeTEwQA_k0TDc3Nw@mail.gmail.com>

"Rafael J. Wysocki" <rafael@kernel.org> writes:

> On Mon, Jan 30, 2017 at 4:47 AM, Michael Ellerman <mpe@ellerman.id.au> wrote:
>> "Gautham R. Shenoy" <ego@linux.vnet.ibm.com> writes:
>>
>>> From: "Gautham R. Shenoy" <ego@linux.vnet.ibm.com>
>>>
>>> In the current code for powernv_add_idle_states, there is a lot of code
>>> duplication while initializing an idle state in powernv_states table.
>>>
>>> Add an inline helper function to populate the powernv_states[] table
>>> for a given idle state. Invoke this for populating the "Nap",
>>> "Fastsleep" and the stop states in powernv_add_idle_states.
>>>
>>> Acked-by: Balbir Singh <bsingharora@gmail.com>
>>> Signed-off-by: Gautham R. Shenoy <ego@linux.vnet.ibm.com>
>>> ---
>>>  drivers/cpuidle/cpuidle-powernv.c | 89 +++++++++++++++++++++++----------------
>>>  include/linux/cpuidle.h           |  1 +
>>
>> I was going to merge this, but I see you've touched cpuidle.h, so I feel
>> like I should get an ACK from the cpuidle folks.
>>
>> It's a fairly uncontroversial change, but it's their API.
>
> OK, please add an ACK from me to it then.

Thanks.

cheers

  reply	other threads:[~2017-01-30 11:18 UTC|newest]

Thread overview: 12+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-25  8:36 [PATCH v6 0/5] powernv:stop: Use psscr_val,mask provided by firmware Gautham R. Shenoy
2017-01-25  8:36 ` [PATCH v6 1/5] powernv:idle: Add IDLE_STATE_ENTER_SEQ_NORET macro Gautham R. Shenoy
2017-02-01  1:05   ` [v6,1/5] " Michael Ellerman
2017-01-25  8:36 ` [PATCH v6 2/5] powernv:stop: Rename pnv_arch300_idle_init to pnv_power9_idle_init Gautham R. Shenoy
2017-01-25  8:36 ` [PATCH v6 3/5] cpuidle:powernv: Add helper function to populate powernv idle states Gautham R. Shenoy
2017-01-30  3:47   ` Michael Ellerman
2017-01-30  7:12     ` Rafael J. Wysocki
2017-01-30 11:17       ` Michael Ellerman [this message]
2017-01-30 11:41         ` Gautham R Shenoy
2017-01-25  8:36 ` [PATCH v6 4/5] powernv: Pass PSSCR value and mask to power9_idle_stop Gautham R. Shenoy
2017-01-25  8:36 ` [PATCH v6 5/5] Documentation:powerpc: Add device-tree bindings for power-mgt Gautham R. Shenoy
2017-01-30 17:49   ` Rob Herring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87efzkx0dd.fsf@concordia.ellerman.id.au \
    --to=mpe@ellerman.id.au \
    --cc=benh@kernel.crashing.org \
    --cc=bsingharora@gmail.com \
    --cc=daniel.lezcano@linaro.org \
    --cc=devicetree@vger.kernel.org \
    --cc=ego@linux.vnet.ibm.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mark.rutland@arm.com \
    --cc=mikey@neuling.org \
    --cc=oohall@gmail.com \
    --cc=paulus@samba.org \
    --cc=rafael@kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=robh+dt@kernel.org \
    --cc=shilpa.bhat@linux.vnet.ibm.com \
    --cc=shreyasbp@gmail.com \
    --cc=stewart@linux.vnet.ibm.com \
    --cc=svaidy@linux.vnet.ibm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®