From: Javier Martinez Canillas <javierm@redhat.com>
To: Jocelyn Falempe <jfalempe@redhat.com>,
Maarten Lankhorst <maarten.lankhorst@linux.intel.com>,
Maxime Ripard <mripard@kernel.org>,
Thomas Zimmermann <tzimmermann@suse.de>,
David Airlie <airlied@gmail.com>, Simona Vetter <simona@ffwll.ch>,
Jocelyn Falempe <jfalempe@redhat.com>,
linux-kernel@vger.kernel.org, dri-devel@lists.freedesktop.org
Subject: Re: [PATCH v4 1/2] drm/panic: Rename draw_panic_static_* to draw_panic_screen_*
Date: Tue, 16 Dec 2025 09:35:28 +0100 [thread overview]
Message-ID: <87fr9alt7z.fsf@ocarina.mail-host-address-is-not-set> (raw)
In-Reply-To: <20251216082524.115980-2-jfalempe@redhat.com>
Jocelyn Falempe <jfalempe@redhat.com> writes:
Hello Jocelyn,
> I called them "static" because the panic screen is drawn only once,
> but this can be confused with the static meaning in C.
> Also remove some unnecessary braces in draw_panic_dispatch().
> No functionnal change.
>
> Signed-off-by: Jocelyn Falempe <jfalempe@redhat.com>
> ---
Makes sense.
Reviewed-by: Javier Martinez Canillas <javierm@redhat.com>
--
Best regards,
Javier Martinez Canillas
Core Platforms
Red Hat
next prev parent reply other threads:[~2025-12-16 8:35 UTC|newest]
Thread overview: 5+ messages / expand[flat|nested] mbox.gz Atom feed top
2025-12-16 8:20 [PATCH v4 0/2] drm/panic: Add kunit tests for drm_panic Jocelyn Falempe
2025-12-16 8:20 ` [PATCH v4 1/2] drm/panic: Rename draw_panic_static_* to draw_panic_screen_* Jocelyn Falempe
2025-12-16 8:35 ` Javier Martinez Canillas [this message]
2025-12-16 8:20 ` [PATCH v4 2/2] drm/panic: Add kunit tests for drm_panic Jocelyn Falempe
2025-12-19 9:29 ` Maxime Ripard
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=87fr9alt7z.fsf@ocarina.mail-host-address-is-not-set \
--to=javierm@redhat.com \
--cc=airlied@gmail.com \
--cc=dri-devel@lists.freedesktop.org \
--cc=jfalempe@redhat.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maarten.lankhorst@linux.intel.com \
--cc=mripard@kernel.org \
--cc=simona@ffwll.ch \
--cc=tzimmermann@suse.de \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®