mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Andreas Hindborg <a.hindborg@kernel.org>
To: "Ingo Molnar" <mingo@kernel.org>
Cc: <linux-kernel@vger.kernel.org>,
	 "Thomas Gleixner" <tglx@linutronix.de>,
	"Frederic Weisbecker" <frederic@kernel.org>,
	 "H . Peter Anvin" <hpa@zytor.com>,
	 "Linus Torvalds" <torvalds@linux-foundation.org>,
	"Peter Zijlstra" <peterz@infradead.org>,
	 "Miguel Ojeda" <ojeda@kernel.org>,
	 "Alex Gaynor" <alex.gaynor@gmail.com>,
	 "Anna-Maria Behnsen" <anna-maria@linutronix.de>,
	 "Boqun Feng" <boqun.feng@gmail.com>,
	"Lyude Paul" <lyude@redhat.com>,
	 "Rust ML" <rust-for-linux@vger.kernel.org>
Subject: Re: [PATCH 01/10] rust: Rename timer_container_of() to hrtimer_container_of()
Date: Mon, 12 May 2025 11:29:01 +0200	[thread overview]
Message-ID: <87jz6mnpnm.fsf@kernel.org> (raw)
In-Reply-To: <aBu2ocPIFOvq_EiA@gmail.com> (Ingo Molnar's message of "Wed, 07 May 2025 21:38:09 +0200")

"Ingo Molnar" <mingo@kernel.org> writes:

> * Andreas Hindborg <a.hindborg@kernel.org> wrote:
>
>> "Ingo Molnar" <mingo@kernel.org> writes:
>>
>> > This primitive is dealing with 'struct hrtimer' objects, not
>> > 'struct timer_list' objects - so clarify the name.
>> >
>> > We want to introduce the timer_container_of() symbol in the kernel
>> > for timer_list, make sure there's no clash of namespaces, at least
>> > on the conceptual plane.
>>
>> Is this a resend?
>
> I noted the changes in the boilerplate:
>
>   Changes in -v3:
>
>     - Picked up review tags
>     - Rebased to v6.15-rc5
>
> This particular patch didn't change.

Thanks. I didn't get the cover letter, but I should have looked for it.

>
>> Again, I think this change is unnecessary. Please see my earlier reply [1].
>>
>> Best regards,
>> Andreas Hindborg
>>
>>
>> [1] https://lore.kernel.org/all/877c3cbdq2.fsf@kernel.org
>
> Yeah, saw that, but you said you are fine with it if I insist, and I'd
> like to have this to free up the timer_* namespace.

Yes. I did not hear any proper insisting till now though.

> Since I think we'd
> like to introduce the timer_container_of() in the future it would be
> nice to do this rename, as:
>
> 	$ git grep -w timer_container_of
>
> will have hrtimer related false positive hits in rust/ code, even
> though the namespaces are obviously independent.

Ok, I see. I'm not used to grepping like that, but I see how that can be
annoying.

>
> The Rust method is arguably a minor misnomer as well: you have
> work_container_of around struct work, but timer_container_of is around
> struct hrtimer?

Yes, you are right.

Feel free to take this through tip. Otherwise maybe Miguel can pick it
up in the rust PR for 6.15.


Acked-by: Andreas Hindborg <a.hindborg@kernel.org>


Best regards,
Andreas Hindborg



  reply	other threads:[~2025-05-12  9:29 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2025-05-07 17:53 [PATCH -v2 00/10] timers: Simple cleanup of the timer API namespace Ingo Molnar
2025-05-07 17:53 ` [PATCH 01/10] rust: Rename timer_container_of() to hrtimer_container_of() Ingo Molnar
2025-05-07 18:04   ` Andreas Hindborg
2025-05-07 19:38     ` Ingo Molnar
2025-05-12  9:29       ` Andreas Hindborg [this message]
2025-05-12 10:33         ` Andreas Hindborg
2025-05-15 17:23         ` [PATCH -v2 " Ingo Molnar
2025-05-07 17:53 ` [PATCH 02/10] timers: Rename init_timer_key() => timer_init_key() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] timers: Rename init_timer_key() as timer_init_key() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 03/10] timers: Rename init_timer_on_stack_key() => timer_init_key_on_stack() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] timers: Rename init_timer_on_stack_key() as timer_init_key_on_stack() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 04/10] timers: Rename __init_timer() => __timer_init() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] timers: Rename __init_timer() as __timer_init() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 05/10] timers: Rename __init_timer_on_stack() => __timer_init_on_stack() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] timers: Rename __init_timer_on_stack() as __timer_init_on_stack() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 06/10] timers: Rename NEXT_TIMER_MAX_DELTA => TIMER_NEXT_MAX_DELTA Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] timers: Rename NEXT_TIMER_MAX_DELTA as TIMER_NEXT_MAX_DELTA tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 07/10] timers: Rename init_timers() => timers_init() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] timers: Rename init_timers() as timers_init() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 08/10] treewide, timers: Rename try_to_del_timer_sync() => timer_delete_sync_try() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] treewide, timers: Rename try_to_del_timer_sync() as timer_delete_sync_try() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 09/10] treewide, timers: Rename destroy_timer_on_stack() => timer_destroy_on_stack() Ingo Molnar
2025-05-08 17:54   ` [tip: timers/cleanups] treewide, timers: Rename destroy_timer_on_stack() as timer_destroy_on_stack() tip-bot2 for Ingo Molnar
2025-05-07 17:53 ` [PATCH 10/10] treewide, timers: Rename from_timer() => timer_container_of() Ingo Molnar
2025-05-09  5:51   ` [PATCH -v2 " Ingo Molnar
2025-06-08  7:13     ` [tip: timers/cleanups] treewide, timers: Rename from_timer() to timer_container_of() tip-bot2 for Ingo Molnar
  -- strict thread matches above, loose matches on Subject: below --
2025-04-16  9:05 [PATCH -v2 00/10] timers: Simple cleanup of the timer API namespace Ingo Molnar
2025-04-16  9:05 ` [PATCH 01/10] rust: Rename timer_container_of() to hrtimer_container_of() Ingo Molnar
2025-04-16 13:29   ` Miguel Ojeda
2025-04-18  7:13     ` Ingo Molnar
2025-04-22 12:08   ` Andreas Hindborg

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87jz6mnpnm.fsf@kernel.org \
    --to=a.hindborg@kernel.org \
    --cc=alex.gaynor@gmail.com \
    --cc=anna-maria@linutronix.de \
    --cc=boqun.feng@gmail.com \
    --cc=frederic@kernel.org \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=lyude@redhat.com \
    --cc=mingo@kernel.org \
    --cc=ojeda@kernel.org \
    --cc=peterz@infradead.org \
    --cc=rust-for-linux@vger.kernel.org \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®