From: Chaoyi Chen <chaoyi.chen@rock-chips.com>
To: "Heiko Stübner" <heiko@sntech.de>,
"Chaoyi Chen" <kernel@airkyi.com>,
"Alexey Charkov" <alchark@gmail.com>
Cc: Rob Herring <robh@kernel.org>,
Krzysztof Kozlowski <krzk+dt@kernel.org>,
Conor Dooley <conor+dt@kernel.org>,
Quentin Schulz <quentin.schulz@cherry.de>,
Kever Yang <kever.yang@rock-chips.com>,
Jonas Karlman <jonas@kwiboo.se>, John Clark <inindev@gmail.com>,
FUKAUMI Naoki <naoki@radxa.com>,
Jimmy Hon <honyuenkwun@gmail.com>,
Dragan Simic <dsimic@manjaro.org>,
Michael Riesch <michael.riesch@collabora.com>,
Peter Robinson <pbrobinson@gmail.com>,
Shawn Lin <shawn.lin@rock-chips.com>,
Sebastian Reichel <sebastian.reichel@collabora.com>,
Andy Yan <andy.yan@rock-chips.com>,
devicetree@vger.kernel.org, linux-arm-kernel@lists.infradead.org,
linux-rockchip@lists.infradead.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v2 2/2] arm64: dts: rockchip: Add rk3576 evb2 board
Date: Wed, 7 Jan 2026 17:57:48 +0800 [thread overview]
Message-ID: <881548f1-7dd9-40bb-9267-e5a03fb97820@rock-chips.com> (raw)
In-Reply-To: <2437891.BjyWNHgNrj@diego>
Hi Heiko,
On 1/7/2026 4:21 PM, Heiko Stübner wrote:
> Am Mittwoch, 7. Januar 2026, 08:56:04 Mitteleuropäische Normalzeit schrieb Alexey Charkov:
>> Hi Chaoyi,
>>
>> On Wed, Jan 7, 2026 at 11:04 AM Chaoyi Chen <kernel@airkyi.com> wrote:
>>>
>>> From: Chaoyi Chen <chaoyi.chen@rock-chips.com>
>>>
>>> General features for rk3576 evb2 board:
>>> - Rockchip RK3576
>>> - LPDDR4/4X
>>> - eMMC5.1
>>> - RK806-2x2pcs + DiscretePower
>>> - 1x HDMI2.1 TX / HDMI2.0 RX
>>> - 1x full size DP1.4 TX (Only 2 Lanes)
>>> - 2x 10/100/1000M Ethernet
>>> - 5x SATA3.0 7Pin Slot
>>> - 2x USB3.2 Gen1 Host
>>> - 3x USB2.0 Host
>>> - WIFI/BT
>>> - ...
>>>
>>> Tested with eMMC/SDMMC/HDMI/USB/Ethernet/WIFI/BT module.
>>>
>>> Signed-off-by: Chaoyi Chen <chaoyi.chen@rock-chips.com>
>
> [...]
>
>>> + vbus5v0_typec: regulator-vbus5v0-typec {
>>> + compatible = "regulator-fixed";
>>> + regulator-name = "vbus5v0_typec";
>>
>> This might better be renamed, given that last time you mentioned this
>> board doesn't have a Type-C connector. Perhaps regulator-vbus5v0-otg?
>
> Alternatively a comment above it.
>
> I.e. regulator-naming should always follow the naming used in the
> schematics, so that it gets easier to reference between schematics
> and devicetree.
>
Thanks for the explanation. I will fix this in v3.
>
>>> + regulator-min-microvolt = <5000000>;
>>> + regulator-max-microvolt = <5000000>;
>>> + enable-active-high;
>>> + gpio = <&gpio0 RK_PD1 GPIO_ACTIVE_HIGH>;
>>> + vin-supply = <&vcc5v0_device>;
>>> + pinctrl-names = "default";
>>> + pinctrl-0 = <&usb_otg0_pwren>;
>>> + };
>>> +
>>> + vcc12v_dcin: regulator-vcc12v-dcin {
>>> + compatible = "regulator-fixed";
>>> + regulator-name = "vcc12v_dcin";
>>> + regulator-always-on;
>>> + regulator-boot-on;
>>> + regulator-min-microvolt = <12000000>;
>>> + regulator-max-microvolt = <12000000>;
>>> + };
>>> +
>>> + vcc1v2_ufs_vccq_s0: regulator-vcc1v2-ufs-vccq-s0 {
>>> + compatible = "regulator-fixed";
>>> + regulator-name = "vcc1v2_ufs_vccq_s0";
>>> + regulator-boot-on;
>>> + regulator-always-on;
>>> + regulator-min-microvolt = <1200000>;
>>> + regulator-max-microvolt = <1200000>;
>>> + vin-supply = <&vcc_sys>;
>>> + };
>>> +
>>> + vcc1v8_ufs_vccq2_s0: regulator-vcc1v8-ufs-vccq2-s0 {
>>> + compatible = "regulator-fixed";
>>> + regulator-name = "vcc1v8_ufs_vccq2_s0";
>>> + regulator-boot-on;
>>> + regulator-always-on;
>>> + regulator-min-microvolt = <1800000>;
>>> + regulator-max-microvolt = <1800000>;
>>> + vin-supply = <&vcc_1v8_s3>;
>>> + };
>>> +
>>> + vcc3v3_hubreset: vcc3v3-hubreset {
>>> + compatible = "regulator-fixed";
>>> + regulator-name = "vcc3v3_hubreset";
>>> + regulator-boot-on;
>>> + regulator-always-on;
>>
>> If this regulator supplies a soldered-on discrete hub and is required
>> to power it up, won't it be better to describe the hub in the device
>> tree (see binding at [1]), make the regulator its supply, and perhaps
>> drop the "regulator-boot-on/regulator-always-on" annotation here,
>> letting the regulator core deal with its enabling instead?
>>
>> [1] https://github.com/torvalds/linux/blob/master/Documentation/devicetree/bindings/usb/usb-device.yaml
>
> Yep, it would be nicer to it this way.
> A live example can be found in the Rock 5 ITX [2]
>
> [2] https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/tree/arch/arm64/boot/dts/rockchip/rk3588-rock-5-itx.dts#n1266
Thank you for the great example. BTW the hub used here is CH344. It
looks like we need to add a new binding :)
>
>
> Heiko
>
>
>> [snip]
>>
>> Other than these, LGTM - thanks for addressing my comments from v1!
>> Feel free to include my:
>>
>> Reviewed-by: Alexey Charkov <alchark@gmail.com>
>>
>> Best regards,
>> Alexey
>>
>
>
>
>
>
>
--
Best,
Chaoyi
next prev parent reply other threads:[~2026-01-07 10:03 UTC|newest]
Thread overview: 26+ messages / expand[flat|nested] mbox.gz Atom feed top
2026-01-07 7:03 [PATCH v2 0/2] " Chaoyi Chen
2026-01-07 7:03 ` [PATCH v2 1/2] dt-bindings: arm: " Chaoyi Chen
2026-01-07 7:03 ` [PATCH v2 2/2] arm64: dts: " Chaoyi Chen
2026-01-07 7:56 ` Alexey Charkov
2026-01-07 8:21 ` Heiko Stübner
2026-01-07 9:57 ` Chaoyi Chen [this message]
2026-01-07 10:04 ` Chaoyi Chen
2026-01-07 14:54 ` Heiko Stübner
2026-01-07 14:56 ` Heiko Stübner
2026-01-07 9:50 ` Chaoyi Chen
2026-01-07 15:46 ` Quentin Schulz
2026-01-08 6:27 ` Chaoyi Chen
2026-01-08 10:07 ` Quentin Schulz
2026-01-08 10:41 ` Chaoyi Chen
2026-01-08 10:51 ` Quentin Schulz
2026-01-07 18:17 ` Andrew Lunn
2026-01-08 6:53 ` Alexey Charkov
2026-01-08 7:42 ` Chaoyi Chen
2026-01-08 8:01 ` Chaoyi Chen
2026-01-08 8:11 ` Alexey Charkov
2026-01-08 8:38 ` Chaoyi Chen
2026-01-08 8:49 ` Alexey Charkov
2026-01-08 9:02 ` Chaoyi Chen
2026-01-08 13:53 ` Andrew Lunn
2026-01-08 6:50 ` Andy Yan
2026-01-08 8:04 ` [PATCH " Chaoyi Chen
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=881548f1-7dd9-40bb-9267-e5a03fb97820@rock-chips.com \
--to=chaoyi.chen@rock-chips.com \
--cc=alchark@gmail.com \
--cc=andy.yan@rock-chips.com \
--cc=conor+dt@kernel.org \
--cc=devicetree@vger.kernel.org \
--cc=dsimic@manjaro.org \
--cc=heiko@sntech.de \
--cc=honyuenkwun@gmail.com \
--cc=inindev@gmail.com \
--cc=jonas@kwiboo.se \
--cc=kernel@airkyi.com \
--cc=kever.yang@rock-chips.com \
--cc=krzk+dt@kernel.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rockchip@lists.infradead.org \
--cc=michael.riesch@collabora.com \
--cc=naoki@radxa.com \
--cc=pbrobinson@gmail.com \
--cc=quentin.schulz@cherry.de \
--cc=robh@kernel.org \
--cc=sebastian.reichel@collabora.com \
--cc=shawn.lin@rock-chips.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®