* [PATCH] drm/amd/display: Use swap() to simplify code
@ 2025-08-06 12:41 Liao Yuanhong
2025-08-18 0:03 ` Alex Hung
0 siblings, 1 reply; 2+ messages in thread
From: Liao Yuanhong @ 2025-08-06 12:41 UTC (permalink / raw)
To: Austin Zheng, Jun Lei, Harry Wentland, Leo Li, Rodrigo Siqueira,
Alex Deucher, Christian König, David Airlie, Simona Vetter,
open list:AMD DISPLAY CORE, open list:DRM DRIVERS, open list
Cc: liaoyuanhong
Replace the original swapping logic with swap() to improve readability and
remove temporary variables
Signed-off-by: Liao Yuanhong <liaoyuanhong@vivo.com>
---
drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c b/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
index 5f1b49a50049..4cfe64aa8492 100644
--- a/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
+++ b/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
@@ -473,7 +473,6 @@ static void sort_pipes_for_splitting(struct dc_plane_pipe_pool *pipes)
{
bool sorted, swapped;
unsigned int cur_index;
- unsigned int temp;
int odm_slice_index;
for (odm_slice_index = 0; odm_slice_index < pipes->num_pipes_assigned_to_plane_for_odm_combine; odm_slice_index++) {
@@ -489,9 +488,8 @@ static void sort_pipes_for_splitting(struct dc_plane_pipe_pool *pipes)
swapped = false;
while (!sorted) {
if (pipes->pipes_assigned_to_plane[odm_slice_index][cur_index] > pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1]) {
- temp = pipes->pipes_assigned_to_plane[odm_slice_index][cur_index];
- pipes->pipes_assigned_to_plane[odm_slice_index][cur_index] = pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1];
- pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1] = temp;
+ swap(pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1],
+ pipes->pipes_assigned_to_plane[odm_slice_index][cur_index]);
swapped = true;
}
--
2.34.1
^ permalink raw reply [flat|nested] 2+ messages in thread
* Re: [PATCH] drm/amd/display: Use swap() to simplify code
2025-08-06 12:41 [PATCH] drm/amd/display: Use swap() to simplify code Liao Yuanhong
@ 2025-08-18 0:03 ` Alex Hung
0 siblings, 0 replies; 2+ messages in thread
From: Alex Hung @ 2025-08-18 0:03 UTC (permalink / raw)
To: Liao Yuanhong, Austin Zheng, Jun Lei, Harry Wentland, Leo Li,
Rodrigo Siqueira, Alex Deucher, Christian König,
David Airlie, Simona Vetter, open list:AMD DISPLAY CORE,
open list:DRM DRIVERS, open list
Reviewed-by: Alex Hung <alex.hung@amd.com>
On 8/6/25 06:41, Liao Yuanhong wrote:
> Replace the original swapping logic with swap() to improve readability and
> remove temporary variables
>
> Signed-off-by: Liao Yuanhong <liaoyuanhong@vivo.com>
> ---
> drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c | 6 ++----
> 1 file changed, 2 insertions(+), 4 deletions(-)
>
> diff --git a/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c b/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
> index 5f1b49a50049..4cfe64aa8492 100644
> --- a/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
> +++ b/drivers/gpu/drm/amd/display/dc/dml2/dml2_dc_resource_mgmt.c
> @@ -473,7 +473,6 @@ static void sort_pipes_for_splitting(struct dc_plane_pipe_pool *pipes)
> {
> bool sorted, swapped;
> unsigned int cur_index;
> - unsigned int temp;
> int odm_slice_index;
>
> for (odm_slice_index = 0; odm_slice_index < pipes->num_pipes_assigned_to_plane_for_odm_combine; odm_slice_index++) {
> @@ -489,9 +488,8 @@ static void sort_pipes_for_splitting(struct dc_plane_pipe_pool *pipes)
> swapped = false;
> while (!sorted) {
> if (pipes->pipes_assigned_to_plane[odm_slice_index][cur_index] > pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1]) {
> - temp = pipes->pipes_assigned_to_plane[odm_slice_index][cur_index];
> - pipes->pipes_assigned_to_plane[odm_slice_index][cur_index] = pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1];
> - pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1] = temp;
> + swap(pipes->pipes_assigned_to_plane[odm_slice_index][cur_index + 1],
> + pipes->pipes_assigned_to_plane[odm_slice_index][cur_index]);
>
> swapped = true;
> }
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2025-08-18 0:03 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-08-06 12:41 [PATCH] drm/amd/display: Use swap() to simplify code Liao Yuanhong
2025-08-18 0:03 ` Alex Hung
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®